[meta-rockchip][PATCH] u-boot: Replace virtual/trusted-firmware-a with trusted-firmware-a


Khem Raj
 



On Wed, Dec 8, 2021 at 6:03 PM Trevor Woerner <twoerner@...> wrote:
On Wed 2021-12-08 @ 01:15:26 PM, Khem Raj wrote:
> meta-arm has dropped exporting virtual/trusted-firmware-a and expects
> direct use of trusted-firmware-a on depends sections
>
> Signed-off-by: Khem Raj <raj.khem@...>
> ---
>  recipes-bsp/u-boot/u-boot%.bbappend | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Oops, looks like we both noticed this at about the same time.
Since both our patches are identical, I simply added your SoB line.

Cool



Thanks!


Trevor Woerner
 

On Wed 2021-12-08 @ 01:15:26 PM, Khem Raj wrote:
meta-arm has dropped exporting virtual/trusted-firmware-a and expects
direct use of trusted-firmware-a on depends sections

Signed-off-by: Khem Raj <raj.khem@...>
---
recipes-bsp/u-boot/u-boot%.bbappend | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Oops, looks like we both noticed this at about the same time.
Since both our patches are identical, I simply added your SoB line.

Thanks!


Khem Raj
 

meta-arm has dropped exporting virtual/trusted-firmware-a and expects
direct use of trusted-firmware-a on depends sections

Signed-off-by: Khem Raj <raj.khem@...>
---
recipes-bsp/u-boot/u-boot%.bbappend | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/recipes-bsp/u-boot/u-boot%.bbappend b/recipes-bsp/u-boot/u-boot%.bbappend
index 7916e45..9108a36 100644
--- a/recipes-bsp/u-boot/u-boot%.bbappend
+++ b/recipes-bsp/u-boot/u-boot%.bbappend
@@ -8,9 +8,9 @@ do_compile:append:rock2-square () {
ATF_DEPENDS ??= ""

EXTRA_OEMAKE:append:rk3399 = " BL31=${DEPLOY_DIR_IMAGE}/bl31-rk3399.elf"
-ATF_DEPENDS:rk3399 = " virtual/trusted-firmware-a:do_deploy"
+ATF_DEPENDS:rk3399 = " trusted-firmware-a:do_deploy"
EXTRA_OEMAKE:append:rk3328 = " BL31=${DEPLOY_DIR_IMAGE}/bl31-rk3328.elf"
-ATF_DEPENDS:rk3328 = " virtual/trusted-firmware-a:do_deploy"
+ATF_DEPENDS:rk3328 = " trusted-firmware-a:do_deploy"

do_compile[depends] .= "${ATF_DEPENDS}"

--
2.34.1