building mbpoll


Josef Holzmayr
 

(re-adding list)

Am 27.08.2021 um 11:17 schrieb Ivan Riabtsov:
maybe mbpoll is not cloned? I found the custom-rts.c file on the
mbpoll website and try to search for it in the build directory, but I
can't find anything
my mbpoll_1.4.11.bb file:
SUMMARY = "bitbake-layers recipe"
DESCRIPTION = "mbpoll recipe"
LICENSE = "CLOSED"
SRC_URI = "git://github.com/epsilonrt/mbpoll"
SRCREV = "2bf602817370000e69221eb50c4ece813d10c0b4"
DEPENDS = "libmodbus"
S = "${WORKDIR}/git"
inherit pkgconfig cmake
again, any particular reason why you're poking the recipe by hand instead of just using devtool (which perfectly works in this case)? it would even give you a good start on the licenses, as well as not having missed the inherits.

Greetz


Josef Holzmayr
 

Howdy!

Am 27.08.2021 um 10:10 schrieb Ivan Riabtsov:
Hi All. i need to build mbpoll git://github.com/epsilonrt/mbpoll
I was created layer:
ivr@home-machine:~/work/yocto_orig/sources/meta-mbpoll/recipes-mbpoll/mbpoll
$ cat mbpoll_1.4.11.bb
SUMMARY = "bitbake-layers recipe"
DESCRIPTION = "mbpoll recipe"
LICENSE = "CLOSED"
SRC_URI = "git://github.com/epsilonrt/mbpoll"
SRCREV = "2b385d85d919138cefe79870c87c60eaa8b0d19c"
DEPENDS = "libmodbus"
if thats all of the recipe, then nothing will be built. you probably want to include at least the class for the buildsystem that you need, for example autotools, cmake, meson...

usually devtool is quite good at guessing that, so i'd suggest to start out with "devtool add"

Greetz

i was run:
rm -rf ./build/tmp ./build/sstate-cache ./build/deploy
and
bitbake mbpoll
i am trying to search for a package
ivr@home-machine:~/work/yocto_orig/build
$ find . -name 'mbpoll*.ipk'
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
but i have only debug and dev packages, not simple mbpoll_version.ipk
i try to run:
bitbake -c clean mbpoll --force
and
bitbake mbpoll --force
but the task is done in a 1 second and
$ find . -name 'mbpoll*.ipk'
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
found nothing
please tell me what am I doing wrong? Maybe I created the layer incorrectly?


Ivan Riabtsov <ivriabtsov@...>
 

Hi All. i need to build mbpoll git://github.com/epsilonrt/mbpoll
I was created layer:

ivr@home-machine:~/work/yocto_orig/sources/meta-mbpoll/recipes-mbpoll/mbpoll
$ cat mbpoll_1.4.11.bb
SUMMARY = "bitbake-layers recipe"
DESCRIPTION = "mbpoll recipe"
LICENSE = "CLOSED"

SRC_URI = "git://github.com/epsilonrt/mbpoll"
SRCREV = "2b385d85d919138cefe79870c87c60eaa8b0d19c"

DEPENDS = "libmodbus"

i was run:
rm -rf ./build/tmp ./build/sstate-cache ./build/deploy
and
bitbake mbpoll

i am trying to search for a package

ivr@home-machine:~/work/yocto_orig/build
$ find . -name 'mbpoll*.ipk'
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk

but i have only debug and dev packages, not simple mbpoll_version.ipk

i try to run:
bitbake -c clean mbpoll --force
and
bitbake mbpoll --force
but the task is done in a 1 second and

$ find . -name 'mbpoll*.ipk'
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./tmp/work/cortexa7t2hf-neon-vfpv4-phytec-linux-gnueabi/mbpoll/1.4.11-r0/deploy-ipks/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dev_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk
./deploy/ipk/cortexa7t2hf-neon-vfpv4/mbpoll-dbg_1.4.11-r0_cortexa7t2hf-neon-vfpv4.ipk

found nothing

please tell me what am I doing wrong? Maybe I created the layer incorrectly?