Install SDK with yocto


daniel_herrmann22@...
 

Hi,
I am new to yocto and have some problems by installing a SDK with yocto for AArch64.
The SDK you can find here: https://www.baumer.com/ch/de/produktubersicht/industriekameras-bildverarbeitung/software/baumer-gapi-sdk/linux-arm/c/14178

It comes with a debian package and a tar.gz file.
The tar is like this:
include/sdk-folder/header-files
lib/sdk-folder/lib-files
etc..


Question 1: What is the best way to install this with yocto ?

1. I tried to install the deb package like this with no success:

DEPENDS += " dpkg-native "

SRC_URI += " \
    file://baumer-gapi-sdk-linux-v2.11.0-gcc-5.4-aarch64.deb.zip \
"

do_install_append() {
    touch ${STAGING_DIR_NATIVE}/var/lib/dpkg/status
    ${STAGING_BINDIR_NATIVE}/dpkg --instdir=${D}/ \
    --admindir=${STAGING_DIR_NATIVE}/var/lib/dpkg/ \
     -i ${WORKDIR}/baumer-gapi-sdk-linux-v2.11.0-gcc-5.4-aarch64.deb
}
Question 2: Is this a good way with dpkg, when host and target architecture are different ?


2. I tried to install the tar.gz file like this also with no sucess:

# Use local tarball
SRC_URI = "file://${BP}.tar.gz"

S = "${WORKDIR}"

inherit bin_package

#For Error: libraries are added by mutiple providers
EXCLUDE_FROM_SHLIBS = "1"

#For Warning: was already stripped (precompiled sources)
INSANE_SKIP_${PN} = "ldflags"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
INHIBIT_PACKAGE_STRIP = "1"

do_install() {
    cp -r "${WORKDIR}/include ${D}/include
    ...  
}
The way I thought here, is to extract and copy each file to the target inside do_install..

It would be very helpful when you could give me some hints for the best way to installing this package
Thanks


Robert Berger
 

Hi,

After you download e.g. the tarball, you'll find an installation guide inside.

It says:

OpenSUSE 13.1 / 42.3
Ubuntu ® 14.04 / 16.04
Fedora 26 / 27
Debian 8.10 / 9.3

So I am not sure why you assume that this should work out of the box/at all with the Yocto Project.

If you really want it I suggest to talk to Baumer about it and I am happy to help you and them with the integration.

Regards,

Robert