Yocto build isnot Booting up on board zc702 #yocto #linux #gatesgarth


Leon Woestenberg
 

Hello,


i have tried to build yocto image. And it compiled successfully without any error but when am trying to BOOT them it didnt prompt any error message
what should i do to BOOT my yocto build image on zc702 board
What is your output from the ZC702 (USB) serial console?


I had similar issue on ZCU102 and debugged my issue:

"the U-Boot not showing anything I have debugged to be an issue where
DEVICE_TREE does not propagate from the BitBake recipe into the U-Boot
build (both for upstream and Xilinx). I have reported this on
meta-xilinx but will make it a separate bug report."

I can imagine the same problem would occur on ZC702 (single-core Zynq).

I have posted a few messages with meta-xilinx in the subject on how I
had to bring Yocto to the ZCU102.

Regards,

Leon.


--
Leon Woestenberg
leon@sidebranch.com
M: +31 6 472 30 372

Sidebranch Embedded Systems
Eindhoven, The Netherlands
http://www.sidebranch.com



On Tue, Jun 29, 2021 at 8:02 AM shoaib akhtar
<m.shoaibakhtar98@gmail.com> wrote:




i have tried to build yocto image. And it compiled successfully without any error but when am trying to BOOT them it didnt prompt any error message my BBlayer.conf is shown below

# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
POKY_BBLAYERS_CONF_VERSION = "2"

BBPATH = "${TOPDIR}"
BBFILES ?= ""

BBLAYERS ?= " \
/media/vmnrtc/Drive/poky/meta \
/media/vmnrtc/Drive/poky/meta-poky \
/media/vmnrtc/Drive/poky/meta-yocto-bsp \
/media/vmnrtc/Drive/poky/meta-xilinx/meta-xilinx-bsp \
/media/vmnrtc/Drive/poky/meta-openembedded/meta-oe \
/media/vmnrtc/Drive/poky/meta-openembedded/meta-python \
/media/vmnrtc/Drive/poky/meta-xilinx/meta-xilinx-standalone \
/media/vmnrtc/Drive/poky/meta-xilinx-tools \
/media/vmnrtc/Drive/poky/build/meta-networking \
"

MY files in image directories


boot.bin
boot.bin-zc702-zynq7
boot.bin-zc702-zynq7-v2020.01-xilinx-v2020.2+gitAUTOINC+bb4660c33a-r0
boot.scr
core-image-minimal-zc702-zynq7-20210629031233.qemuboot.conf
core-image-minimal-zc702-zynq7-20210629031233.rootfs.cpio
core-image-minimal-zc702-zynq7-20210629031233.rootfs.cpio.gz.u-boot
core-image-minimal-zc702-zynq7-20210629031233.rootfs.manifest
core-image-minimal-zc702-zynq7-20210629031233.rootfs.tar.gz
core-image-minimal-zc702-zynq7-20210629031233.testdata.json
core-image-minimal-zc702-zynq7.cpio
core-image-minimal-zc702-zynq7.cpio.gz.u-boot
core-image-minimal-zc702-zynq7.manifest
core-image-minimal-zc702-zynq7.qemuboot.conf
core-image-minimal-zc702-zynq7.tar.gz
core-image-minimal-zc702-zynq7.testdata.json
modules--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.tgz
modules-zc702-zynq7.tgz
pxeboot
pxelinux.cfg
u-boot.elf
u-boot.img
u-boot-xlnx-AUTOINC+bb4660c33a.elf
u-boot-xlnx-initial-env
u-boot-xlnx-initial-env-zc702-zynq7
u-boot-xlnx-initial-env-zc702-zynq7-v2020.01-xilinx-v2020.2+gitAUTOINC+bb4660c33a-r0
u-boot-zc702-zynq7.elf
u-boot-zc702-zynq7.img
u-boot-zc702-zynq7-v2020.01-xilinx-v2020.2+gitAUTOINC+bb4660c33a-r0.img
u-boot-zynq-scr--1.0-r0.scr
uEnv.txt
uImage
uImage--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.bin
uImage-zc702-zynq7.bin
zImage
zImage--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.bin
zImage-zc702-zynq7.bin
zynq-zc702--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.dtb
zynq-zc702.dtb
zynq-zc702-zc702-zynq7.dtb



what should i do to BOOT my yocto build image on zc702 board




shoaib akhtar
 

i have tried to build yocto image.  And it compiled successfully without any error but when am trying to BOOT them it didnt prompt any error message my BBlayer.conf is shown below
 
# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
POKY_BBLAYERS_CONF_VERSION = "2"

BBPATH = "${TOPDIR}"
BBFILES ?= ""

BBLAYERS ?= " \
  /media/vmnrtc/Drive/poky/meta \
  /media/vmnrtc/Drive/poky/meta-poky \
  /media/vmnrtc/Drive/poky/meta-yocto-bsp \
  /media/vmnrtc/Drive/poky/meta-xilinx/meta-xilinx-bsp \
  /media/vmnrtc/Drive/poky/meta-openembedded/meta-oe \
  /media/vmnrtc/Drive/poky/meta-openembedded/meta-python \
  /media/vmnrtc/Drive/poky/meta-xilinx/meta-xilinx-standalone \
  /media/vmnrtc/Drive/poky/meta-xilinx-tools \
  /media/vmnrtc/Drive/poky/build/meta-networking \
  "

MY files in image directories
 
 
boot.bin
boot.bin-zc702-zynq7
boot.bin-zc702-zynq7-v2020.01-xilinx-v2020.2+gitAUTOINC+bb4660c33a-r0
boot.scr
core-image-minimal-zc702-zynq7-20210629031233.qemuboot.conf
core-image-minimal-zc702-zynq7-20210629031233.rootfs.cpio
core-image-minimal-zc702-zynq7-20210629031233.rootfs.cpio.gz.u-boot
core-image-minimal-zc702-zynq7-20210629031233.rootfs.manifest
core-image-minimal-zc702-zynq7-20210629031233.rootfs.tar.gz
core-image-minimal-zc702-zynq7-20210629031233.testdata.json
core-image-minimal-zc702-zynq7.cpio
core-image-minimal-zc702-zynq7.cpio.gz.u-boot
core-image-minimal-zc702-zynq7.manifest
core-image-minimal-zc702-zynq7.qemuboot.conf
core-image-minimal-zc702-zynq7.tar.gz
core-image-minimal-zc702-zynq7.testdata.json
modules--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.tgz
modules-zc702-zynq7.tgz
pxeboot
pxelinux.cfg
u-boot.elf
u-boot.img
u-boot-xlnx-AUTOINC+bb4660c33a.elf
u-boot-xlnx-initial-env
u-boot-xlnx-initial-env-zc702-zynq7
u-boot-xlnx-initial-env-zc702-zynq7-v2020.01-xilinx-v2020.2+gitAUTOINC+bb4660c33a-r0
u-boot-zc702-zynq7.elf
u-boot-zc702-zynq7.img
u-boot-zc702-zynq7-v2020.01-xilinx-v2020.2+gitAUTOINC+bb4660c33a-r0.img
u-boot-zynq-scr--1.0-r0.scr
uEnv.txt
uImage
uImage--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.bin
uImage-zc702-zynq7.bin
zImage
zImage--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.bin
zImage-zc702-zynq7.bin
zynq-zc702--5.4+git0+62ea514294-r0-zc702-zynq7-20210622034511.dtb
zynq-zc702.dtb
zynq-zc702-zc702-zynq7.dtb
 
 
 
what should i do to BOOT my yocto build image on zc702 board