[meta-intel]: support for NUC11


simon
 

Hi all,

I'm having trouble figuring out how to fix my issues with the new intel NUC gen 11 (NUC11TNBi5).

At the moment I'm testing with the following meta-layer
poky (hardknott)
meta-openembedded (hardknott)
meta-intel (master)
meta-qt5 (hardknott)

I'm currently using EGLFS to display our Qt-QML GUI

My first issue is with the our GUI, it is launching as expected but we barely have 1 fps

- There's a warning about not finding the IRIS driver:
MESA_LOADER: failed to open iris: /usr/lib/dri/iris_dri.so: cannot open shared object file: No such file or directory
failed to load driver: iris

But from what I was able to understand, I was expecting it would be available with mesa 21.0.3 since I've seen some commit about fixing issue with it in the change logs.

I've tried to force the driver to both i965 and i915 but I either got a warning that this GEN cannot use it or still got the same fps.
Am I right to assume that it goes to a default driver that uses the CPU instead of the GPU?

My second issue is with the nvme slot, it does not detect the partition on the SSD, but it does when I use a NVME to USB adaptor

- There's a few warning about ACPI bios error AE_NOT_FOUND too, and again with my little knowledge I thought this would have been fixed with the most recent update in master with the new microcode since the Core gen 11 was added as new device.
But again, I'm not entirely sure that I'm doing the right thing to update the microcode. I've installed manually the microcode.cpio in /etc/firmware/intel-ucode/

The ouput of "dmesg | grep microcode":
microcode: sig=0x806c1, pf=0x80, revision=0x72
microcode: Microcode Update Driver: v2.2.

I don't know if I'm too early to be using the latest NUC11, any information about when it should be supported would be very appreciated.

I'm willing to help but my knowledge is pretty limited so I might need assistance.

thanks a lot

Simon


Alexander Kanavin
 

On Wed, 16 Jun 2021 at 16:58, simon <simon@...> wrote:
- There's a warning about not finding the IRIS driver:
MESA_LOADER: failed to open iris: /usr/lib/dri/iris_dri.so: cannot open
shared object file: No such file or directory
failed to load driver: iris

But from what I was able to understand, I was expecting it would be
available with mesa 21.0.3 since I've seen some commit about fixing
issue with it in the change logs.

I've tried to force the driver to both i965 and i915 but I either got a
warning that this GEN cannot use it or still got the same fps.
Am I right to assume that it goes to a default driver that uses the CPU
instead of the GPU?

Hello Simon,

I honestly don't know how Intel folks have overlooked this, but mesa in yocto not only does not enable iris, the mesa recipe does not even have an option to enable it.

However, it should be pretty easy to add. Please take a look at poky/meta/recipes-graphics/mesa/mesa.inc, specificially any lines that mention GALLIUMDRIVERS and matching PACKAGECONFIG,
and you should be able to add iris there, and rebuild your image. Then you can submit your first patch to yocto via oe-core mailing list ;)

Alex


simon
 

On 2021-06-16 1:24 pm, Alexander Kanavin wrote:

On Wed, 16 Jun 2021 at 16:58, simon <simon@...> wrote:
- There's a warning about not finding the IRIS driver:
MESA_LOADER: failed to open iris: /usr/lib/dri/iris_dri.so: cannot open
shared object file: No such file or directory
failed to load driver: iris

But from what I was able to understand, I was expecting it would be
available with mesa 21.0.3 since I've seen some commit about fixing
issue with it in the change logs.

I've tried to force the driver to both i965 and i915 but I either got a
warning that this GEN cannot use it or still got the same fps.
Am I right to assume that it goes to a default driver that uses the CPU
instead of the GPU?

Hello Simon,
 
I honestly don't know how Intel folks have overlooked this, but mesa in yocto not only does not enable iris, the mesa recipe does not even have an option to enable it.
 
However, it should be pretty easy to add. Please take a look at poky/meta/recipes-graphics/mesa/mesa.inc, specificially any lines that mention GALLIUMDRIVERS and matching PACKAGECONFIG,
and you should be able to add iris there, and rebuild your image. Then you can submit your first patch to yocto via oe-core mailing list ;)
 
Alex


Hello Alex,

I was able to fix the iris driver issue with the following added to mesa.inc

GALLIUMDRIVERS_append = "${@bb.utils.contains('PACKAGECONFIG', 'iris', ',iris', '', d)}"

I will look into sending the patch

thanks a lot for your help

Simon