[External] [yocto] Bitbake failure

Randy MacLeod

On 2021-06-10 6:33 a.m., Cris Scott wrote:

It is still a problem and I have tried everything you suggested.  I am building with Ubuntu 20.4 and that seems to be the issue.

Lots of people use 20.04 so it seems odd that you'd have a problem specific to that host.


I have moved on from this, so will no longer require any information.  The problem has been turned over to someone new.

Okay, please encourage them to reply on this thread.

We may not always respond right away but there is usually
someone reading things and in my case, I'll respond eventually.




From: Randy MacLeod <randy.macleod@...>
Sent: Tuesday, June 8, 2021 8:27 PM
To: Cris Scott <cscott@...>; yocto@...
Subject: Re: [External] [yocto] Bitbake failure


On 2021-05-31 6:12 p.m., Cris Scott wrote:

Not sure who to ask about this.

Using https://push.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes-extended/lighttpd/lighttpd_1.4.59.bb to build lighttpd, bitbake fails, and I receive tons of messages that look like:


ERROR: lighttpd-1.4.59-r0 do_package_qa: QA Issue: /usr/lib/mod_staticfile.so contained in package lighttpd-module-staticfile requires libc.so.6(GLIBC_2.4), but no providers found in RDEPENDS_lighttpd-module-staticfile? [file-rdeps]



Can someone point me in the right direction to resolve this?

Hi Cris,

It's been a while is this still a problem for you?
If not, how did you fix it?


Can you reproduce the error with poky? git://git.yoctoproject.org/poky

What release/commit are you using?

Does it happen when you just run: bitbake lighttpd ?

Does it happen if you mv your sstate-cache (tmp*) directories aside
and do a rebuild?

What's in your local.conf?

For completeness, what is your build host distro (I doubt it matters here.).


I built poky from:
7f3c996d30 (HEAD -> master, origin/master, origin/HEAD) lttng-tools: upgrade 2.12.3 -> 2.12.4

on an Ubu-18.04.3 builder, and both:
$ bitbake lighttpd and
$ bitbake core-image-minimal

worked fine with:

grep -v "^$" conf/local.conf  | grep -v "^#"
MACHINE ??= "qemux86-64"
DISTRO ?= "poky"
PACKAGE_CLASSES ?= "package_rpm"
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
USER_CLASSES ?= "buildstats image-prelink"
    STOPTASKS,${DL_DIR},1G,100K \
    STOPTASKS,/tmp,100M,100K \
    ABORT,${TMPDIR},100M,1K \
    ABORT,${DL_DIR},100M,1K \
    ABORT,${SSTATE_DIR},100M,1K \
PACKAGECONFIG_append_pn-qemu-system-native = " sdl"
IMAGE_INSTALL_append = "lighttpd"








# Randy MacLeod
# Wind River Linux


This email has been scanned for spam and viruses by Proofpoint Essentials. Click here to report this email as spam.

# Randy MacLeod
# Wind River Linux