need Sysvinit as system manager in Rocko Version #rocko


rohit jadhav
 

I have created rootfs with Rocko yocto version.

I need sysyvinit as system manager instead of Systemd.

I have tried with following in local.conf

DISTRO_FEATURES_append = " sysvinit"

VIRTUAL-RUNTIME_init_manager = "sysvinit"

VIRTUAL-RUNTIME_initscripts = "initscripts"

It created run-level folder like rcS and rc0.d to rc6.d. but did not created inittab file in /etc .

And after booting it rootfs boots up with systemd only
root@imx6ull14x14evk:~# ps -p1 | grep "init\|upstart\|systemd"
    1 ?        00:00:07 systemd
I need init as system manager . can you please guide me in this regard.

Thank you

Regards
Rohit


Khem Raj
 

On 4/13/21 3:02 AM, rohitbjadhav1@gmail.com wrote:
I have created rootfs with Rocko yocto version.
I need sysyvinit as system manager instead of Systemd.
I have tried with following in local.conf
DISTRO_FEATURES_append = " sysvinit"
remove systemd from DISTRO_FEATURES as well.

DISTRO_FEATURES_remove = "sytemd"

VIRTUAL-RUNTIME_init_manager = "sysvinit"
VIRTUAL-RUNTIME_initscripts = "initscripts"
It created run-level folder like rcS and rc0.d to rc6.d. but did not created inittab file in /etc .
And after booting it rootfs boots up with systemd only
root@imx6ull14x14evk:~# ps -p1 | grep "init\|upstart\|systemd"
    1 ?        00:00:07 systemd
I need init as system manager . can you please guide me in this regard.
Thank you
Regards
Rohit


rohit jadhav
 

Hi Khem Raj,
Thanks you for your valuable feedback.
I have tried with your suggestions.
but observed with following error:
ERROR: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-qt5-webengine.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (systemd) matches the entries enabled in DISTRO_FEATURES
ERROR: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-qt5-demos.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (systemd) matches the entries enabled in DISTRO_FEATURES
ERROR: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-imx-erpc.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (systemd) matches the entries enabled in DISTRO_FEATURES
ERROR: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-fsl-tools-gpu-external.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (systemd) matches the entries enabled in DISTRO_FEATURES
ERROR: Failed to parse recipe: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-imx-erpc.bb
ERROR: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-fsl-optee-imx.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (systemd) matches the entries enabled in DISTRO_FEATURES
ERROR: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-fsl-pulseaudio.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (systemd) matches the entries enabled in DISTRO_FEATURES
ERROR: /home/tel/imx_yocto_bsp/sources/meta-fsl-bsp-release/imx/meta-sdk/recipes-fsl/packagegroup/packagegroup-fsl-tools-audio.bb: Please ensure that your setting of VIRTUAL-RUNTIME_init_manager (systemd) matches the entries enabled in DISTRO_FEATURES

Thanks and regards
Rohit J


On Tue, Apr 13, 2021 at 8:58 PM Khem Raj <raj.khem@...> wrote:


On 4/13/21 3:02 AM, rohitbjadhav1@... wrote:
> I have created rootfs with Rocko yocto version.
>
> I need sysyvinit as system manager instead of Systemd.
>
> I have tried with following in local.conf
>
> DISTRO_FEATURES_append = " sysvinit"

remove systemd from DISTRO_FEATURES as well.

DISTRO_FEATURES_remove = "sytemd"

>
> VIRTUAL-RUNTIME_init_manager = "sysvinit"
>
> VIRTUAL-RUNTIME_initscripts = "initscripts"
>
> It created run-level folder like rcS and rc0.d to rc6.d. but did not
> created inittab file in /etc .
>
> And after booting it rootfs boots up with systemd only
> root@imx6ull14x14evk:~# ps -p1 | grep "init\|upstart\|systemd"
>      1 ?        00:00:07 systemd
> I need init as system manager . can you please guide me in this regard.
>
> Thank you
>
> Regards
> Rohit
>
>
>
>
>