curl certificate error


Mauro Ziliani
 

Hi all
I try to download the file

https://github.com/google/googletest/archive/release-1.8.0.tar.gz

with curl -L inside a devshell of a recipe


I get this error


curl: (77) error setting certificate verify locations:
  CAfile: /Sources/softfx/krogoth/softfx-build/tmp/sysroots/x86_64-linux/etc/ssl/certs/ca-certificates.crt
  CApath: none


I miss some dependency?


I'm working on an old Krogoth


Thanks all

  MZ


Quentin Schulz
 

Hi Mauro,

On Wed, Feb 10, 2021 at 01:11:07PM +0100, Mauro Ziliani wrote:
Hi all
I try to download the file

https://github.com/google/googletest/archive/release-1.8.0.tar.gz

with curl -L inside a devshell of a recipe


I get this error


curl: (77) error setting certificate verify locations:
  CAfile: /Sources/softfx/krogoth/softfx-build/tmp/sysroots/x86_64-linux/etc/ssl/certs/ca-certificates.crt
  CApath: none
Missing ca-certificates-native somewhere in the dependency chain. I
honestly thought curl-native would bring it, but does not seem so. I
personally added ca-certificates-native to the DEPENDS of the recipe
needing curl-native for a quick fix since I'm in the middle of an
upgrade and will not use krogoth anymore.

Cheers,
Quentin
--
StreamUnlimited Engineering GmbH
High Tech Campus Vienna, Gutheil-Schoder-Gasse 10, 1100 Vienna, Austria
Fax: +43 1 667 20 02 4401
quentin.schulz@streamunlimited.com, www.streamunlimited.com


Mauro Ziliani
 

Thank you.

I have included the dependencies, but curl miss the CAfile.

I have to fix the right full path by CURL_CA_BUNDLE in the recipe which uses curl-native


I have changed TMP variabile in conf/local.conf

Now TMP:=mytmp  (the default value was tmp)


curl looks for CAFile in

/home/mauro/yocto/krogoth/bin/tmp/sysroot/x86_64/etc/ssl/certs/ca-certificates.crt

while the file i in

/home/mauro/yocto/krogoth/bin/mytmp/sysroot/x86_64/etc/ssl/certs/ca-certificates.crt


In the recipe I put


CURL_CA_BUNDLE=${STAGING_DIR_NATIVE}/etc/ssl/certs/ca-certificates.crt

export CURL_CA_BUNDLE


Now curl works fine


Thanks again

  MZ


Il 10/02/21 13:15, Quentin Schulz ha scritto:

Hi Mauro,

On Wed, Feb 10, 2021 at 01:11:07PM +0100, Mauro Ziliani wrote:
Hi all
I try to download the file

https://github.com/google/googletest/archive/release-1.8.0.tar.gz

with curl -L inside a devshell of a recipe


I get this error


curl: (77) error setting certificate verify locations:
  CAfile: /Sources/softfx/krogoth/softfx-build/tmp/sysroots/x86_64-linux/etc/ssl/certs/ca-certificates.crt
  CApath: none

Missing ca-certificates-native somewhere in the dependency chain. I
honestly thought curl-native would bring it, but does not seem so. I
personally added ca-certificates-native to the DEPENDS of the recipe
needing curl-native for a quick fix since I'm in the middle of an
upgrade and will not use krogoth anymore.

Cheers,
Quentin