chpasswd not working in yocto-2019


Raghu Icecraft Software Trainings
 

Hello,
I have upgraded my kernel poky to 2019.1 version, here i am unable to find chpasswd utility because of which i am unable to set password to my root-user.
Can you please let me know if the chpasswd utility has been changed or modified please.


 

On Mon, 28 Dec 2020 at 09:44, Raghu Icecraft Software Trainings
<raghu.icecraft@...> wrote:

Hello,
I have upgraded my kernel poky to 2019.1 version, here i am unable to find chpasswd utility because of which i am unable to set password to my root-user.
Can you please let me know if the chpasswd utility has been changed or modified please.
Yocto Project doesn't have a version "2019.1", see
https://wiki.yoctoproject.org/wiki/Releases.

I guess you're using a vendor supplied BSP or SDK with that version
number. Could you provide the Yocto Project version number and the
layers in use, or at least give some more info on where your "2019.1"
release is from.

Thanks,

--
Paul Barker
Konsulko Group


Raghu Icecraft Software Trainings
 

Paul,
Thanks for the reply.
I am using Xilinx-SDK based : Linux version 4.19.0-rt1-xilinx-v2019.1

Can you please let me know how to verify the yocto version running on target.

Thanks,
Raghu 

On Mon, Dec 28, 2020 at 5:31 PM Paul Barker <pbarker@...> wrote:
On Mon, 28 Dec 2020 at 09:44, Raghu Icecraft Software Trainings
<raghu.icecraft@...> wrote:
>
> Hello,
> I have upgraded my kernel poky to 2019.1 version, here i am unable to find chpasswd utility because of which i am unable to set password to my root-user.
> Can you please let me know if the chpasswd utility has been changed or modified please.

Yocto Project doesn't have a version "2019.1", see
https://wiki.yoctoproject.org/wiki/Releases.

I guess you're using a vendor supplied BSP or SDK with that version
number. Could you provide the Yocto Project version number and the
layers in use, or at least give some more info on where your "2019.1"
release is from.

Thanks,

--
Paul Barker
Konsulko Group


Philip Balister
 

On 12/28/20 7:33 AM, Raghu Icecraft Software Trainings wrote:
Paul,
Thanks for the reply.
I am using Xilinx-SDK based : Linux version 4.19.0-rt1-xilinx-v2019.1

Can you please let me know how to verify the yocto version running on
target.
You might have better luck on the meta-xilinx mailing list. They should
know the details for their BSP.

More info on Xilnx layers and a pointer to subscribe info to the mailing
list is here:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841883/Yocto

Philip


Thanks,
Raghu

On Mon, Dec 28, 2020 at 5:31 PM Paul Barker <pbarker@...> wrote:

On Mon, 28 Dec 2020 at 09:44, Raghu Icecraft Software Trainings
<raghu.icecraft@...> wrote:

Hello,
I have upgraded my kernel poky to 2019.1 version, here i am unable to
find chpasswd utility because of which i am unable to set password to my
root-user.
Can you please let me know if the chpasswd utility has been changed or
modified please.

Yocto Project doesn't have a version "2019.1", see
https://wiki.yoctoproject.org/wiki/Releases.

I guess you're using a vendor supplied BSP or SDK with that version
number. Could you provide the Yocto Project version number and the
layers in use, or at least give some more info on where your "2019.1"
release is from.

Thanks,

--
Paul Barker
Konsulko Group




Raghu Icecraft Software Trainings
 

Hello,
Thanks for the reply.
I mailed to 
meta-xilinx@...
But no response yet, can you please let me know where else can i find some information.

Thanks,
Raghu

On Mon, Dec 28, 2020 at 7:28 PM Philip Balister <philip@...> wrote:
On 12/28/20 7:33 AM, Raghu Icecraft Software Trainings wrote:
> Paul,
> Thanks for the reply.
> I am using Xilinx-SDK based : Linux version 4.19.0-rt1-xilinx-v2019.1
>
> Can you please let me know how to verify the yocto version running on
> target.

You might have better luck on the meta-xilinx mailing list. They should
know the details for their BSP.

More info on Xilnx layers and a pointer to subscribe info to the mailing
list is here:

https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841883/Yocto

Philip

>
> Thanks,
> Raghu
>
> On Mon, Dec 28, 2020 at 5:31 PM Paul Barker <pbarker@...> wrote:
>
>> On Mon, 28 Dec 2020 at 09:44, Raghu Icecraft Software Trainings
>> <raghu.icecraft@...> wrote:
>>>
>>> Hello,
>>> I have upgraded my kernel poky to 2019.1 version, here i am unable to
>> find chpasswd utility because of which i am unable to set password to my
>> root-user.
>>> Can you please let me know if the chpasswd utility has been changed or
>> modified please.
>>
>> Yocto Project doesn't have a version "2019.1", see
>> https://wiki.yoctoproject.org/wiki/Releases.
>>
>> I guess you're using a vendor supplied BSP or SDK with that version
>> number. Could you provide the Yocto Project version number and the
>> layers in use, or at least give some more info on where your "2019.1"
>> release is from.
>>
>> Thanks,
>>
>> --
>> Paul Barker
>> Konsulko Group
>>
>
>
>
>
>