python3-psycopg2cffi DEPENDS error cffi


Bel Hadj Salem Talel
 

HI,
That's what I did exactly, but failed with the same error.
Here is the python3-cffi-native recipe:

SUMMARY = "Foreign Function Interface for Python calling C code."
HOMEPAGE = "http://cffi.readthedocs.org"
AUTHOR = "Armin Rigo, Maciej Fijalkowski <python-cffi@...>"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
SRC_URI = "https://files.pythonhosted.org/packages/cb/ae/380e33d621ae301770358eb11a896a34c34f30db188847a561e8e39ee866/cffi-1.14.3.tar.gz"
SRC_URI[md5sum] = "c2a47ffd5d183b193ac8ed3414dcfd07"
SRC_URI[sha256sum] = "f92f789e4f9241cd262ad7a555ca2c648a98178a953af117ef7fad46aa1d5591"
S = "${WORKDIR}/cffi-1.14.3"
RDEPENDS_${PN} = "python3-pycparser"
BBCLASSEXTEND = "native"
inherit setuptools3

and here is python3-psycopg2cffi recipe

SUMMARY = ".. image:: https://travis-ci.org/chtd/psycopg2cffi.svg?branch=master"
HOMEPAGE = "http://github.com/chtd/psycopg2cffi"
AUTHOR = "Konstantin Lopuhin <konstantin.lopuhin@...>"
LICENSE = "LGPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=edf147a599198440160215f8111f5bcf"
SRC_URI = "https://files.pythonhosted.org/packages/95/50/5b94b81a57948ce0350559aad8c20d250ff3b87868a5615efcc79704ba49/psycopg2cffi-2.8.1.tar.gz"
SRC_URI[md5sum] = "f67394d47803dab8a481402754bf83a1"
SRC_URI[sha256sum] = "fcaa4d5477a8205b33e8e9e6707a5c331a0f5d7f4af354529b6564377b678079"
S = "${WORKDIR}/psycopg2cffi-2.8.1"
DEPENDS = "python3-cffi-native"
RDEPENDS_${PN} = ""
inherit setuptools3


Quentin Schulz
 

Hi Talel,

On Tue, Nov 10, 2020 at 05:23:09AM -0800, Bel Hadj Salem Talel wrote:
HI All,
I created a recipe with pipoe for python3-psycopg2cffi when compiling this error occured:


ERROR: Do not try to fetch `cffi>=1.0' for building. Please add its native
recipe to DEPENDS.
I created a recipe for python3-cffi and I made it native with BBCLASSEXTEND = "native" and it depends also on python3-pycparser which is already native and exist.
Then I added DEPENDS = "python3-cffi" to python3-psycopg2cffi recipe but failed with same error, I tried to rename the python3-cffi to just cffi but same error.
If the native version of python3-cffi is needed, add
DEPENDS = "python3-cffi-native".

Quentin


Bel Hadj Salem Talel
 

HI All,
I created a recipe with pipoe for python3-psycopg2cffi when compiling this error occured:
ERROR: Do not try to fetch `cffi>=1.0' for building. Please add its native recipe to DEPENDS.
I created a recipe for python3-cffi and I made it native with BBCLASSEXTEND = "native" and it depends also on python3-pycparser which is already native and exist.
Then I added DEPENDS = "python3-cffi" to python3-psycopg2cffi recipe but failed with same error, I tried to rename the python3-cffi to just cffi but same error.

What I'm missing ?
Thanks ,Talel