: how to fix "do not ask to insatll a package providing xxxx"?


ouyangxuan10@163.com
 

Dear all,

I build a libarary in other project. And add a bb file in yocto to add to my yocto project, but it appear error.

who can tell me how to fix it?

thanks,
Byron



 


Rudolf J Streif
 

Hi Byron,

It's a dependency problem. The build system cannot find a recipe to build libdebuglog1. You either need to provide that or you don't install anything that requires libdebuglog1.

:rjs

On 11/5/20 5:10 AM, ouyangxuan10@... wrote:
Dear all,

I build a libarary in other project. And add a bb file in yocto to add to my yocto project, but it appear error.

who can tell me how to fix it?

thanks,
Byron



 




-- 
Rudolf J Streif
CEO/CTO ibeeto
+1.855.442.3386 x700


Chen Qi
 

It's basically about some package conflict & absence.

You could provide more info such as you bb file, the layers you're using, the result of `grep packagegroup-obmc-apps-network', etc.

Regards,
Chen Qi

On 11/05/2020 09:10 PM, ouyangxuan10@... wrote:
Dear all,

I build a libarary in other project. And add a bb file in yocto to add to my yocto project, but it appear error.

who can tell me how to fix it?

thanks,
Byron