Topics

[meta-security][zeus][PATCH] tpm2-tss-engine: License changed


Armin Kuster
 

Fixes this error:

ERROR: tpm2-tss-engine-1.0.1-r0 do_populate_lic: QA Issue: tpm2-tss-engine: The LIC_FILES_CHKSUM does not match for file://LICENSE;md5=3fb0047fd29391478a71e8e6101c76eb
tpm2-tss-engine: The new md5 checksum is 7b3ab643b9ce041de515d1ed092a36d4
tpm2-tss-engine: Here is the selected license text:

The License changed to BSD-3 14 months ago so I suspect the commit was incorrect.

This corrects the License and hash

[Yocto #13926]

Signed-off-by: Armin Kuster <akuster808@gmail.com>
---
.../recipes-tpm2/tpm2-tss-engine/tpm2-tss-engine_1.0.1.bb | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/meta-tpm/recipes-tpm2/tpm2-tss-engine/tpm2-tss-engine_1.0.1.bb b/meta-tpm/recipes-tpm2/tpm2-tss-engine/tpm2-tss-engine_1.0.1.bb
index 8825737..5a5192f 100644
--- a/meta-tpm/recipes-tpm2/tpm2-tss-engine/tpm2-tss-engine_1.0.1.bb
+++ b/meta-tpm/recipes-tpm2/tpm2-tss-engine/tpm2-tss-engine_1.0.1.bb
@@ -1,8 +1,8 @@
SUMMARY = "The tpm2-tss-engine project implements a cryptographic engine for OpenSSL."
DESCRIPTION = "The tpm2-tss-engine project implements a cryptographic engine for OpenSSL for Trusted Platform Module (TPM 2.0) using the tpm2-tss software stack that follows the Trusted Computing Groups (TCG) TPM Software Stack (TSS 2.0). It uses the Enhanced System API (ESAPI) interface of the TSS 2.0 for downwards communication. It supports RSA decryption and signatures as well as ECDSA signatures."

-LICENSE = "BSD-2-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=3fb0047fd29391478a71e8e6101c76eb"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7b3ab643b9ce041de515d1ed092a36d4"

SECTION = "security/tpm"

--
2.17.1