[meta-qt5, zeus-next, python3-pyqt5] QtChart can't be imported


Adrian
 

Hi,

I use python3-pyqt5 from meta-qt5 (in zeus-next). I get an error in python3 when I try to import QtChart module (from PyQt5 import QtChart). Has anybody experience the same issue and knows a fix? The deployed image comes with qtchart packages.

I have created an issue on the layer's issue tracker (link), but so far no reply.

Regards,

Adrian


Adrian
 

Hi,

I turn out PyQtChart was simply missing in the meta-qt5 layer.
I have created a recipe which adds it and hopefully will be merged to the upstream.

Regards,

Adrian

On 31.01.2020 17:52, Adrian Fiergolski wrote:

Hi,

I use python3-pyqt5 from meta-qt5 (in zeus-next). I get an error in python3 when I try to import QtChart module (from PyQt5 import QtChart). Has anybody experience the same issue and knows a fix? The deployed image comes with qtchart packages.

I have created an issue on the layer's issue tracker (link), but so far no reply.

Regards,

Adrian