Problem with rootfs boot on my raspberrypi. #raspberrypi

I am building simple image for my raspbery pi 3 A+ and connect to the pi via USB-UART converter and see the following in the console
[ 2.071459] Run /bin/init as init process
[ 2.076507] Run /bin/sh as init process
sh: cannot set terminal process group (-1): Inappropriate ioctl for device
sh: no job control in this shell

I build with the "bitbake core-image-base" and tried to run it on rpi 3A+, 3B, 3B+ and the problem is always the same it cannot switch to the rootfs on the sd card it seem like it stack at initramfs or some middle ground.

I burn the *.rpi-sdimg image to SD card with dd from my Ubuntu16.04 host machine.
I tried with two branches thud and warrior and the problem is exactly the same.
The strange thing is that in this initramfs there are no tools like find grep modprobe etc. but I see my extra tools "
i2c-tools vim"

Here is my local.conf adjustments:
MACHINE ?= "raspberrypi3"
ENABLE_I2C = "1"
IMAGE_INSTALL += "i2c-tools vim"

and the bblayer.conf
  /media/dave/Develop/yoctopi/warrior/sources/poky/meta \
  /media/dave/Develop/yoctopi/warrior/sources/poky/meta-poky \
  /media/dave/Develop/yoctopi/warrior/sources/poky/meta-yocto-bsp \
  /media/dave/Develop/yoctopi/warrior/sources/meta-openembedded/meta-oe \
  /media/dave/Develop/yoctopi/warrior/sources/meta-raspberrypi \

I tried also to build with the deprecated image "bitbake rpi-basic-image" but then I did not get my extra tools
"i2c-tools vim".

Anyone have any idea what can be wrong with my approach ?