One second timestamp resolution?


Paul D. DeRocco
 

I just noticed that I'm getting one-second resolution on all my
timestamps. This is for both ext4 and vfat partitions, and shows up in ls
--full-time and the stat command. What could account for this? My uname -a
output is "Linux CHROMA1 4.10.17-yocto-preempt-rt #1 SMP PREEMPT Wed Oct
11 12:33:54 PDT 2017 i686 i686 i386 GNU/Linux" if that's any help. Also,
my ext4 mount options are "rw,noatime,nodiratime,data=ordered".

--

Ciao, Paul D. DeRocco
Paul mailto:pderocco@ix.netcom.com


Jussi Kukkonen
 

On Wed, 11 Sep 2019 at 08:53, Paul D. DeRocco <pderocco@ix.netcom.com> wrote:

I just noticed that I'm getting one-second resolution on all my
timestamps. This is for both ext4 and vfat partitions, and shows up in ls
--full-time and the stat command. What could account for this? My uname -a
output is "Linux CHROMA1 4.10.17-yocto-preempt-rt #1 SMP PREEMPT Wed Oct
11 12:33:54 PDT 2017 i686 i686 i386 GNU/Linux" if that's any help. Also,
my ext4 mount options are "rw,noatime,nodiratime,data=ordered".
I think file timestamp resolution on ext4 is one of the things that
depend on inode size (ext4 does not enforce reasonable values because
of compatibility with earlier versions I guess). So maybe check inode
size (should be 256 bytes I think?).

Jussi


Paul D. DeRocco
 

From: Jussi Kukkonen [mailto:jku@goto.fi]

I think file timestamp resolution on ext4 is one of the things that
depend on inode size (ext4 does not enforce reasonable values because
of compatibility with earlier versions I guess). So maybe check inode
size (should be 256 bytes I think?).
I don't have tune2fs on my embedded system, so I can't check, but that sounds like the probable reason. The nanoseconds that ext4 added are in the upper 128 bytes of a 256 byte inode, for compatibility reasons, so somehow I must have ext4 configured to use 128 byte inodes. Where would this be configured in a Yocto build? I'm still on Pyro.

--

Ciao, Paul D. DeRocco
Paul mailto:pderocco@ix.netcom.com