gdb remote debugging not working correctly

Moritz Porst <Moritz.Porst@...>

Hello everyone,
I am having trouble to remote debug using gdb (v 8.2.0) with QTCreator (4.8.0).
My remote target features QT 5.12.0. I configured it like the following ( only relevant configurations ) :
inherit populate_sdk_qt5 # QT5 in SDK
IMAGE_INSTALL_append = " gdbserver"
IMAGE_FEATURES_append = " dev-pkgs dbg-pkgs" # dbg-pkgs for debug-libraries. Not sure if the dev-pkgs is really required, but it should not do any harm (except for bloat the image)
Now from my build/development machine I start the QT example "boxes". Executing in debug configuration >locally< it takes around 5 seconds to hit the first breakpoint (at the very beginning of main). On a breakpoint after the widget was created I can expand the widget variable which contains 8 objects. I can further expand (e.g.) [QWidget] which again contains several objects like [QObject].
Executing the debug configuration >remote< only takes around 1 second until first breakpoint. Expanding "widget" shows it is empty. No objects at all and the "expand arrow" is gone. When trying to step out of the actual main using f11 ("step into") I receive a SIGSEGV.
What I tried but didn't work:
- build the SDK again (because I had an older version)
- check versions: gdbserver on remote target (8.2.0); gdb on development machine (8.2.0)
- tried system gdb (7.11.1) which shows the exact same behaviour.
In remote debugging I am however able to use breakpoints, step through MY code (not code coming from 3rd party libraries -> SIGSEGV) and expanding variables that do not come from 3rd party variables (like argv).
I am not sure on how to proceed from here. It might be that I do something wrong but it could also be that this is an actual bug in gdb (?).
Any advice is appreciated ! System information below.
Best regards
System information:
Target uses a modified intel-corei7-64 machine and modified poky distribution. I removed following distro features:
DISTRO_FEATURES_remove = "bluetooth alsa wifi 3g wayland vulkan pulseaudio bluez5"
Dev machine runs an ubuntu 16.04.