Yocto failed to build

Jerrod Peach <peachj@...>

Aha.  And apparently there was a typo in the README that lead you down the wrong path.  Looks like it just got fixed.

(Btw I meant to leave the response on-list last time, so I'm bringing this back on-list.)

On Fri, Jun 28, 2013 at 11:42 AM, Jerrod Peach <peachj@...> wrote:

Looks like the fatal error is this:

DISTRO 'mf43' not found. Please set a valid DISTRO in your local.conf

That makes sense, because you probably meant to configure-workspace sim-mfp43 and not sim-mf43.  Try re-running configure-workspace with the correct distro and see if that gets you farther.

Kind regards,


On Fri, Jun 28, 2013 at 11:18 AM, Ramkumar Sankar Singh <ramsingh@...> wrote:
    I am trying to follow the README instruction provided in build-bundle and I have encountered the following error in the process, can anyone please let me know what I am doing wrong.

step followed:

  • git clone ssh://git@.../build-bundle
  • [git pull --rebase]
  • git submodule update --init
  • source init-build-env
  • configure-workspace sim-mf43
  • bitbake core-image-highlevel

Pseudo is not present but is required, building this first before the main build
ERROR:  OE-core's config sanity checker detected a potential misconfiguration.
    Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
    Following is the list of potential problems / advisories:

    Your version of bblayers.conf was generated from an older/newer version of bblayers.conf.sample and there have been updates made to this file. Please compare the two files and merge any changes before continuing.
Matching the version numbers will remove this message.
"meld conf/bblayers.conf /bonus/scratch/ramsingh/yocto/build-bundle/poky/meta*/conf/bblayers.conf.sample" is a good way to visualise the changes.
DISTRO 'mf43' not found. Please set a valid DISTRO in your local.conf

ERROR: Execution of event handler 'check_sanity_eventhandler' failed

workspace at: 

Ramkumar Singh

Yocto mailing list