[PATCH 0/1] Fix X issue on crownbay


nitin.a.kamble@...
 

From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit 66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06 10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work
http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=nitin/work

Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)

--
1.7.3.4


Tom Zanussi <tom.zanussi@...>
 

On Wed, 2012-09-05 at 17:59 -0700, nitin.a.kamble@intel.com wrote:
From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit 66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06 10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work
http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=nitin/work
I built and tried this, but it still didn't boot into X, and now there's
not even an Xorg.log to look at:

root@crownbay:/var/log# ls -al
drwxr-xr-x 2 root root 80 Sep 10 20:15 .
drwxrwxrwt 7 root root 140 Jan 6 2009 ..
-rw-r--r-- 1 root root 78429 Sep 10 20:17 messages
-rw-rw-r-- 1 root root 4224 Sep 10 20:17 wtmp

I assume this is a different X problem related to recent changes in
mater. Can you update the bug report with the commits that you tested
with so I can verify that your patch at least works?

Thanks,

Tom



Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)


Kamble, Nitin A <nitin.a.kamble@...>
 

Hi Tom,
Thanks for looking into the matter. I will try to reproduce the issue you are seeing with master. And send another pull request with all the fixes.

Regards,
Nitin

-----Original Message-----
From: Zanussi, Tom
Sent: Monday, September 10, 2012 4:34 PM
To: Kamble, Nitin A
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [PATCH 0/1] Fix X issue on crownbay

On Wed, 2012-09-05 at 17:59 -0700, nitin.a.kamble@intel.com wrote:
From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit
66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06
10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work

http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=nitin/w
ork
I built and tried this, but it still didn't boot into X, and now there's not even an
Xorg.log to look at:

root@crownbay:/var/log# ls -al
drwxr-xr-x 2 root root 80 Sep 10 20:15 .
drwxrwxrwt 7 root root 140 Jan 6 2009 ..
-rw-r--r-- 1 root root 78429 Sep 10 20:17 messages
-rw-rw-r-- 1 root root 4224 Sep 10 20:17 wtmp

I assume this is a different X problem related to recent changes in mater.
Can you update the bug report with the commits that you tested with so I
can verify that your patch at least works?

Thanks,

Tom



Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)


Kamble, Nitin A <nitin.a.kamble@...>
 

FYI While testing on the fishriver platform, I also find that there is no X log, and looking further found out that xorg executable is not on the image. I think the same thing is also happening on crownbay.

Nitin

-----Original Message-----
From: Kamble, Nitin A
Sent: Wednesday, September 12, 2012 9:18 AM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay

Hi Tom,
Thanks for looking into the matter. I will try to reproduce the issue you are
seeing with master. And send another pull request with all the fixes.

Regards,
Nitin


-----Original Message-----
From: Zanussi, Tom
Sent: Monday, September 10, 2012 4:34 PM
To: Kamble, Nitin A
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [PATCH 0/1] Fix X issue on crownbay

On Wed, 2012-09-05 at 17:59 -0700, nitin.a.kamble@intel.com wrote:
From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit
66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06
10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work

http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=nitin
/w
ork
I built and tried this, but it still didn't boot into X, and now
there's not even an Xorg.log to look at:

root@crownbay:/var/log# ls -al
drwxr-xr-x 2 root root 80 Sep 10 20:15 .
drwxrwxrwt 7 root root 140 Jan 6 2009 ..
-rw-r--r-- 1 root root 78429 Sep 10 20:17 messages
-rw-rw-r-- 1 root root 4224 Sep 10 20:17 wtmp

I assume this is a different X problem related to recent changes in mater.
Can you update the bug report with the commits that you tested with so
I can verify that your patch at least works?

Thanks,

Tom



Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)


Ross Burton
 

On 12 September 2012 21:14, Kamble, Nitin A <nitin.a.kamble@intel.com> wrote:
FYI While testing on the fishriver platform, I also find that there is no X log, and looking further found out that xorg executable is not on the image. I think the same thing is also happening on crownbay.
There have been transient reports of Xorg missing in the qemu images
too -- transient because the reporter said that the next day's
autobuilt image had the package installed again. Very odd.

In the broken systems you say there is no Xorg binary. Can you confirm
that there is no xserver-xorg package too? Can you inspect the build
and see if this failed, or if there is some machine configuration
disaster which means it doesn't think it needs to install an xserver?

Ross

FWIW, my qemuarm image from earlier today works.


Bodke, Kishore K <kishore.k.bodke@...>
 

-----Original Message-----
From: yocto-bounces@yoctoproject.org [mailto:yocto-
bounces@yoctoproject.org] On Behalf Of Kamble, Nitin A
Sent: Wednesday, September 12, 2012 1:14 PM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [yocto] [PATCH 0/1] Fix X issue on crownbay

FYI While testing on the fishriver platform, I also find that there is no X log, and
looking further found out that xorg executable is not on the image. I think the
same thing is also happening on crownbay.
FYI.. I also see the similar issue for Romley.
There is no Xlog and X does not comes up.

Thanks
Kishore.


Nitin



-----Original Message-----
From: Kamble, Nitin A
Sent: Wednesday, September 12, 2012 9:18 AM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay

Hi Tom,
Thanks for looking into the matter. I will try to reproduce the issue you are
seeing with master. And send another pull request with all the fixes.

Regards,
Nitin


-----Original Message-----
From: Zanussi, Tom
Sent: Monday, September 10, 2012 4:34 PM
To: Kamble, Nitin A
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [PATCH 0/1] Fix X issue on crownbay

On Wed, 2012-09-05 at 17:59 -0700, nitin.a.kamble@intel.com wrote:
From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit
66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06
10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work

http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=nitin
/w
ork
I built and tried this, but it still didn't boot into X, and now
there's not even an Xorg.log to look at:

root@crownbay:/var/log# ls -al
drwxr-xr-x 2 root root 80 Sep 10 20:15 .
drwxrwxrwt 7 root root 140 Jan 6 2009 ..
-rw-r--r-- 1 root root 78429 Sep 10 20:17 messages
-rw-rw-r-- 1 root root 4224 Sep 10 20:17 wtmp

I assume this is a different X problem related to recent changes in mater.
Can you update the bug report with the commits that you tested with so
I can verify that your patch at least works?

Thanks,

Tom



Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto


Kamble, Nitin A <nitin.a.kamble@...>
 

Ross,
Looking at the bug, I am trying with the latest commits now. When it failed, I looked at the build area, and found that the xorg-xserver package was built fine. I think the issue happened in the with rootfs generation. I haven't found why it was not included in the rootfs. From the bug I thought the issue got resolved in the latest tree HEAD, so I am going to test the latest head on few BSPs, and will dig further if I encounter the issue again.

Nitin

-----Original Message-----
From: Burton, Ross [mailto:ross.burton@intel.com]
Sent: Wednesday, September 12, 2012 1:43 PM
To: Kamble, Nitin A
Cc: Zanussi, Tom; Hart, Darren; yocto@yoctoproject.org
Subject: Re: [yocto] [PATCH 0/1] Fix X issue on crownbay

On 12 September 2012 21:14, Kamble, Nitin A <nitin.a.kamble@intel.com>
wrote:
FYI While testing on the fishriver platform, I also find that there is no X log,
and looking further found out that xorg executable is not on the image. I
think the same thing is also happening on crownbay.

There have been transient reports of Xorg missing in the qemu images too --
transient because the reporter said that the next day's autobuilt image had
the package installed again. Very odd.

In the broken systems you say there is no Xorg binary. Can you confirm that
there is no xserver-xorg package too? Can you inspect the build and see if
this failed, or if there is some machine configuration disaster which means it
doesn't think it needs to install an xserver?

Ross

FWIW, my qemuarm image from earlier today works.


Kamble, Nitin A <nitin.a.kamble@...>
 

Thanks Kishore for reporting it. I am trying to get to bottom of this by today or tomorrow.

Thanks,
Nitin

-----Original Message-----
From: Bodke, Kishore K
Sent: Wednesday, September 12, 2012 1:57 PM
To: Kamble, Nitin A; Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay



-----Original Message-----
From: yocto-bounces@yoctoproject.org [mailto:yocto-
bounces@yoctoproject.org] On Behalf Of Kamble, Nitin A
Sent: Wednesday, September 12, 2012 1:14 PM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [yocto] [PATCH 0/1] Fix X issue on crownbay

FYI While testing on the fishriver platform, I also find that there is
no X log, and looking further found out that xorg executable is not on
the image. I think the same thing is also happening on crownbay.
FYI.. I also see the similar issue for Romley.
There is no Xlog and X does not comes up.

Thanks
Kishore.


Nitin



-----Original Message-----
From: Kamble, Nitin A
Sent: Wednesday, September 12, 2012 9:18 AM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay

Hi Tom,
Thanks for looking into the matter. I will try to reproduce the
issue you are seeing with master. And send another pull request with all
the fixes.

Regards,
Nitin


-----Original Message-----
From: Zanussi, Tom
Sent: Monday, September 10, 2012 4:34 PM
To: Kamble, Nitin A
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [PATCH 0/1] Fix X issue on crownbay

On Wed, 2012-09-05 at 17:59 -0700, nitin.a.kamble@intel.com wrote:
From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit
66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06
10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work

http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=ni
tin
/w
ork
I built and tried this, but it still didn't boot into X, and now
there's not even an Xorg.log to look at:

root@crownbay:/var/log# ls -al
drwxr-xr-x 2 root root 80 Sep 10 20:15 .
drwxrwxrwt 7 root root 140 Jan 6 2009 ..
-rw-r--r-- 1 root root 78429 Sep 10 20:17 messages
-rw-rw-r-- 1 root root 4224 Sep 10 20:17 wtmp

I assume this is a different X problem related to recent changes in
mater.
Can you update the bug report with the commits that you tested with
so I can verify that your patch at least works?

Thanks,

Tom



Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto


Bodke, Kishore K <kishore.k.bodke@...>
 

-----Original Message-----
From: Kamble, Nitin A
Sent: Thursday, September 13, 2012 12:58 PM
To: Bodke, Kishore K; Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay

Thanks Kishore for reporting it. I am trying to get to bottom of this by today or
tomorrow.
Hi Nitin,

I still cannot see the X with the latest poky/master and meta-intel/master for Romley.
No /usr/bin/Xorg and /usr/bin/X .

Thanks
Kishore.


Thanks,
Nitin


-----Original Message-----
From: Bodke, Kishore K
Sent: Wednesday, September 12, 2012 1:57 PM
To: Kamble, Nitin A; Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay



-----Original Message-----
From: yocto-bounces@yoctoproject.org [mailto:yocto-
bounces@yoctoproject.org] On Behalf Of Kamble, Nitin A
Sent: Wednesday, September 12, 2012 1:14 PM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [yocto] [PATCH 0/1] Fix X issue on crownbay

FYI While testing on the fishriver platform, I also find that there is
no X log, and looking further found out that xorg executable is not on
the image. I think the same thing is also happening on crownbay.
FYI.. I also see the similar issue for Romley.
There is no Xlog and X does not comes up.

Thanks
Kishore.


Nitin



-----Original Message-----
From: Kamble, Nitin A
Sent: Wednesday, September 12, 2012 9:18 AM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay

Hi Tom,
Thanks for looking into the matter. I will try to reproduce the
issue you are seeing with master. And send another pull request with all
the fixes.

Regards,
Nitin


-----Original Message-----
From: Zanussi, Tom
Sent: Monday, September 10, 2012 4:34 PM
To: Kamble, Nitin A
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [PATCH 0/1] Fix X issue on crownbay

On Wed, 2012-09-05 at 17:59 -0700, nitin.a.kamble@intel.com wrote:
From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit
66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06
10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work

http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=ni
tin
/w
ork
I built and tried this, but it still didn't boot into X, and now
there's not even an Xorg.log to look at:

root@crownbay:/var/log# ls -al
drwxr-xr-x 2 root root 80 Sep 10 20:15 .
drwxrwxrwt 7 root root 140 Jan 6 2009 ..
-rw-r--r-- 1 root root 78429 Sep 10 20:17 messages
-rw-rw-r-- 1 root root 4224 Sep 10 20:17 wtmp

I assume this is a different X problem related to recent changes in
mater.
Can you update the bug report with the commits that you tested with
so I can verify that your patch at least works?

Thanks,

Tom



Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto


Saul Wold <sgw@...>
 

On 09/18/2012 07:35 PM, Bodke, Kishore K wrote:


-----Original Message-----
From: Kamble, Nitin A
Sent: Thursday, September 13, 2012 12:58 PM
To: Bodke, Kishore K; Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay

Thanks Kishore for reporting it. I am trying to get to bottom of this by today or
tomorrow.
Hi Nitin,

I still cannot see the X with the latest poky/master and meta-intel/master for Romley.
No /usr/bin/Xorg and /usr/bin/X .
The patch is pending on stage/master_under_test, it's changes an RPROVIDES to an RCONFLICTS.

Sau!

Thanks
Kishore.


Thanks,
Nitin


-----Original Message-----
From: Bodke, Kishore K
Sent: Wednesday, September 12, 2012 1:57 PM
To: Kamble, Nitin A; Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay



-----Original Message-----
From: yocto-bounces@yoctoproject.org [mailto:yocto-
bounces@yoctoproject.org] On Behalf Of Kamble, Nitin A
Sent: Wednesday, September 12, 2012 1:14 PM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [yocto] [PATCH 0/1] Fix X issue on crownbay

FYI While testing on the fishriver platform, I also find that there is
no X log, and looking further found out that xorg executable is not on
the image. I think the same thing is also happening on crownbay.
FYI.. I also see the similar issue for Romley.
There is no Xlog and X does not comes up.

Thanks
Kishore.


Nitin



-----Original Message-----
From: Kamble, Nitin A
Sent: Wednesday, September 12, 2012 9:18 AM
To: Zanussi, Tom
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: RE: [PATCH 0/1] Fix X issue on crownbay

Hi Tom,
Thanks for looking into the matter. I will try to reproduce the
issue you are seeing with master. And send another pull request with all
the fixes.

Regards,
Nitin


-----Original Message-----
From: Zanussi, Tom
Sent: Monday, September 10, 2012 4:34 PM
To: Kamble, Nitin A
Cc: Hart, Darren; yocto@yoctoproject.org
Subject: Re: [PATCH 0/1] Fix X issue on crownbay

On Wed, 2012-09-05 at 17:59 -0700, nitin.a.kamble@intel.com wrote:
From: Nitin A Kamble <nitin.a.kamble@intel.com>

The following changes since commit
66b516f3d3a287eecbf8804b2221bfc27e36db63:

README: add info explaining meta-tlk layer purpose (2012-09-06
10:36:02 -0500)

are available in the git repository at:
git://git.yoctoproject.org/meta-intel-contrib nitin/work

http://git.yoctoproject.org/cgit.cgi/meta-intel-contrib/log/?h=ni
tin
/w
ork
I built and tried this, but it still didn't boot into X, and now
there's not even an Xorg.log to look at:

root@crownbay:/var/log# ls -al
drwxr-xr-x 2 root root 80 Sep 10 20:15 .
drwxrwxrwt 7 root root 140 Jan 6 2009 ..
-rw-r--r-- 1 root root 78429 Sep 10 20:17 messages
-rw-rw-r-- 1 root root 4224 Sep 10 20:17 wtmp

I assume this is a different X problem related to recent changes in
mater.
Can you update the bug report with the commits that you tested with
so I can verify that your patch at least works?

Thanks,

Tom



Nitin A Kamble (1):
emgd-driver-bin: Fix package naming issue

.../xorg-xserver/emgd-driver-bin_1.14.bb | 8 +++++++-
1 files changed, 7 insertions(+), 1 deletions(-)
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto