preempt-rt kernel shutdown now command does not work


Bodke, Kishore K <kishore.k.bodke@...>
 

Hi,

 

“shutdown –h now” command is not working on core-image-sato image with preempt-rt kernel 3.0.4  on Romley and crystal forest BSP

 

I get

Warning**: could not initialize ACPI battery.

Xinit: connection to X server lost.

xinit: uexpected signal 15

 

Does anybody see the same problem on other meta-intel BSPs?

 

Thanks

Kishore.


Darren Hart <darren.hart@...>
 

On 09/29/2011 05:54 PM, Bodke, Kishore K wrote:
Hi,

"shutdown -h now" command is not working on core-image-sato image
with preempt-rt kernel 3.0.4 on Romley and crystal forest BSP

I get Warning**: could not initialize ACPI battery. Xinit: connection
to X server lost. xinit: uexpected signal 15
Hi Kishore,


I don't know that I've tried that specific command.

I see the unexpected signal message when shutting down the qemux86 sato
image (non-rt) with that or the halt command, but it does shut all the
way down. In your case does the system continue to be responsive after
issuing the command?


--
Darren Hart
Intel Open Source Technology Center
Yocto Project - Linux Kernel


Bodke, Kishore K <kishore.k.bodke@...>
 

Hi Darren,

For the non-rt "shutdown now" works perfectly fine.
For the rt kernel, after the command is issued, it tries to halt the system and hangs there forever after the connection to the X server is lost.

Thanks
Kishore.

-----Original Message-----
From: Hart, Darren
Sent: Thursday, September 29, 2011 6:44 PM
To: Bodke, Kishore K
Cc: yocto@...
Subject: Re: preempt-rt kernel shutdown now command does not work

On 09/29/2011 05:54 PM, Bodke, Kishore K wrote:
Hi,

"shutdown -h now" command is not working on core-image-sato image
with preempt-rt kernel 3.0.4 on Romley and crystal forest BSP

I get Warning**: could not initialize ACPI battery. Xinit: connection
to X server lost. xinit: uexpected signal 15
Hi Kishore,


I don't know that I've tried that specific command.

I see the unexpected signal message when shutting down the qemux86 sato
image (non-rt) with that or the halt command, but it does shut all the
way down. In your case does the system continue to be responsive after
issuing the command?


--
Darren Hart
Intel Open Source Technology Center
Yocto Project - Linux Kernel


Darren Hart <darren.hart@...>
 

On 09/29/2011 07:32 PM, Bodke, Kishore K wrote:
Hi Darren,

For the non-rt "shutdown now" works perfectly fine. For the rt
kernel, after the command is issued, it tries to halt the system and
hangs there forever after the connection to the X server is lost.
Sounds like a legitimate bug. It works in qemux86 with -rt. I'll be able
to test an rt image on a meta-intel board in the morning. In the mean
time, please open a bug and let us know how critical you feel it is.

Thanks,

--
Darren


Thanks Kishore.

-----Original Message----- From: Hart, Darren Sent: Thursday,
September 29, 2011 6:44 PM To: Bodke, Kishore K Cc:
yocto@... Subject: Re: preempt-rt kernel shutdown now
command does not work

On 09/29/2011 05:54 PM, Bodke, Kishore K wrote:
Hi,

"shutdown -h now" command is not working on core-image-sato image
with preempt-rt kernel 3.0.4 on Romley and crystal forest BSP

I get Warning**: could not initialize ACPI battery. Xinit:
connection to X server lost. xinit: uexpected signal 15
Hi Kishore,


I don't know that I've tried that specific command.

I see the unexpected signal message when shutting down the qemux86
sato image (non-rt) with that or the halt command, but it does shut
all the way down. In your case does the system continue to be
responsive after issuing the command?


--
Darren Hart
Intel Open Source Technology Center
Yocto Project - Linux Kernel


Bruce Ashfield <bruce.ashfield@...>
 

On 11-09-29 10:40 PM, Darren Hart wrote:
On 09/29/2011 07:32 PM, Bodke, Kishore K wrote:
Hi Darren,

For the non-rt "shutdown now" works perfectly fine. For the rt
kernel, after the command is issued, it tries to halt the system and
hangs there forever after the connection to the X server is lost.
Sounds like a legitimate bug. It works in qemux86 with -rt. I'll be able
to test an rt image on a meta-intel board in the morning. In the mean
time, please open a bug and let us know how critical you feel it is.
It's also worth trying the board booted UP versus SMP. We've seen
this in the past with kstop and thread migration interacting badly
on -rt. Forcing them to cpu0 on shutdown fixed those problems.

Bruce




Thanks,

--
Darren


Thanks Kishore.

-----Original Message----- From: Hart, Darren Sent: Thursday,
September 29, 2011 6:44 PM To: Bodke, Kishore K Cc:
yocto@... Subject: Re: preempt-rt kernel shutdown now
command does not work

On 09/29/2011 05:54 PM, Bodke, Kishore K wrote:
Hi,

"shutdown -h now" command is not working on core-image-sato image
with preempt-rt kernel 3.0.4 on Romley and crystal forest BSP

I get Warning**: could not initialize ACPI battery. Xinit:
connection to X server lost. xinit: uexpected signal 15
Hi Kishore,


I don't know that I've tried that specific command.

I see the unexpected signal message when shutting down the qemux86
sato image (non-rt) with that or the halt command, but it does shut
all the way down. In your case does the system continue to be
responsive after issuing the command?