Date   

requesting help

U RAVI KUMAR <uppadaravi2511@...>
 

Hello guys,
                    I have built a linux distribution using core-image-sato.I want a qtwebbrowser as one of the application to be installed on the OS. can anyone pls help me through this process.

Thanks and Regards,
ravi_uppada


Re: Can't Build Read-Only RootFS

Leon Woestenberg
 

Hello Dave,

On Fri, Jan 15, 2021 at 10:40 PM Dave Tucker <theaethereal@...> wrote:
ERROR: core-image-minimal-1.0-r0 do_rootfs: The following packages could not be configured offline and rootfs is read-only: ['sysvinit-inittab']
I've not been able to find any information on this issue and am not sure how to proceed.  Could someone please point me in the right direction?

I copied that error report into Google. Maybe you are hitting a similar case to this?


Regards,

Leon,


Can't Build Read-Only RootFS

Dave Tucker
 

I'm trying to build yocto for a Beaglebone Black.  I was setting the file system to be read-only in /etc/fstab, and that was causing the boot process to lock up as of my latest build when I switched to dunfell.  So I added IMAGE_FEATURES += "read-only-rootfs" to my local.conf, which I believe is the correct way to handle this.  But now the system won't build.  I get the following output:

NOTE: recipe core-image-minimal-1.0-r0: task do_rootfs: Started
ERROR: core-image-minimal-1.0-r0 do_rootfs: The following packages could not be configured offline and rootfs is read-only: ['sysvinit-inittab']
ERROR: Logfile of failure stored in: /data/dunfell-bbb/build/bbb/tmp/work/beaglebone_yocto-poky-linux-gnueabi/core-image-minimal/1.0-r0/temp/log.do_rootfs.10987
NOTE: recipe core-image-minimal-1.0-r0: task do_rootfs: Failed
I've not been able to find any information on this issue and am not sure how to proceed.  Could someone please point me in the right direction?

Here are my local.conf and bblayers.conf.

Thanks,

Dave


Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

I am still seeing the Nothing PROVIDES 'init-system-helpers-service'...

I am currently working around this be over-writing the "mountnfs.sh" script, but I want resolve this issue so we are 100% Yocto compliant...

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Thursday, January 14, 2021 2:48 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


yeah no worries I intendted to give hints to look into that recipe and find out package as needed, not giving a fully cooked solution

On 1/14/21 10:46 AM, Monsees, Steven C (US) via lists.yoctoproject.org
wrote:

I believe you said: init-system-helpers...
I will try the other (init-system-helpers-service) later today

Thanks,
Steve

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Thursday, January 14, 2021 1:36 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I must have said add init-system-helpers-service

On Wed, Jan 13, 2021 at 5:17 AM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:

I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve









Re: cpio issues

Leon Woestenberg
 

Hello Damien,

On Fri, Jan 15, 2021 at 3:48 PM Damien LEFEVRE <lefevre.da@gmail.com> wrote:

How can I keep the initramfs with cpio, but disable cpio archiving for the rootfs which I don't need or use for anything?
I have this in my local.conf:

IMAGE_FSTYPES = "tar ext4"
INITRAMFS_FSTYPES = "cpio.xz"

It does depend a bit on your image recipes and classes if this works for you.

Regards,

Leon.


cpio issues

Damien LEFEVRE
 

Hi,

I am working with Tegra Xavier and meta-tegra.

During the build process, 2 images get generated:
 - initramfs (cpio archive)
 - the actual roofs image

initramfs is archived with cpio and since the cpio image type is enabled, bitbake tries to cpio the rootfs. The roofts is more than 2GB (not difficult with CUDA libraries) and cpio fails due to some 2GB size limitation.

How can I keep the initramfs with cpio, but disable cpio archiving for the rootfs which I don't need or use for anything?

Thanks,
-Damien


Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

I believe you said: init-system-helpers...
I will try the other (init-system-helpers-service) later today

Thanks,
Steve

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Thursday, January 14, 2021 1:36 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I must have said add init-system-helpers-service

On Wed, Jan 13, 2021 at 5:17 AM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:

I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve





Re: #yocto #kernel #yocto #kernel

Khem Raj
 

perhaps use netkit-rsh-server and inetutils-rsh

On Thu, Jan 14, 2021 at 8:24 AM Monsees, Steven C (US)
<steven.monsees@baesystems.com> wrote:


Khem:

I appear to have a similar issue building in inetutils-rsh and inetutils-rshd...

When added to IMAGE_INSTALL, (IMAGE_INSTALL += " inetutils-rsh inetutils-rshd")

I also get an "Error: Nothing PROVIDES ..."

How do you pull in various net utility commands (ex. rlogind) without inetutils-rsh and inetutils-rshd ?

I do not see anything in the migration guides on this...

Any ideas ?

I am using zeus 3.0.4 and building aarch64 Xilinx based image...

Steve

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 2:25 PM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


Khem:

I am having issues attempting to resolve this issue...
I am seeing it in my bootloader...

Can you possibly point me in the right direction ?

Thanks.
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Wednesday, January 13, 2021 8:17 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




Re: #yocto #kernel #yocto #kernel

Khem Raj
 

I must have said add init-system-helpers-service

On Wed, Jan 13, 2021 at 5:17 AM Monsees, Steven C (US) via
lists.yoctoproject.org
<steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:


I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve





Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

Do we know why it was disabled ?

I will look into this, thanks...

-----Original Message-----
From: Quentin Schulz <quentin.schulz@streamunlimited.com>
Sent: Thursday, January 14, 2021 12:18 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: Khem Raj <raj.khem@gmail.com>; yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


Hi Steve,

On Thu, Jan 14, 2021 at 05:11:29PM +0000, Monsees, Steven C (US) via lists.yoctoproject.org wrote:

Khem:

Should have waited for build to complete... this just delays where the error occurs.

Now rather than upfront, it fails on packaging with the following error:

ERROR: aiox-defaultfs-1.0-r0 do_rootfs: Unable to install packages. Command '/disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/recipe-sysroot-native/usr/bin/opkg --volatile-cache -f /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/opkg.conf -t /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/temp/ipktemp/ -o /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/rootfs --force_postinstall --prefer-arch-to-version install base-files bash bc binutils bridge-utils coreutils crush cs-hdlc dhcp-server dhcp-server-config e2fsprogs ethtool haveged hdparm i2c-tools inetutils inetutils-rsh iperf3 iproute2 iptables iputils iputils-ping kernel-modules key-helper kmod libpci3 module-init-tools mtd-utils mtd-utils-ubifs nano ncurses ncurses-dev net-tools netcat nfs-utils nfs-utils-stats ntfs-3g ntfsprogs openssh openssh-sftp-server packagegroup-base-vfat packagegroup-core-boot pciutils pciutils-ids peekpoke perl plx8000 plx8000nt plxsvc pub-key python python-stringold python-subprocess rsync run-postinsts sg3-utils swig tar tcpdump tftp-hpa tftp-hpa-server traceroute usbutils util-linux wolfssl xinetd' returned 255:
Collected errors:
* opkg_prepare_url_for_install: Couldn't find anything to satisfy 'inetutils-rsh'.

What has changed in the build process ?, under rocko I do not see an issue adding inetutils-rsh...
http://cgit.openembedded.org/openembedded-core/commit/meta/recipes-connectivity/inetutils?h=zeus&id=9e13dad6ea76dd036098ef62427804e4138bf83b

It's disabled by default now.

You can probably re-enable it by appending --enable-rsh again I guess?

Quentin


Re: #yocto #kernel #yocto #kernel

Quentin Schulz
 

Hi Steve,

On Thu, Jan 14, 2021 at 05:11:29PM +0000, Monsees, Steven C (US) via lists.yoctoproject.org wrote:

Khem:

Should have waited for build to complete... this just delays where the error occurs.

Now rather than upfront, it fails on packaging with the following error:

ERROR: aiox-defaultfs-1.0-r0 do_rootfs: Unable to install packages. Command '/disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/recipe-sysroot-native/usr/bin/opkg --volatile-cache -f /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/opkg.conf -t /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/temp/ipktemp/ -o /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/rootfs --force_postinstall --prefer-arch-to-version install base-files bash bc binutils bridge-utils coreutils crush cs-hdlc dhcp-server dhcp-server-config e2fsprogs ethtool haveged hdparm i2c-tools inetutils inetutils-rsh iperf3 iproute2 iptables iputils iputils-ping kernel-modules key-helper kmod libpci3 module-init-tools mtd-utils mtd-utils-ubifs nano ncurses ncurses-dev net-tools netcat nfs-utils nfs-utils-stats ntfs-3g ntfsprogs openssh openssh-sftp-server packagegroup-base-vfat packagegroup-core-boot pciutils pciutils-ids peekpoke perl plx8000 plx8000nt plxsvc pub-key python python-stringold python-subprocess rsync run-postinsts sg3-utils swig tar tcpdump tftp-hpa tftp-hpa-server traceroute usbutils util-linux wolfssl xinetd' returned 255:
Collected errors:
* opkg_prepare_url_for_install: Couldn't find anything to satisfy 'inetutils-rsh'.

What has changed in the build process ?, under rocko I do not see an issue adding inetutils-rsh...
http://cgit.openembedded.org/openembedded-core/commit/meta/recipes-connectivity/inetutils?h=zeus&id=9e13dad6ea76dd036098ef62427804e4138bf83b

It's disabled by default now.

You can probably re-enable it by appending --enable-rsh again I guess?

Quentin


Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

Khem:

Should have waited for build to complete... this just delays where the error occurs.

Now rather than upfront, it fails on packaging with the following error:

ERROR: aiox-defaultfs-1.0-r0 do_rootfs: Unable to install packages. Command '/disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/recipe-sysroot-native/usr/bin/opkg --volatile-cache -f /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/opkg.conf -t /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/temp/ipktemp/ -o /disk0/scratch/smonsees/yocto/workspace_3/meta-bae/meta-limws/builds/aiox-default/tmp/work/aiox_default-poky-linux/aiox-defaultfs/1.0-r0/rootfs --force_postinstall --prefer-arch-to-version install base-files bash bc binutils bridge-utils coreutils crush cs-hdlc dhcp-server dhcp-server-config e2fsprogs ethtool haveged hdparm i2c-tools inetutils inetutils-rsh iperf3 iproute2 iptables iputils iputils-ping kernel-modules key-helper kmod libpci3 module-init-tools mtd-utils mtd-utils-ubifs nano ncurses ncurses-dev net-tools netcat nfs-utils nfs-utils-stats ntfs-3g ntfsprogs openssh openssh-sftp-server packagegroup-base-vfat packagegroup-core-boot pciutils pciutils-ids peekpoke perl plx8000 plx8000nt plxsvc pub-key python python-stringold python-subprocess rsync run-postinsts sg3-utils swig tar tcpdump tftp-hpa tftp-hpa-server traceroute usbutils util-linux wolfssl xinetd' returned 255:
Collected errors:
* opkg_prepare_url_for_install: Couldn't find anything to satisfy 'inetutils-rsh'.

What has changed in the build process ?, under rocko I do not see an issue adding inetutils-rsh...

Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Thursday, January 14, 2021 11:59 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


Khem:

I may have stumbled upon it, it appears I had to add a DEPENDS += "inetutils" to fix the issue on including inetutils-rsh...

What does "init-system-helpers" depend on ?

Thanks,
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Thursday, January 14, 2021 11:24 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.



Khem:

I appear to have a similar issue building in inetutils-rsh and inetutils-rshd...

When added to IMAGE_INSTALL, (IMAGE_INSTALL += " inetutils-rsh inetutils-rshd")

I also get an "Error: Nothing PROVIDES ..."

How do you pull in various net utility commands (ex. rlogind) without inetutils-rsh and inetutils-rshd ?

I do not see anything in the migration guides on this...

Any ideas ?

I am using zeus 3.0.4 and building aarch64 Xilinx based image...

Steve

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 2:25 PM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


Khem:

I am having issues attempting to resolve this issue...
I am seeing it in my bootloader...

Can you possibly point me in the right direction ?

Thanks.
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Wednesday, January 13, 2021 8:17 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

Khem:

I may have stumbled upon it, it appears I had to add a DEPENDS += "inetutils" to fix the issue on including inetutils-rsh...

What does "init-system-helpers" depend on ?

Thanks,
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Thursday, January 14, 2021 11:24 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.



Khem:

I appear to have a similar issue building in inetutils-rsh and inetutils-rshd...

When added to IMAGE_INSTALL, (IMAGE_INSTALL += " inetutils-rsh inetutils-rshd")

I also get an "Error: Nothing PROVIDES ..."

How do you pull in various net utility commands (ex. rlogind) without inetutils-rsh and inetutils-rshd ?

I do not see anything in the migration guides on this...

Any ideas ?

I am using zeus 3.0.4 and building aarch64 Xilinx based image...

Steve

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 2:25 PM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


Khem:

I am having issues attempting to resolve this issue...
I am seeing it in my bootloader...

Can you possibly point me in the right direction ?

Thanks.
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Wednesday, January 13, 2021 8:17 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

Khem:

I appear to have a similar issue building in inetutils-rsh and inetutils-rshd...

When added to IMAGE_INSTALL, (IMAGE_INSTALL += " inetutils-rsh inetutils-rshd")

I also get an "Error: Nothing PROVIDES ..."

How do you pull in various net utility commands (ex. rlogind) without inetutils-rsh and inetutils-rshd ?

I do not see anything in the migration guides on this...

Any ideas ?

I am using zeus 3.0.4 and building aarch64 Xilinx based image...

Steve

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 2:25 PM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


Khem:

I am having issues attempting to resolve this issue...
I am seeing it in my bootloader...

Can you possibly point me in the right direction ?

Thanks.
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Wednesday, January 13, 2021 8:17 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




Devtool eSDK remove package #devtool

Gustavo Plaza
 

Hello,
I have generated and installed eSDK for Yocto sumo correctly.
 
I have two packages that provide the same headers, one of them is installed by default in the eSDK and I would like to install the other one and remove the previous from the eSDK.
 
If I install the second package using the command "devtool sdk-install my-package2" I would like the first package to be removed from the sdk. Can I add any variable (similar to RREPLACES or RCONFLICTS ) to the "my-package1" and "my-package2" recipes in order to remove one package when the other one is installed?
 
I think devtool doesn't provide the opposite functionality to sdk-install, isn't it? I think I could implement the funtionallity "sdk-remove" in the file sdk.py so that it would be possible to execute the task "do_cleanall" of any recipe. Is this ok ? Is there any reason behind the non-existence of the functionality "sdk-remove" ? 
 
Best regards.


Re: OpenEmbedded Virtual Stand at FOSDEM 2021

Philip Balister
 

I have some photos of stands from the past that would be fun to add to
the stand web page. I can watch chat some, mainly during times I am
awake in the US East coat though.

Philip

On 1/14/21 6:02 AM, Robert Berger wrote:
Hi,

On 13/01/2021 23:33, Paul Barker wrote:
Hi folks,

* Any participants in the project who want to help host the Matrix
chat room between 09:00 and 18:00 each day of the event. This will
likely involve introducing the project to folks dropping in the chat
who aren't familiar with OpenEmbedded, answering basic questions and
chatting about example uses of the project. You don't need to be a
long-standing expert in the project to help out here! If you can do a
couple of hours or a half day please let us know.
Let's try to come up with some schedule when I should be there and just
let me know how the join the chat.


* Any contributions of video content to go along with the static web
pages. I'm planning to record some short introductory video content
but other contributions would also be welcome. Details on how to
upload videos is expected in the near future but for now it would be
good to just collect folks who are interested so we can discuss this
further.

If you're interested in any of the above please reply to me and/or the
list. I look forward to virtually seeing many of you at FOSDEM 2021!
What kind of video would you like? A small video which explains a
specific topic?

Something like this?[1]

[1] https://www.youtube.com/watch?v=kmpEN953pzs&feature=youtu.be


Thanks,
Regards,

Robert









Re: OpenEmbedded Virtual Stand at FOSDEM 2021

Robert Berger
 

Hi,

On 13/01/2021 23:33, Paul Barker wrote:
Hi folks,
* Any participants in the project who want to help host the Matrix
chat room between 09:00 and 18:00 each day of the event. This will
likely involve introducing the project to folks dropping in the chat
who aren't familiar with OpenEmbedded, answering basic questions and
chatting about example uses of the project. You don't need to be a
long-standing expert in the project to help out here! If you can do a
couple of hours or a half day please let us know.
Let's try to come up with some schedule when I should be there and just let me know how the join the chat.

* Any contributions of video content to go along with the static web
pages. I'm planning to record some short introductory video content
but other contributions would also be welcome. Details on how to
upload videos is expected in the near future but for now it would be
good to just collect folks who are interested so we can discuss this
further.
If you're interested in any of the above please reply to me and/or the
list. I look forward to virtually seeing many of you at FOSDEM 2021!
What kind of video would you like? A small video which explains a specific topic?

Something like this?[1]

[1] https://www.youtube.com/watch?v=kmpEN953pzs&feature=youtu.be

Thanks,
Regards,

Robert


Re: QA notification for completed autobuilder build (yocto-3.1.5.rc1)

Sangeeta Jain
 

Hi all,

Intel and WR YP QA is planning for QA execution for YP build yocto-3.1.5.rc1 We are planning to execute following tests for this cycle:

OEQA-manual tests for following module:
1. OE-Core
2. BSP-hw

Runtime auto test for following platforms:
1. MinnowTurbot 32-bit
2. Coffee Lake
3. NUC 7
4. NUC 6
5. Edgerouter
6. Beaglebone

ETA for completion is next Tuesday, January 19.

Thanks,
Sangeeta

-----Original Message-----
From: Pokybuild User <pokybuild@ubuntu1804-ty-1.yocto.io>
Sent: Thursday, 14 January, 2021 2:37 AM
To: yocto@lists.yoctoproject.org
Cc: otavio@ossystems.com.br; yi.zhao@windriver.com; Sangal, Apoorv
<apoorv.sangal@intel.com>; Yeoh, Ee Peng <ee.peng.yeoh@intel.com>; Chan,
Aaron Chun Yew <aaron.chun.yew.chan@intel.com>;
richard.purdie@linuxfoundation.org; akuster808@gmail.com;
sjolley.yp.pm@gmail.com; Jain, Sangeeta <sangeeta.jain@intel.com>;
steve@sakoman.com
Subject: QA notification for completed autobuilder build (yocto-3.1.5.rc1)


A build flagged for QA (yocto-3.1.5.rc1) was completed on the autobuilder and is
available at:


https://autobuilder.yocto.io/pub/releases/yocto-3.1.5.rc1


Build hash information:

bitbake: a394eeec6aeb98c6395cb5da2036ce936bdaa0a0
meta-arm: 9e2ff72858c1744217195ca4a728e0044ac28af1
meta-gplv2: 60b251c25ba87e946a0ca4cdc8d17b1cb09292ac
meta-intel: 4922e10c7b8169585ff9322b0d913dadc525c68e
meta-kernel: 8349870943ba44bbd688656897372e881f32c741
meta-mingw: 524de686205b5d6736661d4532f5f98fee8589b7
oecore: 72431ee8de5e3a53d259cebf420a7713ac9e1f14
poky: e32d854e33bc86c2a616df8708e021a098afcf73



This is an automated message from the Yocto Project Autobuilder
Git: git://git.yoctoproject.org/yocto-autobuilder2
Email: richard.purdie@linuxfoundation.org



OpenEmbedded Virtual Stand at FOSDEM 2021

 

Hi folks,

OpenEmbedded has been accepted to hold a "virtual stand" at FOSDEM
2021 which is taking place online this year on Sat 6th Feb & Sun 7th
Feb, based around the CET timezone.

Most of you will be familiar with FOSDEM by now, but if not let me
give a quick bit of background on the event. This is the Free and Open
Source Developers' European Meeting and usually takes place in
Brussels in early February each year. The event won't be happening
in-person in Brussels this year due to the current pandemic but I
think it's still important to take advantage of this opportunity of
connecting with other contributors to OpenEmbedded & Yocto Project as
well as other members and projects within the wider open source
community. For more information see the FOSDEM 2021 website at
https://fosdem.org/2021/.

This virtual stand will consist of a Matrix chat room (likely with
Jitsi video chat) along with hosting space for static web pages &
video within the FOSDEM 2021 website. The details on all of this are
still being figured out but right now we've got enough information to
start planning our involvement. What we're looking for is:

* Any participants in the project who want to help host the Matrix
chat room between 09:00 and 18:00 each day of the event. This will
likely involve introducing the project to folks dropping in the chat
who aren't familiar with OpenEmbedded, answering basic questions and
chatting about example uses of the project. You don't need to be a
long-standing expert in the project to help out here! If you can do a
couple of hours or a half day please let us know.

* Any folks who would like to help build the static web pages for the
stands section of the FOSDEM 2021 website. FOSDEM is using the Hugo
static website generator so the content will be written as Markdown
files which are converted to html by hugo. Further information is
available in the README file at
https://github.com/FOSDEM/stands-website/blob/master/README.md. I'm
hoping that someone is willing to take the lead on this as I'm already
very busy in the runup to FOSDEM. I'm available to help set up git
repositories, test things out and review content.

* Any contributions of video content to go along with the static web
pages. I'm planning to record some short introductory video content
but other contributions would also be welcome. Details on how to
upload videos is expected in the near future but for now it would be
good to just collect folks who are interested so we can discuss this
further.

If you're interested in any of the above please reply to me and/or the
list. I look forward to virtually seeing many of you at FOSDEM 2021!

Thanks,

--
Paul Barker
Konsulko Group


Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

Khem:

I am having issues attempting to resolve this issue...
I am seeing it in my bootloader...

Can you possibly point me in the right direction ?

Thanks.
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Wednesday, January 13, 2021 8:17 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve



1881 - 1900 of 53871