Date   

Re: QA notification for completed autobuilder build (yocto-3.1.5.rc1)

Sangeeta Jain
 

Hi all,

Intel and WR YP QA is planning for QA execution for YP build yocto-3.1.5.rc1 We are planning to execute following tests for this cycle:

OEQA-manual tests for following module:
1. OE-Core
2. BSP-hw

Runtime auto test for following platforms:
1. MinnowTurbot 32-bit
2. Coffee Lake
3. NUC 7
4. NUC 6
5. Edgerouter
6. Beaglebone

ETA for completion is next Tuesday, January 19.

Thanks,
Sangeeta

-----Original Message-----
From: Pokybuild User <pokybuild@ubuntu1804-ty-1.yocto.io>
Sent: Thursday, 14 January, 2021 2:37 AM
To: yocto@lists.yoctoproject.org
Cc: otavio@ossystems.com.br; yi.zhao@windriver.com; Sangal, Apoorv
<apoorv.sangal@intel.com>; Yeoh, Ee Peng <ee.peng.yeoh@intel.com>; Chan,
Aaron Chun Yew <aaron.chun.yew.chan@intel.com>;
richard.purdie@linuxfoundation.org; akuster808@gmail.com;
sjolley.yp.pm@gmail.com; Jain, Sangeeta <sangeeta.jain@intel.com>;
steve@sakoman.com
Subject: QA notification for completed autobuilder build (yocto-3.1.5.rc1)


A build flagged for QA (yocto-3.1.5.rc1) was completed on the autobuilder and is
available at:


https://autobuilder.yocto.io/pub/releases/yocto-3.1.5.rc1


Build hash information:

bitbake: a394eeec6aeb98c6395cb5da2036ce936bdaa0a0
meta-arm: 9e2ff72858c1744217195ca4a728e0044ac28af1
meta-gplv2: 60b251c25ba87e946a0ca4cdc8d17b1cb09292ac
meta-intel: 4922e10c7b8169585ff9322b0d913dadc525c68e
meta-kernel: 8349870943ba44bbd688656897372e881f32c741
meta-mingw: 524de686205b5d6736661d4532f5f98fee8589b7
oecore: 72431ee8de5e3a53d259cebf420a7713ac9e1f14
poky: e32d854e33bc86c2a616df8708e021a098afcf73



This is an automated message from the Yocto Project Autobuilder
Git: git://git.yoctoproject.org/yocto-autobuilder2
Email: richard.purdie@linuxfoundation.org



OpenEmbedded Virtual Stand at FOSDEM 2021

 

Hi folks,

OpenEmbedded has been accepted to hold a "virtual stand" at FOSDEM
2021 which is taking place online this year on Sat 6th Feb & Sun 7th
Feb, based around the CET timezone.

Most of you will be familiar with FOSDEM by now, but if not let me
give a quick bit of background on the event. This is the Free and Open
Source Developers' European Meeting and usually takes place in
Brussels in early February each year. The event won't be happening
in-person in Brussels this year due to the current pandemic but I
think it's still important to take advantage of this opportunity of
connecting with other contributors to OpenEmbedded & Yocto Project as
well as other members and projects within the wider open source
community. For more information see the FOSDEM 2021 website at
https://fosdem.org/2021/.

This virtual stand will consist of a Matrix chat room (likely with
Jitsi video chat) along with hosting space for static web pages &
video within the FOSDEM 2021 website. The details on all of this are
still being figured out but right now we've got enough information to
start planning our involvement. What we're looking for is:

* Any participants in the project who want to help host the Matrix
chat room between 09:00 and 18:00 each day of the event. This will
likely involve introducing the project to folks dropping in the chat
who aren't familiar with OpenEmbedded, answering basic questions and
chatting about example uses of the project. You don't need to be a
long-standing expert in the project to help out here! If you can do a
couple of hours or a half day please let us know.

* Any folks who would like to help build the static web pages for the
stands section of the FOSDEM 2021 website. FOSDEM is using the Hugo
static website generator so the content will be written as Markdown
files which are converted to html by hugo. Further information is
available in the README file at
https://github.com/FOSDEM/stands-website/blob/master/README.md. I'm
hoping that someone is willing to take the lead on this as I'm already
very busy in the runup to FOSDEM. I'm available to help set up git
repositories, test things out and review content.

* Any contributions of video content to go along with the static web
pages. I'm planning to record some short introductory video content
but other contributions would also be welcome. Details on how to
upload videos is expected in the near future but for now it would be
good to just collect folks who are interested so we can discuss this
further.

If you're interested in any of the above please reply to me and/or the
list. I look forward to virtually seeing many of you at FOSDEM 2021!

Thanks,

--
Paul Barker
Konsulko Group


Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

Khem:

I am having issues attempting to resolve this issue...
I am seeing it in my bootloader...

Can you possibly point me in the right direction ?

Thanks.
Steve

-----Original Message-----
From: yocto@lists.yoctoproject.org <yocto@lists.yoctoproject.org> On Behalf Of Monsees, Steven C (US) via lists.yoctoproject.org
Sent: Wednesday, January 13, 2021 8:17 AM
To: Khem Raj <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




QA notification for completed autobuilder build (yocto-3.1.5.rc1)

pokybuild@...
 

A build flagged for QA (yocto-3.1.5.rc1) was completed on the autobuilder and is available at:


https://autobuilder.yocto.io/pub/releases/yocto-3.1.5.rc1


Build hash information:

bitbake: a394eeec6aeb98c6395cb5da2036ce936bdaa0a0
meta-arm: 9e2ff72858c1744217195ca4a728e0044ac28af1
meta-gplv2: 60b251c25ba87e946a0ca4cdc8d17b1cb09292ac
meta-intel: 4922e10c7b8169585ff9322b0d913dadc525c68e
meta-kernel: 8349870943ba44bbd688656897372e881f32c741
meta-mingw: 524de686205b5d6736661d4532f5f98fee8589b7
oecore: 72431ee8de5e3a53d259cebf420a7713ac9e1f14
poky: e32d854e33bc86c2a616df8708e021a098afcf73



This is an automated message from the Yocto Project Autobuilder
Git: git://git.yoctoproject.org/yocto-autobuilder2
Email: richard.purdie@linuxfoundation.org


Re: BITBAKE HANGS

U RAVI KUMAR <uppadaravi2511@...>
 

Hello guys,

            I have done with installing the qtwebengine.But iam having some trouble in how to configure the qtbrowser from the qtwebengine.I am using a GUI based core-image-sato image. So please guide me on how to configure the browser in this particular image.

Thanks,
ravi uppada.

On Tue, Jan 12, 2021 at 11:32 AM U RAVI KUMAR via lists.yoctoproject.org <uppadaravi2511=gmail.com@...> wrote:
Hello Davis,

              I will try using 16 GB ram. Thank you very much for your response.
Thanks,
ravi uppada.

On Mon, Jan 11, 2021 at 11:18 PM Davis, Michael <michael.davis@...> wrote:

QTWebengine needs a considerable amount of RAM to compile and link relative to the rest of Yocto.

Normally around 12-16GB.  Less than that and the system tends to hang.

 

 

 

From: yocto@... <yocto@...> On Behalf Of U RAVI KUMAR via lists.yoctoproject.org
Sent: Monday, January 11, 2021 11:25 AM
To: yocto@...
Subject: [yocto] BITBAKE HANGS

 

hi guys,

 

 I have encountered with a problem.I have built a custom linux for raspberrypi and included meta-openembedded,meta-raspberrypi,meta-qt5,meta-python2 layers and compiled on the bitbake. it is working fine.

I have added recipe "qtwebengine" , here i have encountered an issue i.e the system hangs. only while compiling qtwebengine system hangs.Can anyone suggest me the solution.So that i canovercome and proceed fiurther..

 

Thanks and regards,

ravikumar



CONFIDENTIALITY NOTICE:

This e-mail transmission and any documents, files or previous e-mail messages attached to it may contain information that is confidential, protected by the attorney/client or other privileges, and may constitute non-public information. It is intended to be conveyed only to the designated recipient(s) named above.

Any unauthorized use, reproduction, forwarding, distribution or other dissemination of this transmission is strictly prohibited and may be unlawful. If you are not an intended recipient of this email transmission, please notify the sender by return e-mail and permanently delete any record of this transmission. Your cooperation is appreciated. To find out more Click Here.





Bitbake's cached basehash does not match

yuvaraj.velumani@...
 

Hi, 

 

I am not quite sure why am I getting the below error message and how do I fix it.

 

"ERROR: When reparsing /home/ota/qcombuild/8155_agl/apps/apps_proc/meta-flutter/recipes-graphics/flutter-engine/flutter-engine_git.bb:do_patch, the basehash value changed from 1530cc970eeaed481afc4b0e34db2e2d05660b730efe2596beb3669e11282467 to cf17c978d7ffc1da3406f5345b779730717dff7f671ca7bdaa25dbb6c77b3e72. The metadata is not deterministic and this needs to be fixed.

ERROR: The following commands may help:
ERROR: $ bitbake flutter-engine -cdo_patch -Snone
ERROR: Then:
ERROR: $ bitbake flutter-engine -cdo_patch -Sprintdiff

ERROR: Bitbake's cached basehash does not match the one we just generated (/home/ota/qcombuild/8155_agl/apps/apps_proc/meta-flutter/recipes-graphics/flutter-engine/flutter-engine_git.bb:do_patch)!
ERROR: The mismatched hashes were 1530cc970eeaed481afc4b0e34db2e2d05660b730efe2596beb3669e11282467 and cf17c978d7ffc1da3406f5345b779730717dff7f671ca7bdaa25dbb6c77b3e72
ERROR: Taskhash mismatch 5e73f226e97df142e82bb61aac71967b6e2f8a0e7e8203b62a90ececcda81012 versus 3e73b20fffb5291533f6ce0221399f71fb9b93d57e8a3946943990b718987625 for /home/ota/qcombuild/8155_agl/apps/apps_proc/meta-flutter/recipes-graphics/flutter-engine/flutter-engine_git.bb:do_patch"

 

Any help would be highly appreciated.

 

Regards,

Raj

 

DENSO TEN AMERICA Limited® The information in this transmittal (including attachments, if any) may be confidential, proprietary, legally privileged, or subject to other restrictions and is meant only for the intended recipient(s)/addressee(s). Any review, use, disclosure, distribution, copying, or storing of this transmittal is prohibited except by or on behalf of any of the intended recipients. If you are not an intended recipient/addressee, any use of the transmittal and/or its contents, including, but not limited to, dissemination, distribution or copying is strictly prohibited and may be unlawful, and you must not take any action in reliance on it. If you receive this transmittal in error, please immediately notify the sender and delete the original message, any copies of it from your computer system and any hard copies that may have been generated. The company denies any liability for damages resulting from the use of this transmittal by an unintended recipient/addressee, including the recipient in error.


Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

I am using sysvinit...

-----Original Message-----
From: Monsees, Steven C (US)
Sent: Wednesday, January 13, 2021 7:15 AM
To: 'Khem Raj' <raj.khem@gmail.com>
Cc: yocto@lists.yoctoproject.org
Subject: RE: [yocto] #yocto #kernel


When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




Re: #yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

When I do this I am seeing "Nothing PROVIDES 'init-system-helpers',,,

-----Original Message-----
From: Khem Raj <raj.khem@gmail.com>
Sent: Tuesday, January 12, 2021 6:13 PM
To: Monsees, Steven C (US) <steven.monsees@baesystems.com>
Cc: yocto@lists.yoctoproject.org
Subject: Re: [yocto] #yocto #kernel

*** WARNING ***
EXTERNAL EMAIL -- This message originates from outside our organization.


On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via lists.yoctoproject.org <steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




Re: Unable to add pre compiled library #yocto

Vijay Rakesh Munganda
 

Is re compiling the .so file is correct? I found one solution online, tried to recompile and my build is got successful.  

do_compile(){
        ${CXX} -shared -o  libopentok.so ${S}/lib/libopentok.so
}

Thanks,
VR


Re: #vmdk #hddimg #iso with #dunfell #vmdk #hddimg #iso

chruetli@...
 

I switched from warrior to dunfell and want to build an image for Oracles VirtualBox VM.
On warrior there was 'automatically' a hddimg generated on dunfell this is no longer the case. The IMAGE_FSTYPES has to by specified, I use:
WKS_FILE = "virtualbox.wks"
IMAGE_FSTYPES += "wic.vmdk"

This requires me to write an wks file for which I use:
part /boot --source bootimg-pcbios --ondisk sda --label boot --active --align 1024
part / --source rootfs --ondisk sda --fstype=ext4 --label platform --align 1024
bootloader --ptable gpt  --timeout=5  --append="rootfstype=ext4 video=vesafb vga=current console=tty0"

With these settings I get an vmdk image but it fails to boot. I get a "VFS Unable to mount root fs on unknown block(0,0)" dump.

Any ideas?


Re: Unable to add pre compiled library #yocto

Vijay Rakesh Munganda
 

On Tue, Jan 12, 2021 at 06:29 AM, Quentin Schulz wrote:
I told you on StackOverflow to checkout the dunfell branch of
meta-clang. Do that, and recompile again instead of cherry-picking
recipes, classes, patches and whatnot.
Once you've something that works, you can experiment with cherry-picking
if you want.
I had tried your suggestion and bitbake started to reinstall all packages but facing the same issue. Bitbake doesn't show any progress.

meta-clang           = "dunfell:e63d6f9abba5348e2183089d6ef5ea384d7ae8d8"
 
Initialising tasks: 100% |###############################################################################| Time: 0:00:18
Sstate summary: Wanted 1189 Found 0 Missed 1189 Current 1157 (0% match, 49% complete)
NOTE: Executing Tasks
Currently  4 running tasks (2744 of 5866)  46% |#################################                                      |
0: linux-mtk-5.4.51+gitAUTOINC+50ca5f1c95-r0 do_compile_kernelmodules - 2h33m23s (pid 117)
1: clang-native-10.0.1-r0 do_compile (pid 4105)   7% |####                                                             |
2: gnutls-3.6.13-r0 do_package - 1h3m55s (pid 4706)
3: libgcrypt-1.8.5-r0 do_configure - 1h0m23s (pid 7528)

Thanks & Regards,
VR


Re: #vmdk #hddimg #iso with #dunfell #vmdk #hddimg #iso

chruetli@...
 

Some more information:

Build Configuration:

BB_VERSION= "1.46.0"
BUILD_SYS= "x86_64-linux"

NATIVELSBSTRING= "universal"
TARGET_SYS= "x86_64-poky-linux"
MACHINE= "virtualbox"
DISTRO= "my-gnu-linux"
DISTRO_VERSION= "3.1.2"
TUNE_FEATURES= "m64"
TARGET_FPU= ""

 

Without any ajustments in my .conf file I get the missing WKS_FILE/S warning:

ERROR: my-image-1.0-r0 do_image_wic: No kickstart files from WKS_FILES were found: my-image.virtualbox.wks my-image.wks. Please set WKS_FILE or WKS_FILES appropriately.

 

*** hddimg/vdmk ***

Setting
IMAGE_FSTYPES = "hddimg"


Convert the generated hddimg to vdmk :

$ vboxmanage convertfromraw image-virtualbox.hddimg image-virtualbox.vdmk

Starting image-virtualbox.vdmk with VirtualBox:

 



Starting image-virtualbox.hdd with VirtualBox shows the same behaviour as for vdmk

 
Opening the vdmk file as an archive the files show strange creation dates:


 

*** iso ***

Setting IMAGE_FSTYPES = "iso"
 
Starting image-virtualbox.iso with VirtualBox:
Linux is booting until it hangs after "Load/Save Random Seed". What stands out is the failure message in the beginning "Failed to start Remount Root and Kernel File Systems"... But how to fix it?



 

 

 


Re: [meta-mingw][PATCH] openssl: support for building nativesdk of mingw

Changqing Li
 

ping

On 1/5/21 11:31 AM, Changqing Li wrote:
* add support for mingw32
* Engines are installed in a slightly different path, which is
  urgly, patch it to make the path shorter
* remove runtime dependency from perl for mingw nativesdk

since commit 70da1f956bfbb627691c47eba7451182aca758e3 of oe-core
'openssl: Add c_rehash to misc package and add perl runtime dependency'

package openssl-misc have runtime dependency on perl, and perl then
have depenency on another 3 recipes, db/gdbm/libxcrypt. according to
http://arsv.github.io/perl-cross/usage.html, perl don't support
cross-compile build for mingw32 and another 3 recipes also don't
support mingw well. so remove the dependency of perl, don't support
c_rehash for mingw.

Signed-off-by: Changqing Li <changqing.li@...>
---
 ...ile.tmpl-don-t-add-prefix-for-libdir.patch | 32 +++++++++++++++++++
 .../openssl/openssl_%.bbappend                | 31 ++++++++++++++++++
 2 files changed, 63 insertions(+)
 create mode 100644 recipes-connectivity/openssl/files/0001-unix-Makefile.tmpl-don-t-add-prefix-for-libdir.patch
 create mode 100644 recipes-connectivity/openssl/openssl_%.bbappend

diff --git a/recipes-connectivity/openssl/files/0001-unix-Makefile.tmpl-don-t-add-prefix-for-libdir.patch b/recipes-connectivity/openssl/files/0001-unix-Makefile.tmpl-don-t-add-prefix-for-libdir.patch
new file mode 100644
index 0000000..028431b
--- /dev/null
+++ b/recipes-connectivity/openssl/files/0001-unix-Makefile.tmpl-don-t-add-prefix-for-libdir.patch
@@ -0,0 +1,32 @@
+From 8fe5c9421acfaff35b637e7ad55d1df598bb7081 Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@...>
+Date: Tue, 22 Dec 2020 09:22:10 +0800
+Subject: [PATCH] unix-Makefile.tmpl: don't add prefix for libdir
+
+we had pass libdir to Configure, don't use prefix again to
+avoid engineer dir set to:
+/opt/poky/3.2+snapshot/sysroots/x86_64-w64-mingw32/usr/opt/poky/3.2+snapshot/sysroots/x86_64-w64-mingw32/usr/lib/engines-1_1
+
+Upstream-Status: Inappropriate[oe-specific]
+
+Signed-off-by: Changqing Li <changqing.li@...>
+---
+ Configurations/unix-Makefile.tmpl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Configurations/unix-Makefile.tmpl b/Configurations/unix-Makefile.tmpl
+index bbafb98..eecb63e 100644
+--- a/Configurations/unix-Makefile.tmpl
++++ b/Configurations/unix-Makefile.tmpl
+@@ -244,7 +244,7 @@ LIBDIR={- our $libdir = $config{libdir} || "lib";
+           File::Spec::Win32->file_name_is_absolute($libdir) ? "" : $libdir -}
+ ENGINESDIR_dev={- use File::Spec::Win32;
+                   our $enginesdir =
+-                      File::Spec::Win32->catdir($prefix,$libdir,
++                      File::Spec::Win32->catdir($libdir,
+                                                 "engines-$sover_dirname");
+                   our ($enginesdir_dev, $enginesdir_dir, $enginesdir_file) =
+                       File::Spec::Win32->splitpath($enginesdir, 1);
+-- 
+2.17.1
+
diff --git a/recipes-connectivity/openssl/openssl_%.bbappend b/recipes-connectivity/openssl/openssl_%.bbappend
new file mode 100644
index 0000000..7fd82f1
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl_%.bbappend
@@ -0,0 +1,31 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_mingw32_class-nativesdk = " \
+           file://0001-unix-Makefile.tmpl-don-t-add-prefix-for-libdir.patch \
+"
+
+do_configure_mingw32 () {
+	os=${HOST_OS}
+	target="$os-${HOST_ARCH}"
+	case $target in
+        mingw32-x86_64)
+                target=mingw64
+                ;;
+        mingw32-i686)
+                target=mingw
+                ;;
+        esac
+
+        useprefix=${prefix}
+        if [ "x$useprefix" = "x" ]; then
+                useprefix=/
+        fi
+        # WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
+        # environment variables set by bitbake. Adjust the environment variables instead.
+        HASHBANGPERL="/usr/bin/env perl" PERL=perl PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
+        perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=${libdir} $target
+        perl ${B}/configdata.pm --dump
+}
+
+FILES_${PN}-engines_mingw32_class-nativesdk = "${libdir}/engines-1_1"
+RDEPENDS_${PN}-misc_remove_mingw32_class-nativesdk = "perl"




Re: #yocto #kernel #yocto #kernel

Khem Raj
 

On Tue, Jan 12, 2021 at 12:09 PM Monsees, Steven C (US) via
lists.yoctoproject.org
<steven.monsees=baesystems.com@lists.yoctoproject.org> wrote:



Working on zeus 3.0.4, for aarch64



I have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.



The error seen is : /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found



Usage: @ line 70: “service rpcbind status >/dev/null”

perhaps just add init-system-helpers to IMAGE_INSTALL


Thanks,

Steve




#yocto #kernel #yocto #kernel

Monsees, Steven C (US)
 

 

Working on zeus 3.0.4, for aarch64

 

I  have a startup script making use of “service” How do I properly configure in support for the “service” command ?

I do not have an error when working under rocko.

 

The error seen is :    /etc/rc5.d/S15mountnfs.sh: line 70: service: command not found

 

Usage: @ line 70:  “service rpcbind status >/dev/null”

 

Thanks,

Steve


remove particular device from QB_OPT_APPEND: per-word manner

Sergey Ivanov <icegood1980@...>
 

For all info

---------- Forwarded message ---------
От: Quentin Schulz <quentin.schulz@...>
Date: вт, 12 янв. 2021 г. в 17:43
Subject: Re: [yocto] remove particular device from QB_OPT_APPEND: per-word manner
To: Sergey Ivanov <icegood1980@...>


Rah, please answer to all always (keep the mailing list in Cc). I'll
bounce the mail on the mailing list for you now.

On Tue, Jan 12, 2021 at 05:27:58PM +0200, Sergey Ivanov wrote:
> Thanks, it should work, provided...
> Am i understand correctly that all append-remove stuff works BEFORE
> anonymous python script?
>
> вт, 12 янв. 2021 г. в 17:19, Quentin Schulz <
> quentin.schulz@...>:
>
> > Hi Sergey,
> >
> > On Tue, Jan 12, 2021 at 05:09:25PM +0200, Sergey Ivanov wrote:
> > > Hi there.
> > >
> > > I'm working with arm64 target and i want to take control on usb buses on
> > it.
> > > What i'm trying to do is tro remove both bus and hid devices on it via
> > > QB_OPT_APPEND_remove = " -show-cursor -device qemu-xhci -device
> > usb-tablet
> > > -device usb-kbd "
> > >
> > > Of course, it doesn't work properly since it removes ALL occurrences of
> > > each word above. In particular, i had "-device VGA,edid=on" that i wanted
> > > to stay.
> > > Instead, i obtained "VGA,edid=on" that lead to boot error. OK, it is
> > clear.
> > > I also tried smth. like
> > >
> > > QB_OPT_APPEND_remove = " -show-cursor '-device qemu-xhci' '-device
> > > usb-tablet' '-device usb-kbd -device' "
> > >
> > > however nothing was removed here. Can i workaround given issue under
> > *Zeus?*
> >
> > A "hack" I'm thinking about right now would be to remove those variables
> > by hand in a python anonymous function. You want to expand the variable
> > first, then do some python regex or however you like, to remove what you
> > want. Python anonymous functions are run at parsing time.
> >
> > Otherwise, if you know pretty much exactly what the content of the
> > variable should be for you, you can always use the following:
> > QB_OPT_APPEND_<my-machine> = "<content>"
> >
> > Hope this can give you some ideas,
> > Cheers,
> > Quentin
> >
>
>
> --
> Kind regards,
> Sergey Ivanov

--
StreamUnlimited Engineering GmbH
High Tech Campus Vienna, Gutheil-Schoder-Gasse 10, 1100 Vienna, Austria
Fax: +43 1 667 20 02 4401
quentin.schulz@..., www.streamunlimited.com


--
Kind regards,
Sergey Ivanov


Re: remove particular device from QB_OPT_APPEND: per-word manner

Quentin Schulz
 

On Tue, Jan 12, 2021 at 05:27:58PM +0200, Sergey Ivanov wrote:
Thanks, it should work, provided...
Am i understand correctly that all append-remove stuff works BEFORE
anonymous python script?
I'd say yes except for task-specific variables (one can do
QB_OPT_APPEND_task-install for example). Make sure you expand the
variable though (d.getVar('QB_OPT_APPEND', True) IIRC?) so that if
QB_OPT_APPEND contains other variables, they'll be resolved before you
start doing your logic.

Quentin


Yocto Project Status WW02`21

Stephen Jolley
 

Current Dev Position: YP 3.3 M2 development

Next Deadline: 18th January 2021 YP 3.3 M2 build 

 

Next Team Meetings:

 

Key Status/Updates:

  • Patches for 3.3 M2 development are being tested and merged. We have one week left before M2 is due to be built.
  • It was a mixed week for builds and patches, several reproducibility issues appeared and issues also appeared after patches had merged in the second or third build after that due to state reuse and differences between worker distros. This makes merging the patches challenging.
  • In particular, an upgrade to qemu 5.2.0 did merge. That upgrade includes a change to the underlying build system and the patchset was significantly rationalised which may cause issues. In particular, issues on centos hosts were eventually traced to the mmap_min_addr setting being too low (65536 now seems to be the useful minimum).
  • We are now tracking intermittent ptest failures and a number of bugs have been opened for these, we don’t as yet have people able to work on them though.
  • CVE metrics are starting to trend down again but we still have 56 “open” CVEs against master and more in gatesgath/dunfell so help in further reducing the number would be appreciated.
  • Intermittent autobuilder issues continue to occur and with more invasive changes and higher rebuild rates, the numbers are increasing again. You can see the list of failures we’re continuing to see by searching for the “AB-INT” tag in bugzilla: https://bugzilla.yoctoproject.org/buglist.cgi?quicksearch=AB-INT

 

Ways to contribute:

 

YP 3.3 Milestone Dates:

  • YP 3.3 M2 build date 2021/01/18
  • YP 3.3 M2 Release date 2021/01/29
  • YP 3.3 M3 build date 2021/03/01
  • YP 3.3 M3 Release date 2021/03/12
  • YP 3.3 M4 build date 2021/04/05
  • YP 3.3 M4 Release date 2021/04/30

 

Planned upcoming dot releases:

  • YP 3.1.5 build date 2021/01/11
  • YP 3.1.5 release date 2021/01/22
  • YP 3.2.2 build date 2021/02/08
  • YP 3.2.2 release date 2021/02/19
  • YP 3.1.6 build date 2021/02/22
  • YP 3.1.6 release date 2021/03/05
  • YP 3.1.7 build date 2021/03/22
  • YP 3.1.7 release date 2021/04/02

 

Tracking Metrics:

 

The Yocto Project’s technical governance is through its Technical Steering Committee, more information is available at:

https://wiki.yoctoproject.org/wiki/TSC

 

The Status reports are now stored on the wiki at: https://wiki.yoctoproject.org/wiki/Weekly_Status

 

[If anyone has suggestions for other information you’d like to see on this weekly status update, let us know!]

 

Thanks,

 

Stephen K. Jolley

Yocto Project Program Manager

(    Cell:                (208) 244-4460

* Email:              sjolley.yp.pm@...

 


Re: remove particular device from QB_OPT_APPEND: per-word manner

Quentin Schulz
 

Hi Sergey,

On Tue, Jan 12, 2021 at 05:09:25PM +0200, Sergey Ivanov wrote:
Hi there.

I'm working with arm64 target and i want to take control on usb buses on it.
What i'm trying to do is tro remove both bus and hid devices on it via
QB_OPT_APPEND_remove = " -show-cursor -device qemu-xhci -device usb-tablet
-device usb-kbd "

Of course, it doesn't work properly since it removes ALL occurrences of
each word above. In particular, i had "-device VGA,edid=on" that i wanted
to stay.
Instead, i obtained "VGA,edid=on" that lead to boot error. OK, it is clear.
I also tried smth. like

QB_OPT_APPEND_remove = " -show-cursor '-device qemu-xhci' '-device
usb-tablet' '-device usb-kbd -device' "

however nothing was removed here. Can i workaround given issue under *Zeus?*
A "hack" I'm thinking about right now would be to remove those variables
by hand in a python anonymous function. You want to expand the variable
first, then do some python regex or however you like, to remove what you
want. Python anonymous functions are run at parsing time.

Otherwise, if you know pretty much exactly what the content of the
variable should be for you, you can always use the following:
QB_OPT_APPEND_<my-machine> = "<content>"

Hope this can give you some ideas,
Cheers,
Quentin


Re: insmod - huawei E3372h kernel module

Zoltan Kerenyi Nagy
 

If I make a symbolic link for modprobe, the message is the same like insmod:
root@barix-ipam400:~# ln -s /lib/modules/4.10.0/extra/cdc-ncm.ko /lib/modules/4.10.0/
root@barix-ipam400:~# modprobe cdc_ncm.ko
modprobe: can't load module cdc_wdm (extra/cdc-wdm.ko): invalid module format

--
Zolee

1841 - 1860 of 53814