Date   

Weekly build

Flanagan, Elizabeth <elizabeth.flanagan@...>
 

All,

I'm currently at ELC and am going to be a little slow with email.
However, tonight I will be building M4 rc1. We are looking pretty
green and had been hoping to use the last build for rc1, but we want
to get it a little closer as to have it all green. I will be building
it from current master head and will branch/tag in the morning. If you
maintain a layer that I don't have branch access for, please create
the milestone branch for it from the git hashes I send out in the
morning. Thanks.

-b

--
Elizabeth Flanagan
Yocto Project
Build and Release


Re: Updated Yocto Hands-on Kernel Lab available

Trevor Woerner
 

Following up on a hunch, after reading Pierre Ficheux's email from
earlier today, I realized that by default I always switch my build's
PACKAGE_CLASSES to ipk simply because this packaging takes the least
amount of build time. Sure enough, when working on lab3 I had switched
to ipk and it didn't work. Switching PACKAGE_CLASSES to rpm and doing
nothing else but rebuilding, everything worked. I tried twice more
switching between ipk and rpm and anytime ipk is used the module is
not automatically installed, but with rpm it is.


Re: Always removing status files in case of IPK

Martin Jansa
 

On Tue, Feb 19, 2013 at 08:14:22PM +0100, Pierre Ficheux wrote:
Hi,

I've noticed a problem in rootfs_ipk.bbclass as status files are always removed in case of using IPK (works fine with
RPM). Here is the small patch which fix it.
This is expected, see if in which this is:

if ${@base_contains("IMAGE_FEATURES", "package-management", "false", "true", d)}; then

regards

diff --git a/meta/classes/rootfs_ipk.bbclass b/meta/classes/rootfs_ipk.bbclass
index fadec4d..89c3128 100644
--- a/meta/classes/rootfs_ipk.bbclass
+++ b/meta/classes/rootfs_ipk.bbclass
@@ -109,9 +109,6 @@ fakeroot rootfs_ipk_do_rootfs () {
if $remove_run_postinsts; then
update-rc.d -f -r ${IMAGE_ROOTFS} run-postinsts remove
fi
-
- # Also delete the status files
- remove_packaging_data_files
fi
fi
set +x


--
Pierre FICHEUX -/- CTO OW/OS4I, France -\- pierre.ficheux@openwide.fr
http://www.os4i.com
http://www.linuxembedded.fr
I would love to change the world, but they won't give me the source code
_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto
--
Martin 'JaMa' Jansa jabber: Martin.Jansa@gmail.com


bitbake: how to resolve a dependency to kernel-devicetree when building rootfs

Hans Beckérus <hans.beckerus@...>
 

First of all, I am a total noob when it comes to bitbake, but I am
struggling and slowly getting there ( I think).
So, I am sorry if my questions seems stupid, but this one I just can
not seem to figure out on my own.
What I am trying to do is to build a custom ARM based rootfs image
using the ELDK toolchain that should include all the modules from my
kernel build. But the rootfs build stage fails! If I exclude the
kernel modules everything work just fine.

The bitbake error I get is

| Collected errors:
| * satisfy_dependencies_for: Cannot satisfy the following
dependencies for kernel-modules:
| * kernel-devicetree *
| * opkg_install_cmd: Cannot install package kernel-modules.


My simple rootfs.bb looks like this

require recipes-core/images/core-image-minimal.bb

# The list of packages used to build images.
IMAGE_INSTALL += "kernel-modules"

# Formats of root filesystem images that you want to have created.
IMAGE_FSTYPES = "jffs2"


The device tree blob was built successfully and is located in the
kernel deploy image folder.
I can see that I have the following files under the kernel work path

./packages-split/kernel-devicetree
./pkgdata/runtime/kernel-devicetree
./pkgdata/runtime-reverse/kernel-devicetree

Any advice on what I have missed?

Hans


Always removing status files in case of IPK

Pierre Ficheux <pierre.ficheux@...>
 

Hi,

I've noticed a problem in rootfs_ipk.bbclass as status files are always removed in case of using IPK (works fine with
RPM). Here is the small patch which fix it.

regards

diff --git a/meta/classes/rootfs_ipk.bbclass b/meta/classes/rootfs_ipk.bbclass
index fadec4d..89c3128 100644
--- a/meta/classes/rootfs_ipk.bbclass
+++ b/meta/classes/rootfs_ipk.bbclass
@@ -109,9 +109,6 @@ fakeroot rootfs_ipk_do_rootfs () {
if $remove_run_postinsts; then
update-rc.d -f -r ${IMAGE_ROOTFS} run-postinsts remove
fi
-
- # Also delete the status files
- remove_packaging_data_files
fi
fi
set +x


--
Pierre FICHEUX -/- CTO OW/OS4I, France -\- pierre.ficheux@openwide.fr
http://www.os4i.com
http://www.linuxembedded.fr
I would love to change the world, but they won't give me the source code


Re: BSP of the YoctoProject:Cedartrail

Bodke, Kishore K <kishore.k.bodke@...>
 

I am not sure what “hob” layer does and how to build with any BSP.

May be someone from the mailing list would help you here.

 

How to build any meta-intel BSP with “meta-hob” layer?

Just include this layer in bblayers.conf? or any other changes required?

 

Thanks

Kishore.

 

From: 万欣宇 [mailto:wan_xinyu@...]
Sent: Tuesday, February 19, 2013 8:43 AM
To: Bodke, Kishore K
Subject: Re:RE: BSP of the YoctoProject:Cedartrail

 

As your advice, I have removed the meta-hob layer from the bblayer.conf and it can make a mirror successfully.

But now I want some extra spare space in my mirror. What should I do without "hob" ?



 

At 2013-02-14 03:48:07,"Bodke, Kishore K" <kishore.k.bodke@...> wrote:

Do you need meta-hob layer to be built in?

If you do not need, remove the layer from bblayers.conf.

 

We have not tested the meta-hob layer with Cedartrail.

 

-Kishore.

 

From: 万欣宇 [mailto:wan_xinyu@...]
Sent: Tuesday, February 12, 2013 10:16 PM
To: Bodke, Kishore K
Subject: BSP of the YoctoProject:Cedartrail

 

Excuse me, Sir kishore.k.bodke

         I'm a user of Intel Atom N2600 and I want to make a embedded Linux using @ my developing board. However, when I use the "Cedartrail" BSP to make a Linux mirror, it prompts me that "Hob cannot build your image".Details see Annex. The mirror type that I selected to build is "core-image-lsb-dev". Could analyse it for me why it connot build my image? Thank you very much.

 

                                                                                                                                                                                                                           PP.Wan

 

 


Re: Avionic Tamonten Board - Uboot problem

Gary Thomas
 

On 2013-02-19 09:02, Satya Swaroop Damarla wrote:
Unfortunately "tec_config" didnot work. Here is the error message
I think you need a newer U-Boot to get the support for this board.
Try
PREFERRED_VERSION_u-boot ?= "v2012.10%"
or even
PREFERRED_VERSION_u-boot ?= "v2013.01%"

Log data follows:
| DEBUG: Executing shell function do_compile
| NOTE: make -j 8 CROSS_COMPILE=arm-poky-linux-gnueabi- CC=arm-poky-linux-gnueabi-gcc --sysroot=/home/build/yocto/poky/buildTamonten/tmp/sysroots/skidata-tamonten tec_config
| make: *** No rule to make target `tec_config'. Stop.
| make: *** [tec_config] Error 1
| ERROR: oe_runmake failed
| ERROR: Function failed: do_compile (see
/home/build/yocto/poky/buildTamonten/tmp/work/skidata_tamonten-poky-linux-gnueabi/u-boot-v2012.04.01+git3+415d386877df49eb051b85ef74fa59a16dc17c7d-r2/temp/log.do_compile.21665 for
further information)
ERROR: Task 69 (/home/build/yocto/poky/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb <http://u-boot_2012.04.01.bb>, do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 3421 tasks of which 319 didn't need to be rerun and 1 failed.




On Tue, Feb 19, 2013 at 3:58 PM, Gary Thomas <gary@mlbassoc.com <mailto:gary@mlbassoc.com>> wrote:

On 2013-02-19 06:28, Satya Swaroop Damarla wrote:

Hi,

I want to build a basic image for the Avionic Tamonten board using Yocto. SO, I created a skidata-tamonten.conf in the list of machines based on the beagleboard.conf but I dont
know what to add for the UBOOT_MACHINE= . I tried my best to use the same "omap_beagle_conf" but it doesnot boot properly. Here is the skidata-tamonten.conf file description


Try 'tec_config'

#@TYPE: Machine
#@NAME: skidata-tamonten machine
#@DESCRIPTION: Machine configuration for the Tamonten board

PREFERRED_PROVIDER_virtual/__xserver ?= "xserver-xorg"
XSERVER ?= "xserver-xorg \
xf86-input-evdev \
xf86-input-mouse \
xf86-video-omapfb \
xf86-input-keyboard"

# Ship all kernel modules by default
MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"

# Allow for MMC booting ()
EXTRA_IMAGEDEPENDS += "u-boot"

# Uncomment the following line to enable the hard floating point abi. Note that
# this breaks some binary libraries and 3D (neither of which ship with
# meta-yocto). For maximum compatibility, leave this disabled.
DEFAULTTUNE ?= "cortexa9thf"
include conf/machine/include/tune-__cortexa9.inc

IMAGE_FSTYPES += "tar.bz2 ext2 ext3"

SERIAL_CONSOLE = "115200 ttyO2"

PREFERRED_PROVIDER_virtual/__kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "3.2%"

KERNEL_IMAGETYPE = "uImage"

PREFERRED_VERSION_u-boot ?= "v2012.04%"

UBOOT_MACHINE = "???????????????????"

UBOOT_ENTRYPOINT = "0x00008000"
UBOOT_LOADADDRESS = "0x00008000"

MACHINE_FEATURES = "usbgadget usbhost vfat alsa screen touchscreen keyboard"


Greetings & Regards,
Swaroop



_________________________________________________
yocto mailing list
yocto@yoctoproject.org <mailto:yocto@yoctoproject.org>
https://lists.yoctoproject.__org/listinfo/yocto <https://lists.yoctoproject.org/listinfo/yocto>


--
------------------------------__------------------------------
Gary Thomas | Consulting for the
MLB Associates | Embedded world
------------------------------__------------------------------
_________________________________________________
yocto mailing list
yocto@yoctoproject.org <mailto:yocto@yoctoproject.org>
https://lists.yoctoproject.__org/listinfo/yocto <https://lists.yoctoproject.org/listinfo/yocto>

--
------------------------------------------------------------
Gary Thomas | Consulting for the
MLB Associates | Embedded world
------------------------------------------------------------


Re: Updated Yocto Hands-on Kernel Lab available

Tom Zanussi <tom.zanussi@...>
 

On Tue, 2013-02-19 at 05:31 -0500, Trevor Woerner wrote:
On Tue, Feb 19, 2013 at 12:31 AM, Tom Zanussi <tom.zanussi@intel.com> wrote:
So when you say it doesn't work, you mean the module autoload didn't
work, but everything else did?
Yes, exactly.

Did you do the 'bump the PR' step after
you uncommmented the module autoload statement?
Yes, I even bumped it twice :-) But even if I forgot to bump the PR
number, when I deleted tmp/sstate/etc and started a fresh build, it
should have worked then?
It really should have, yes.

If that's not it, then I don't know what you say - I tested it with
danny and it worked fine for me. I can try running through it again to
verify again, but it really should work...
Thanks for your comments. I'll guess I'll have to try it all again.
Maybe I somehow checked out the wrong version. Like I said, performing
the same steps against yesterday's master worked completely as
expected.
I'll go through it here as well as soon as I can and let you know...

Tom


Re: Avionic Tamonten Board - Uboot problem

Satya Swaroop Damarla <swaroop.damarla@...>
 

Unfortunately "tec_config" didnot work. Here is the error message

Log data follows:
| DEBUG: Executing shell function do_compile
| NOTE: make -j 8 CROSS_COMPILE=arm-poky-linux-gnueabi- CC=arm-poky-linux-gnueabi-gcc  --sysroot=/home/build/yocto/poky/buildTamonten/tmp/sysroots/skidata-tamonten tec_config
| make: *** No rule to make target `tec_config'.  Stop.
| make: *** [tec_config] Error 1
| ERROR: oe_runmake failed
| ERROR: Function failed: do_compile (see /home/build/yocto/poky/buildTamonten/tmp/work/skidata_tamonten-poky-linux-gnueabi/u-boot-v2012.04.01+git3+415d386877df49eb051b85ef74fa59a16dc17c7d-r2/temp/log.do_compile.21665 for further information)
ERROR: Task 69 (/home/build/yocto/poky/meta/recipes-bsp/u-boot/u-boot_2012.04.01.bb, do_compile) failed with exit code '1'
NOTE: Tasks Summary: Attempted 3421 tasks of which 319 didn't need to be rerun and 1 failed.




On Tue, Feb 19, 2013 at 3:58 PM, Gary Thomas <gary@...> wrote:
On 2013-02-19 06:28, Satya Swaroop Damarla wrote:
Hi,

I want to build a basic image for the Avionic Tamonten board using Yocto. SO, I created a skidata-tamonten.conf in the list of machines based on the beagleboard.conf but I dont
know what to add for the UBOOT_MACHINE= . I tried my best to use the same "omap_beagle_conf" but it doesnot boot properly. Here is the skidata-tamonten.conf file description


Try 'tec_config'

#@TYPE: Machine
#@NAME: skidata-tamonten machine
#@DESCRIPTION: Machine configuration for the Tamonten board

PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
XSERVER ?= "xserver-xorg \
            xf86-input-evdev \
            xf86-input-mouse \
            xf86-video-omapfb \
            xf86-input-keyboard"

# Ship all kernel modules by default
MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"

# Allow for MMC booting ()
EXTRA_IMAGEDEPENDS += "u-boot"

# Uncomment the following line to enable the hard floating point abi. Note that
# this breaks some binary libraries and 3D (neither of which ship with
# meta-yocto). For maximum compatibility, leave this disabled.
DEFAULTTUNE ?= "cortexa9thf"
include conf/machine/include/tune-cortexa9.inc

IMAGE_FSTYPES += "tar.bz2 ext2 ext3"

SERIAL_CONSOLE = "115200 ttyO2"

PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "3.2%"

KERNEL_IMAGETYPE = "uImage"

PREFERRED_VERSION_u-boot ?= "v2012.04%"

UBOOT_MACHINE = "???????????????????"

UBOOT_ENTRYPOINT = "0x00008000"
UBOOT_LOADADDRESS = "0x00008000"

MACHINE_FEATURES = "usbgadget usbhost vfat alsa screen touchscreen keyboard"


Greetings & Regards,
Swaroop



_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto


--
------------------------------------------------------------
Gary Thomas                 |  Consulting for the
MLB Associates              |    Embedded world
------------------------------------------------------------
_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto


FW: Weekly Test Status for Yocto 1.4 20130213 Build

Stoicescu, CorneliuX <corneliux.stoicescu@...>
 

Hello,

 

Here is a real-time status report for the current weekly build: https://wiki.yoctoproject.org/wiki/1.4_QA_Status

 

We are working towards implementing an automated reporting system and this is what we have so far.

 

We analyzed the previous report style and all the information, in one form or another, is contained in this report as well (it might require some digging but we hope that if you know what you are looking for, you can get the information much faster and with much more detail)  

 

Please look around as much as possible and send us some feedback on what more you would like to see, what you think could be changed and anything else that pops up.

 

PS: I am sorry for the previous email, I did not add the link J

 

Thank you for the support,

Stoicescu Corneliu

Romania Yocto QA


Weekly Test Status for Yocto 1.4 20130213 Build

Stoicescu, CorneliuX <corneliux.stoicescu@...>
 

Hello,

 

Here is a real-time status report for the current weekly build. We are working towards implementing an automated reporting system and this is what we have so far.

 

We analyzed the previous report style and all the information, in one form or another, is contained in this report as well (it might require some digging but we hope that if you know what you are looking for, you can get the information much faster and with much more detail)  

 

Please look around as much as possible and send us some feedback on what more you would like to see, what you think could be changed and anything else that pops up.

 

Thank you for the support,

Stoicescu Corneliu

Romania Yocto QA


Re: Avionic Tamonten Board - Uboot problem

Gary Thomas
 

On 2013-02-19 06:28, Satya Swaroop Damarla wrote:
Hi,

I want to build a basic image for the Avionic Tamonten board using Yocto. SO, I created a skidata-tamonten.conf in the list of machines based on the beagleboard.conf but I dont
know what to add for the UBOOT_MACHINE= . I tried my best to use the same "omap_beagle_conf" but it doesnot boot properly. Here is the skidata-tamonten.conf file description
Try 'tec_config'

#@TYPE: Machine
#@NAME: skidata-tamonten machine
#@DESCRIPTION: Machine configuration for the Tamonten board

PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
XSERVER ?= "xserver-xorg \
xf86-input-evdev \
xf86-input-mouse \
xf86-video-omapfb \
xf86-input-keyboard"

# Ship all kernel modules by default
MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"

# Allow for MMC booting ()
EXTRA_IMAGEDEPENDS += "u-boot"

# Uncomment the following line to enable the hard floating point abi. Note that
# this breaks some binary libraries and 3D (neither of which ship with
# meta-yocto). For maximum compatibility, leave this disabled.
DEFAULTTUNE ?= "cortexa9thf"
include conf/machine/include/tune-cortexa9.inc

IMAGE_FSTYPES += "tar.bz2 ext2 ext3"

SERIAL_CONSOLE = "115200 ttyO2"

PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "3.2%"

KERNEL_IMAGETYPE = "uImage"

PREFERRED_VERSION_u-boot ?= "v2012.04%"

UBOOT_MACHINE = "???????????????????"

UBOOT_ENTRYPOINT = "0x00008000"
UBOOT_LOADADDRESS = "0x00008000"

MACHINE_FEATURES = "usbgadget usbhost vfat alsa screen touchscreen keyboard"


Greetings & Regards,
Swaroop



_______________________________________________
yocto mailing list
yocto@yoctoproject.org
https://lists.yoctoproject.org/listinfo/yocto
--
------------------------------------------------------------
Gary Thomas | Consulting for the
MLB Associates | Embedded world
------------------------------------------------------------


Re: [meta-raspberrypi][PATCH 1/7] rpi-default-providers: Remove virtual/libgl provider

Philipp Wagner <lists@...>
 

Hi Andrei,

I applied and tested all 7 patches and they work as the binary firmware did before. Maybe in a later patch a pkgconfig file can be added (I think it was there before, but I'm not using it yet, so I'm not really sure).

I don't like the name "userland" (it's not really describing that we're actually talking about graphics libraries), but that's just a nitpick. Maybe it can be renamed to rpi-graphics-userland or something more descriptive like that?

Philipp

Am 09.02.2013 23:11, schrieb Andrei Gherzan:

There are no libgl binary shipped in raspberrypi firmware repo.

Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
---
conf/machine/include/rpi-default-providers.inc | 1 -
1 file changed, 1 deletion(-)

diff --git a/conf/machine/include/rpi-default-providers.inc b/conf/machine/include/rpi-default-providers.inc
index ce963b3..6abab60 100644
--- a/conf/machine/include/rpi-default-providers.inc
+++ b/conf/machine/include/rpi-default-providers.inc
@@ -4,5 +4,4 @@ PREFERRED_PROVIDER_virtual/kernel = "linux-raspberrypi"
PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
PREFERRED_PROVIDER_virtual/egl ?= "vc-graphics-hardfp"
PREFERRED_PROVIDER_virtual/libgles2 ?= "vc-graphics-hardfp"
-PREFERRED_PROVIDER_virtual/libgl ?= "vc-graphics-hardfp"
PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-raspberrypi"


Re: [meta-raspberrypi][PATCH 1/1] rpi-first-run-wizard: Fix RDEPENDS warning

Philipp Wagner <lists@...>
 

Am 10.02.2013 18:55, schrieb Andrei Gherzan:
WARNING: QA Issue: [...]/rpi-first-run-wizard.bb:
Variable RDEPENDS is set as not being package specific, please fix this.

Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
---
recipes-extra/startup/rpi-first-run-wizard.bb | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/recipes-extra/startup/rpi-first-run-wizard.bb b/recipes-extra/startup/rpi-first-run-wizard.bb
index c5cef7c..6ede56e 100644
--- a/recipes-extra/startup/rpi-first-run-wizard.bb
+++ b/recipes-extra/startup/rpi-first-run-wizard.bb
@@ -3,11 +3,11 @@ LICENSE = "GPLV2"
LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"

DEPENDS = "zenity dbus"
-RDEPENDS = "slim sudo zenity dbus"
+RDEPENDS_${PN} = "slim sudo zenity dbus"

COMPATIBLE_MACHINE = "raspberrypi"

-PR = "r1"
+PR = "r2"

SRC_URI = " \
file://LICENSE \
I've applied this patch and it works as expected.

Philipp


Avionic Tamonten Board - Uboot problem

Satya Swaroop Damarla <swaroop.damarla@...>
 

Hi, 

I want to build a basic image for the Avionic Tamonten board using Yocto. SO, I created a skidata-tamonten.conf in the list of machines based on the beagleboard.conf but I dont know what to add for the UBOOT_MACHINE= . I tried my best to use the same "omap_beagle_conf" but it doesnot boot properly. Here is the skidata-tamonten.conf file description

#@TYPE: Machine
#@NAME: skidata-tamonten machine
#@DESCRIPTION: Machine configuration for the Tamonten board

PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xorg"
XSERVER ?= "xserver-xorg \
           xf86-input-evdev \
           xf86-input-mouse \
           xf86-video-omapfb \
           xf86-input-keyboard"

# Ship all kernel modules by default
MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"

# Allow for MMC booting ()
EXTRA_IMAGEDEPENDS += "u-boot"

# Uncomment the following line to enable the hard floating point abi. Note that
# this breaks some binary libraries and 3D (neither of which ship with
# meta-yocto). For maximum compatibility, leave this disabled.
DEFAULTTUNE ?= "cortexa9thf"
include conf/machine/include/tune-cortexa9.inc

IMAGE_FSTYPES += "tar.bz2 ext2 ext3"

SERIAL_CONSOLE = "115200 ttyO2"

PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
PREFERRED_VERSION_linux-yocto ?= "3.2%"

KERNEL_IMAGETYPE = "uImage"

PREFERRED_VERSION_u-boot ?= "v2012.04%"

UBOOT_MACHINE = "???????????????????"

UBOOT_ENTRYPOINT = "0x00008000"
UBOOT_LOADADDRESS = "0x00008000"

MACHINE_FEATURES = "usbgadget usbhost vfat alsa screen touchscreen keyboard"


Greetings & Regards,
Swaroop


ww07 Yocto Bug Trend

Serban, Laurentiu <laurentiu.serban@...>
 

Hello,

The Yocto Project bug trend was updated for ww07.

https://wiki.yoctoproject.org/wiki/Yocto_Bug_Trend

 

Best regards,

 

Laurentiu Serban

QA Engineer

Open Source Technology Center

System Software Division Romania

Desk: +40 31 8604742

iNET: 88451042

 


Re: [PATCH] Fix oprofileui build with automake-1.13

Ross Burton
 

On 18 February 2013 17:33, Burton, Ross <ross.burton@intel.com> wrote:
On 18 February 2013 17:31, Burton, Ross <ross.burton@intel.com> wrote:
Merged to oprofileui master, thanks.
I lie - I don't have permission to push there. I'll find someone who
either can push or can give me access to push.
Actually pushed now, thanks Marko.

Ross


Re: Updated Yocto Hands-on Kernel Lab available

Trevor Woerner
 

On Tue, Feb 19, 2013 at 12:31 AM, Tom Zanussi <tom.zanussi@intel.com> wrote:
So when you say it doesn't work, you mean the module autoload didn't
work, but everything else did?
Yes, exactly.

Did you do the 'bump the PR' step after
you uncommmented the module autoload statement?
Yes, I even bumped it twice :-) But even if I forgot to bump the PR
number, when I deleted tmp/sstate/etc and started a fresh build, it
should have worked then?

If that's not it, then I don't know what you say - I tested it with
danny and it worked fine for me. I can try running through it again to
verify again, but it really should work...
Thanks for your comments. I'll guess I'll have to try it all again.
Maybe I somehow checked out the wrong version. Like I said, performing
the same steps against yesterday's master worked completely as
expected.


Re: Agenda: Yocto Project Technical Team Meeting - Tuesday, February 19, 2013 8:00 AM-9:00 AM (UTC-08:00) Pacific Time (US & Canada).

Ross Burton
 

On 19 February 2013 04:32, Liu, Song <song.liu@...> wrote:
Agenda:
 
* Opens collection - 5 min (Song)
* Yocto Project 1.3.1 status - 10 min (Ross)

I've got a conflicting meeting so can't attend this call.  The state is that the autobuilder appeared to go well so we'll be passing the output to QA shortly.

Ross


Re: clear hob error

Iorga, Cristian <cristian.iorga@...>
 

Hello Andre,

 

This is not a Hob error, but a bitbake one.

It seems that BBPATH variable is not set properly.

Follow documentation/dev-manual/dev-manual-common-tasks.xml to set it out correctly.

Also, state your version of poky.

There were some changes to the way BBPATH is defined, so it’s important to know the version of poky.

 

Regards,

Cristian

 

Cristian Iorga

Linux Software Engineer

Open Source Technology Center

Intel

 

From: yocto-bounces@... [mailto:yocto-bounces@...] On Behalf Of Andre Bella
Sent: Tuesday, February 19, 2013 4:37 AM
To: yocto@...
Subject: [yocto] clear hob error

 

does anyone know how can I clear up this error, it happen after hob crash, :(