Re: rootfs image size


Tian, Kevin <kevin.tian@...>
 

From: Darren Hart [mailto:dvhart@...]
Sent: Friday, January 28, 2011 6:37 AM

On 01/26/2011 03:58 PM, Tian, Kevin wrote:
From: Chris Tapp
Sent: Wednesday, January 26, 2011 9:09 PM

I know this is probably a basic question, but I'm not having much luck !

I've built poky-image-minimal for atom-pc using the 0.9 Poky release.

This gives me an ext3 rootfs of over 80MB, which doesn't sound minimal
to me ;-)
This is a known issue in 0.9. the switch from ipk to rpm leaves some
temporary files
in the final ext3 rootfs, which results the large size.


Can I reduce the size of the image, or is it expected to be this size?

I've tried changing

IMAGE_ROOTFS_SIZE_ext3 = "500000"
This configuration option only works when it exceeds the size of generated
rootfs,
or else it will be changed implicitly to the actual size plus some extra buffer


in atom-pc.conf to another value, but this didn't make any
difference to the image that gets created (by re-running bitbake poky-
image-minimal after making the above change).

I've also tried using

ROOT_FLASH_SIZE = "64"

also without any luck.

Any help would be much appreciated !
I'd suggest you to use the master to see whether it works for you.

The alternative is to apply below commit to your 0.9 code:

commit 5e384038cbd5035377d61a1b77ad23ab69e0cac0
Author: Richard Purdie<richard.purdie@...>
Date: Wed Jan 5 18:56:47 2011 +0000

rootfs_rpm.bbclass: Remove temporary work files in install directory,
saving work files in install directory, saving the manifests as logfiles into ${T}

Signed-off-by: Richard Purdie<richard.purdie@...>

diff --git a/meta/classes/rootfs_rpm.bbclass
b/meta/classes/rootfs_rpm.bbclass
index 33abe96..2f7d691 100644
--- a/meta/classes/rootfs_rpm.bbclass
+++ b/meta/classes/rootfs_rpm.bbclass
@@ -202,8 +202,11 @@ EOF
# remove lock files
rm -f ${IMAGE_ROOTFS}${rpmlibdir}/__db.*

- # remove resolver files and manifests
- rm -f ${IMAGE_ROOTFS}/install/install.manifest
+ # Move manifests into the directory with the logs
+ mv ${IMAGE_ROOTFS}/install/*.manifest ${T}/
+
+ # Remove all remaining resolver files
+ rm -f ${IMAGE_ROOTFS}/install

This needs to be "rm -rf", there is another patch in master that takes
care of this: 21fafc889e81411735de7d04ffe504e5cff4830d
Thanks for the catch-up. I do remember that you dig it out but not realize related here. :-)

Thanks
Kevin

Join yocto@lists.yoctoproject.org to automatically receive all group messages.