Re: Unable to get serial console login prompt - PowerPC 440 Virtex 5 processor

Elvis Dowson

Hi Khem,
                  I also just tried gcc-4.6.3 and eglibc-2.13, and I get a segmentation fault while running /bin/getty, and a kernel panic when running init=/bin/bash, building off poky/master branch recipes. 

zImage starting: loaded at 0x00800000 (sp: 0x0185dfa0)
Allocating 0x548f0c bytes for kernel ...
gunzipping (0x00000000 <- 0x0080f000:0x00a1563f)...done 0x42b5c0 bytes
Attached initrd image at 0x00a16000-0x0185ce95
initrd head: 0x1f8b0808

Linux/PowerPC load: console=ttyS0,9600n8 ip=off root=/dev/ram rw rootwait init=/bin/sh
Finalizing device tree... flat tree at 0x186a0e0
 PM: Adding info for No Bus:ttyv9
[    0.588026] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
[    0.593401] 83e00000.serial: ttyS0 at MMIO 0x83e01003 (irq = 20) is a 16550
[    0.788848] console [ttyS0] enabled
[    0.834170] brd: module loaded
[    0.880867] loop: module loaded
[    0.918134] xsysace 83600000.sysace: Xilinx SystemACE revision 1.0.12
[    0.994836] xsysace 83600000.sysace: No CF in slot
[    1.053840] Xilinx SystemACE device driver, major=254
[    1.114793] xilinx_emaclite 81000000.ethernet: Device Tree Probing
[    1.188315] xilinx_emaclite 81000000.ethernet: error registering MDIO bus
[    1.269388] xilinx_emaclite 81000000.ethernet: MAC address is now 00:0a:35:b7:78:00
[    1.363146] xilinx_emaclite 81000000.ethernet: Xilinx EmacLite at 0x81000000 mapped to 0xD10A0000, irq=17
[    1.477955] xilinx_ps2 81480000.ps2: Device Tree Probing 'ps2'
[    1.547173] xilinx_ps2 81480000.ps2: Xilinx PS2 at 0x81480000 mapped to 0xd1036000, irq=22
[    1.646551] xilinx_ps2 81481000.ps2: Device Tree Probing 'ps2'
[    1.716251] xilinx_ps2 81481000.ps2: Xilinx PS2 at 0x81481000 mapped to 0xd1038000, irq=23
[    1.816836] mousedev: PS/2 mouse device common for all mice
[    1.884361] i2c /dev entries driver
[    1.925909] Device Tree Probing 'i2c'
[    1.970181] xilinx-iic #0 at 0x81600000 mapped to 0xD10C0000, irq=18
[    2.047926] TCP cubic registered
[    2.085783] NET: Registered protocol family 17
[    2.882898] atkbd serio0: keyboard reset failed on xilinxps2/serio at 81480000
[    3.367192] RAMDISK: gzip image found at block 0
[    3.891097] input: AT Raw Set 2 keyboard as /devices/plb.0/xps-ps2.1/81481000.ps2/serio1/input/input0
[    6.271270] EXT2-fs (ram0): warning: mounting unchecked fs, running e2fsck is recommended
[    6.368556] VFS: Mounted root (ext2 filesystem) on device 1:0.
[    6.439318] Freeing unused kernel memory: 156k freed
/bin/sh: can't access tty; job control turned off
[    6.583032] Kernel panic - not syncing: Attempted to kill init!
[    6.653114] Rebooting in 180 seconds..

So, in summary:

The following combinations didn't work for the poky/master branch
gcc-4.5.1, eglibc-2.15, binutils-2.22
gcc-4.5.1, eglibc-2.16, binutils-2.22
gcc-4.6.3, eglibc-2.13, binutils-2.22
gcc-4.7.2, eglibc-2.13, binutils-2.22

The combinations that worked are
gcc-4.5.1, eglibc-2.13, binutils-2.22 (from poky/master)
gcc-4.6.3, eglibc-2.13, binutils-2.22 (from the Denx ELDK 5.2.1 release, which corresponds to the denzil release)

What would you like me to do next, to try and narrow down this issue? 

Some things that I can try are:

a. build gcc-4.6.3, eglibc-2.13, binutils-2.22 (from poky/denzil branch, to establish a known good build data point)
b. try and build gcc-4.8.0, with eglibc-2.13, binutils-2.22 (I prepare a gcc-4.8 recipe already, but need to try it out)
c. try eglibc-2.13/2.15/2.16 combination with gcc-4.5.1 and binutils-2.22 on a different architecture (e.g. TI OMAP 3530 ARM Cortex A8 Gumstix Overo, TI OMAP 4430 PandaBoard, Xilinx Zynq-7020 Dual ARM Cortex A9)
    just to see if the problem manifests on different architectures as well

Best regards,

Elvis Dowson

Join { to automatically receive all group messages.