Re: Unable to get serial console login prompt - PowerPC 440 Virtex 5 processor

Elvis Dowson


On Aug 14, 2012, at 7:52 AM, Khem Raj wrote:

On Mon, Aug 13, 2012 at 8:24 PM, Elvis Dowson <elvis.dowson@...> wrote:

I tried eglibc-2.13 with the current gcc-4.7 recipe, and that combination doesn't work.

I do know that the Denx ELDK used eglibc-2.13 and the gcc-4.6 recipe. The ELDK
is based off poky/denzil branch. Only the poky/master branch contains the updated
gcc-4.7 & eglibc-2.15 & 2.16 recipes, which are right now broken for powerpc440
soft float.
and how about gcc 4.5 + eglibc 2.16 did you try that ?
I am not yet sure if we have narrowed it down to one component.
Yes, I tried gcc-4.5.1 and eglibc-2.16, it didn't work.

The following combinations didn't work:
gcc-4.5.1, eglibc-2.15, binutils-2.22
gcc-4.5.1, eglibc-2.16, binutils-2.22
gcc-4.7.2, eglibc-2.13, binutils-2.22

The combinations that worked are
gcc-4.5.1, eglibc-2.13, binutils-2.22
gcc-4.6.3, eglibc-2.13, binutils-2.22 (from the Denx ELDK 5.2.1 release.)

I am going to re-verify with the current poky, meta-openembedded/toolchain-layer to ensure that it too builds and works, with gcc-4.6.3 and eglibc-2.13.

We can't narrow it down to one component because
gcc-4.7.1 + eglibc-2.13 doesnt work, and
gcc-4.5.1 + eglibc-2.15 & egblic-2.16 don't work.

We've got two variables here, that are causing a failure in dynamic linking (probably).

Elvis Dowson

Join to automatically receive all group messages.