Re: Unable to get serial console login prompt - PowerPC 440 Virtex 5 processor


Elvis Dowson
 

Hi Khem,

On Aug 13, 2012, at 9:01 PM, Khem Raj wrote:

Success, at last!! :-) I switch to eglib 2.13, and everything works fine!!
The problem was with eglibc 2.16. It is broken for powerpc 440 soft float,
not sure if the same situation manifests for other target architectures as
well.

OK good. Now we should find what broke eglibc. Did you try 2.15 as
well ? Want to make sure how far back it goes.

I tried with eglibc-2.15 and it's broken for PowerPC 440 soft-float.

zImage starting: loaded at 0x00800000 (sp: 0x017e4fa0)                     
Allocating 0x54cf4c bytes for kernel ...                                   
gunzipping (0x00000000 <- 0x0080f000:0x00a1aee0)...done 0x42f600 bytes
Attached initrd image at 0x00a1b000-0x017e33c3
initrd head: 0x1f8b0808

Linux/PowerPC load: console=ttyS0,9600n8 ip=off root=/dev/ram rw rootwait init=/bin/sh
Finalizing device tree... flat tree at 0x17f10e0
 PM: Adding info for No Bus:ttyv9
[    0.582882] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
[    0.588508] 83e00000.serial: ttyS0 at MMIO 0x83e01003 (irq = 20) is a 16550
[    0.784008] console [ttyS0] enabled
[    0.829401] brd: module loaded
[    0.876027] loop: module loaded
[    0.913302] xsysace 83600000.sysace: Xilinx SystemACE revision 1.0.12
[    0.990015] xsysace 83600000.sysace: No CF in slot
[    1.049035] Xilinx SystemACE device driver, major=254
[    1.109979] xilinx_emaclite 81000000.ethernet: Device Tree Probing
[    1.183493] xilinx_emaclite 81000000.ethernet: error registering MDIO bus
[    1.264571] xilinx_emaclite 81000000.ethernet: MAC address is now 00:0a:35:b7:78:00
[    1.358238] xilinx_emaclite 81000000.ethernet: Xilinx EmacLite at 0x81000000 mapped to 0xD10A0000, irq=17
[    1.473224] xilinx_ps2 81480000.ps2: Device Tree Probing 'ps2'
[    1.542456] xilinx_ps2 81480000.ps2: Xilinx PS2 at 0x81480000 mapped to 0xd1036000, irq=22
[    1.641839] xilinx_ps2 81481000.ps2: Device Tree Probing 'ps2'
[    1.711543] xilinx_ps2 81481000.ps2: Xilinx PS2 at 0x81481000 mapped to 0xd1038000, irq=23
[    1.812133] mousedev: PS/2 mouse device common for all mice
[    1.879716] i2c /dev entries driver
[    1.921305] Device Tree Probing 'i2c'
[    1.965584] xilinx-iic #0 at 0x81600000 mapped to 0xD10C0000, irq=18
[    2.043255] TCP cubic registered
[    2.081065] NET: Registered protocol family 17
[    2.875069] atkbd serio0: keyboard reset failed on xilinxps2/serio at 81480000
[    3.359365] RAMDISK: gzip image found at block 0
[    3.883298] input: AT Raw Set 2 keyboard as /devices/plb.0/xps-ps2.1/81481000.ps2/serio1/input/input0
[    6.351431] EXT2-fs (ram0): warning: mounting unchecked fs, running e2fsck is recommended
[    6.448811] VFS: Mounted root (ext2 filesystem) on device 1:0.
[    6.519375] Freeing unused kernel memory: 160k freed


I get no login prompt. Therefore, both eglibc-2.15 and 2.16 are broken for PowerPC. 

At the moment, only eglibc-2.13 works. 

Has anyone else reported issues with getting a boot or login prompt for other 
architectures, like ARM Cortex-A8, etc?

How do you plan on isolating the cause for this issue, for eglibc-2.15?

Best regards,

Elvis Dowson

Join yocto@lists.yoctoproject.org to automatically receive all group messages.