Re: build error pandaboard on master


Jim Abernathy
 

On 07/30/2012 12:57 PM, Gary Thomas wrote:
On 2012-07-30 10:50, Jim Abernathy wrote:
On 07/30/2012 10:21 AM, Gary Thomas wrote:
On 2012-07-30 08:11, Jim Abernathy wrote:
On 07/30/2012 09:56 AM, Gary Thomas wrote:
On 2012-07-30 07:48, Jim Abernathy wrote:
On 07/30/2012 09:15 AM, Gary Thomas wrote:
On 2012-07-30 06:53, Jim Abernathy wrote:
I'm on master branch trying to build core-image-minimal for the machine "pandaboard". Besides the basics, I put in a license statement for cloud9 into local.conf.

My bblayer.conf is as follows:

# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
LCONF_VERSION = "5"

BBPATH = "${TOPDIR}"
BBFILES ?= ""

BBLAYERS ?= " \
/home/jim/poky/meta \
/home/jim/poky/meta-yocto \
/home/jim/meta-openembedded/meta-oe \
/home/jim/meta-ti \
"

The error I'm getting is:

ERROR: ParseError at /home/jim/meta-ti/recipes-misc/payload/bonescript.bb:5: Could not inherit file classes/systemd.bbclass

Build Configuration:
BB_VERSION = "1.15.3"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "pandaboard"
DISTRO = "poky"
DISTRO_VERSION = "1.2+snapshot-20120730"
TUNE_FEATURES = "armv7a vfp neon cortexa9"
TARGET_FPU = "vfp-neon"
meta
meta-yocto = "master:7411158e1f980cd71c432026fa2f68ab80e3541e"
meta-oe = "master:9afc488a1b97bfc5378f139ba04a7a5297b15fdb"
meta-ti = "master:9bc77dff5f84578e259f8225bfa0656d94a2a60a"

ERROR: Nothing PROVIDES 'pseudo-native'
Try adding this in local.conf:
BBMASK ?= ".*/meta-ti/recipes-(misc|bsp/formfactor)/"
BBMASK by itself didn't solve my particular problem. I'll try the other suggestions and report back.
What other problem do you have? That BBMASK should keep bitbake from
trying to parse the recipe mentioned above.

Note: I use these layers with Yocto all the time with that mask...
When I just used the statement:

BBMASK ?= ".*/meta-ti/recipes-(misc|bsp/formfactor)/"

I got the same error as my original post.
The only way you could get that same error is if you already have a BBMASK
statement somewhere and this one is being ignored because of the ?= assignment.
So I started with a clean build again. This time I only added the BBMASK statement you suggested. I got the following error:

ERROR: No recipes available for:
/home/jim/meta-openembedded/meta-systemd/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bbappend
/home/jim/meta-openembedded/meta-systemd/meta-efl/recipes-efl/efl/elsa_svn.bbappend
ERROR: Command execution failed: Exited with 1

I'm guessing the BBMASK needs to call out meta-openembedded/meta-systemd/meta-gnome and meta-efl?
Or don't include those layers - meta-systemd isn't needed by your yocto build.
Thanks, that makes more sense now. I removed the layer meta-systemd from bblayers.conf and used the

BBMASK ?= ".*/meta-ti/recipes-(misc|bsp/formfactor)/"

statement in local.conf to solves the problem.

What is really causing the problem? Without it dependencies on meta-systemd are there, but the mask removes that?? Why can you remove a dependency?

Jim A

Join yocto@lists.yoctoproject.org to automatically receive all group messages.