Re: build error pandaboard on master


Jim Abernathy
 

On 07/30/2012 09:00 AM, Martin Jansa wrote:
On Mon, Jul 30, 2012 at 08:53:50AM -0400, Jim Abernathy wrote:
I'm on master branch trying to build core-image-minimal for the machine
"pandaboard". Besides the basics, I put in a license statement for
cloud9 into local.conf.

My bblayer.conf is as follows:

# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
# changes incompatibly
LCONF_VERSION = "5"

BBPATH = "${TOPDIR}"
BBFILES ?= ""

BBLAYERS ?= " \
/home/jim/poky/meta \
/home/jim/poky/meta-yocto \
/home/jim/meta-openembedded/meta-oe \
/home/jim/meta-ti \
"

The error I'm getting is:

ERROR: ParseError at
/home/jim/meta-ti/recipes-misc/payload/bonescript.bb:5: Could not
inherit file classes/systemd.bbclass
add meta-openembedded/meta-systemd to your BBLAYERS
When I do that I get the errors:

ERROR: No recipes available for:
/home/jim/meta-openembedded/meta-systemd/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bbappend
/home/jim/meta-openembedded/meta-systemd/meta-efl/recipes-efl/efl/elsa_svn.bbappend
ERROR: Command execution failed: Exited with 1

Jim A
Build Configuration:
BB_VERSION = "1.15.3"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "pandaboard"
DISTRO = "poky"
DISTRO_VERSION = "1.2+snapshot-20120730"
TUNE_FEATURES = "armv7a vfp neon cortexa9"
TARGET_FPU = "vfp-neon"
meta
meta-yocto = "master:7411158e1f980cd71c432026fa2f68ab80e3541e"
meta-oe = "master:9afc488a1b97bfc5378f139ba04a7a5297b15fdb"
meta-ti = "master:9bc77dff5f84578e259f8225bfa0656d94a2a60a"

ERROR: Nothing PROVIDES 'pseudo-native'



_______________________________________________
yocto mailing list
yocto@...
https://lists.yoctoproject.org/listinfo/yocto

Join yocto@lists.yoctoproject.org to automatically receive all group messages.