Re: nothing building under denzil-7.0.1

Jim Abernathy

On 07/21/2012 12:06 AM, Tom Zanussi wrote:
On Fri, 2012-07-20 at 16:55 -0500, Tom Zanussi wrote:
On Fri, 2012-07-20 at 15:39 -0500, Tom Zanussi wrote:
On Fri, 2012-07-20 at 16:35 -0400, Jim Abernathy wrote:
On 07/20/2012 04:29 PM, Scott Garman wrote:
On 07/20/2012 01:11 PM, Jim Abernathy wrote:
There must be some basic thing I'm missing. Nothing that I used to
build under denzil 7.0 will now build under denzil 7.0.1 or tracking the
denzil branch. Are all the BSPs required to be updated to 7.0.1 before
you can run?

I'd thought I'd check before I post a bunch of log files.

I just downloaded the poky 7.0.1 tarball and cd'ed to that untarred
directory and untarred the 7.0 Intel BSPs.

There must be a step I'm missing. otherwise this would not have gotten
thru testing before deployment.

Jim A
Hi Jim,

We need more specific information about the error(s) you're seeing.
We've done extensive QA with 7.0.1 and meta-intel, so I imagine there
must be a step you've forgotten.

For example, you are using the denzil branch of meta-intel, right?

I think it maybe that old problem with the n450 SRCREC being blank in
the linux-yocto bbappend file. Obviously that BSP didn't get fixed
before 7.0.1 was deployed. I'll put in the ones I used to patch in and
see if it works.
I updated the n450 in both the denzil and master meta-intel branches,
but the tarball still needs to be updated with that fix.

Is this the problem you're seeing, or are there other problems you're
seeing with this and/or the other meta-intel BSPs?
As a sanity check, I just now downloaded the denzil-7.0.1 tarball and
the denzil sugarbay tarball and built successfully without any problems.
Also did a fresh clone of meta-intel, checked out meta-intel/denzil and
successfully built n450 with the denzil-7.0.1 tarball here with no

I can confirm I had no issues doing just what you did. tarball for denzil-7.0.1 and denzil clone for meta-intel and default core-image-sato for n450.

Next, I cloned poky and checked out the tag denzil-7.0.1, which in theory should match the tarball I ran with in the above test. I cloned meta-intel and checked out the branch denzil, just as above.

So this good news is that worked as expected. The denzil-7.0.1 tag equals the tarball.

So the only problem is the denzil branch of poky has some problem that's seen in denzil-7.0.1 as it relates to n450.

Jim A



Jim A

yocto mailing list
yocto mailing list

Join { to automatically receive all group messages.