Re: Building all packages using the released toolchain

Tian, Kevin <kevin.tian@...>

From: Rick De Laet [mailto:rdelaet@...]
Sent: Thursday, January 13, 2011 11:37 PM

Btw, could you post your errors?
My gcc version is 4.4.4, the latest available from yum update for Fedora 12.
My poky-4.0-build/conf/local.conf is attached.
OK, I remembered that there're a series of patches to make FC14 happy after

So it's better you can try the poky master for your experiment here:

I assume that the way I get the master is with the following command:

git clone git://

or is there an additional option to get the "master" branch? I tried
the above and have the same build error
Poky.git is a repo which contains a bunch of branches. One simple way you can verify
is to use "git branch", and if "*master" is shown then you're using the master branch.

If it still doesn't work for you, it ends up to other issues. I did another round of read on
original fedora 14 mail thread. It looks that your error is a little bit different to that
(yours) ./ld: invalid option -- 'p'
(original) ./ld: unrecognized option '--no-add-needed'

The common point is that elfutils's own ./ld is used which supports less options and thus
Triggers the error. You can look at the bugzilla here:

Wolfgang has "." included in his PATH which is before /bin and /usr/bin. Ideally this
has been fixed by commit 68030f4 (I had a quick test that "." does be warned out in
master branch). Yours looks similar and I'm not sure how local ".ld" is referenced here.
Could you post your PATH variable from your build directory?

BTW, I missed the latter part in your last post, and thus reply here:

Long term what I want to do is build an embedded linux system from scratch
run on our own hardware.

I only found out about yacto today through searching around the Intel EDC
web is the project homepage.

site. We have the Intel Atom based eval board (EG20T) with Tunnel Creek
saw today that this is a newly supported platform in yocto so I was very
Good to know that. :-)

to try it out. I thought it would be best to first try and build a standard
configuration first just to learn the
tool, so short term, yes, I want to build the complete sato image. We
are building our own Intal Atom/ Tunnel Creek embedded platform and on the
surface it looks like yacto is a perfect fit. Trying to decide now if commercial
linux is required or if something like yocto will work.
Yes, Yocto is a perfect choice for your prototype purpose here.

For developing embedded products I like the idea of having an "isolated"
toolchain so I can built a consistent product, regardless of what updates I do
my laptop distribution. So is there a way to configure yocto to use the
/opt/poky toolchain rather than the fedora tools?
For this you can refer to Yocto development manual:

CH5 provides guidance to use /opt/poky toolchain for application development.
However we don't have doc now about using an external toolchain to compile
the whole yocto yet, though it does be supported. The closest info you could
refer to now is the openembedded manual (CH5.5). Could you fill a bug for this
documentation requirement? We'll address that in coming release.

But there may be one confusion I'd like to clarify here. What /opt/poky contains
are a set of cross-toolchains which are used to compile binaries running on the
target machine. For them Fedora doesn't provide. On the other hand, for the
make-native/elfutils-native, which are running on the build host, they have to
be compiled with Fedora toolchains which is the starting point of the whole
yocto build process. :-)


Join to automatically receive all group messages.