Re: RaspberryPi Kernel - Fails to boot when sound driver is a built-in

Paul Eggleton

On Sunday 24 June 2012 21:31:41 Chris Tapp wrote:
On 24 Jun 2012, at 16:25, Paul Eggleton wrote:
Well, FWIW I can't even get a kernel with the default configuration built
from meta-raspberrypi to boot - I even tried copying it to a Debian
SD-card and it doesn't boot there either. All I get is a black screen or
with the newer firmware I get the four-colour display which apparently
indicates it couldn't load the kernel.
1) Are you using the SRCREVs as supplied, or have you updated them?
2) Which version of the bootfiles are you using?

Everything is in such a state of flux at the moment that it does seem to be
difficult to be sure what works one day will work if you upgrade anything
to use the latest versions. I can get some combinations to work, the most
up-to-date being:

1) Use the bootfiles with SRCREV =
"9308c7ed387e5422883753f7fb71a75506abd1f8" 2) Build the kernel using SRCREV
= "3fc65f9f291fb19cad434968a4a0f66ab749e637"
So far I've tried the following:

1) The current default in meta-raspberrypi - bootfiles at
56cd7ffb3f7244017c8eb3b492ea37592c678506 and kernel

2) The above kernel with known-good bootfiles from a Debian SD card

3) The above kernel *on* the known-good Debian SD card

4) Known good kernel with the above bootfiles

5) The combination you suggested above

6) The latest available kernel + bootfiles

Of those, only option 4 sort-of worked.

BTW - you need to update the .conf file for the machine to use ttyAMA0 if
you want to use the serial port for kernel debug.
I did that, however it's not going to be much help as I don't yet have a
serial cable (I have one on order).

I'm beginning to wonder if it's something about the way the kernel is being
built. Are you using denzil or master of Poky?/OE-core?



Paul Eggleton
Intel Open Source Technology Centre

Join { to automatically receive all group messages.