Re: RaspberryPi Kernel - Fails to boot when sound driver is a built-in

Paul Eggleton

On Monday 18 June 2012 22:16:44 Chris Tapp wrote:
If I build the RPi kernel (SRCREV 3fc65f9f291fb19cad434968a4a0f66ab749e637)
then the board boots as expected.

However, if a modify the .config (either manually after -c configure, or by
-c menuconfig) so that CONFIG_SND, CONFIG_SND_TIMER, CONFIG_SND_PCM and
CONFIG_BCM2835 are set to 'y' (i.e. changed from modules) then the kernel
no longer boots.

Has anyone else tried to do this? I'm trying to get a kernel that has ALSA
working out-of-the-box.
Well, FWIW I can't even get a kernel with the default configuration built from
meta-raspberrypi to boot - I even tried copying it to a Debian SD-card and it
doesn't boot there either. All I get is a black screen or with the newer
firmware I get the four-colour display which apparently indicates it couldn't
load the kernel.

Any suggestions would be welcome...



Paul Eggleton
Intel Open Source Technology Centre

Join { to automatically receive all group messages.