Re: basic recipe building - iperf

Jim Abernathy

On Mon, Jun 18, 2012 at 10:40 PM, Khem Raj <raj.khem@...> wrote:

On Monday, June 18, 2012, James Abernathy <jfabernathy@...> wrote:
> On Mon, Jun 18, 2012 at 5:29 PM, jfabernathy <jfabernathy@...> wrote:
>> On 06/18/2012 05:21 PM, Marc Ferland wrote:
>>> jfabernathy<jfabernathy@...>  writes:
>>>>    I needed to do some network performance testing on a Crownbay board and
>>>>    needed iperf in that environment.  Since I had the core-image-sato-sdk
>>>>    image created, I just booted that and took the tarball from Sourceforge
>>>>    and built it  per the readme file instructions:
>>>>    ./configure
>>>>    make
>>>>    make install
>>>>    After I completed my test, I thought about why not put that in my list
>>>>    of personal recipes.  I found the previous version of iperf in the
>>>>    openembedded collection of benchmark recipes and just copied it over.
>>>>    It built and worked fine.  There were a lot of items in the .bb that I
>>>>    didn't understand, so I thought for fun I'd just try to build a recipe
>>>>    for iperf 2.0.5 and see what happened.  My recipe is simple, mostly
>>>>    taken from the openembedded 2.0.4 version had stripped down:
>>> Hi JF,
>>> I add the same problem you had with the man page stuff, try this patch.

>>> Marc
>> thanks, that patch fixed it from a build point of view. now I'll build the image again and see what happens on the hardware.
>> Jim A
> As expected the new image booted and ran the iperf 2.0.5 just fine.  Are there any plans to add this tool to the Yocto project??

You could have just looked into meta-oe/recipes-benchmarks
> Jim A
You must have missed the earlier discussion.  I first got the iperf 2.0.4 from meta-oe, but wanted 2.0.5, so I just added it to my private collection of apps.
Jim A

Join to automatically receive all group messages.