Re: Failing to compile Yocto (acl package)


Tian, Kevin <kevin.tian@...>
 

From: Pedro Sanchez [mailto:psanchez@...]
Sent: Tuesday, December 28, 2010 9:41 AM

On 12/27/2010 08:13 PM, Tian, Kevin wrote:
From: Pedro Sanchez
Sent: Tuesday, December 28, 2010 8:10 AM

On 12/27/2010 05:44 PM, Gary Thomas wrote:
On 12/27/2010 03:21 PM, Pedro Sanchez wrote:
Hello,

I'm trying to compile Yocto from sources as described in the quick
start documentation but the build fails as follows:

$ wget
http://www.yoctoproject.org/downloads/poky/poky-laverne-4.0.tar.bz2
$ tar xjf poky-laverne-4.0.tar.bz2
$ (edited conf/local.conf to select qemuarm)
$ source poky-laverne-4.0/poky-init-build-env poky-4.0-build
$ bitbake poky-image-minimal


... (30 minutes of work)

NOTE: package acl-2.2.49-r0: task do_fetch: Succeeded
NOTE: Running task 582 of 1621 (ID: 1261,
/home/psanchez/Oven/poky-laverne-4.0/meta/recipes-support/attr/acl_2.2.49.bb,
do_unpack)
NOTE: package acl-2.2.49-r0: task do_unpack: Started
NOTE: Unpacking
/home/psanchez/Oven/poky-4.0-build/downloads/acl-2.2.49.src.tar.gz to
/home/psanchez/Oven/poky-4.0-build/tmp/work/armv5te-poky-linux-gnueabi/acl-2.2.49
-r0/

ERROR: Task failed:
NOTE: package acl-2.2.49-r0: task do_unpack: Failed
ERROR: Task 1261
(/home/psanchez/Oven/poky-laverne-4.0/meta/recipes-support/attr/acl_2.2.49.bb,
do_unpack) failed with 1
ERROR:
'/home/psanchez/Oven/poky-laverne-4.0/meta/recipes-support/attr/acl_2.2.49.bb'
failed


I tried compiling the Laverne branch on a cloned Poky git repo. It
also fails when processing the acl package. Any workarounds? Is there
any log file I can look at for more details?
You can find log files in the build directory with a relative
path like .../tmp/work/*/acl*/temp

In particular, look at the log.do_unpack file for clues
Thanks,

This is what I see:

$ cat armv5te-poky-linux-gnueabi/acl-2.2.49-r0/temp/log.do_unpack
gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Exiting with failure status due to previous errors
NOTE: Unpacking
/home/psanchez/Oven/poky-4.0-build/downloads/acl-2.2.49.src.tar.gz to
/home/psanchez/Oven/poky-4.0-build/tmp/work/armv5te-poky-linux-gnueabi/acl-2.2.49
-r0/
ERROR: Task failed:

$ file poky-4.0-build/downloads/acl-2.2.49.src.tar.gz
poky-4.0-build/downloads/acl-2.2.49.src.tar.gz: HTML document text

The mirror where bb is configured to get acl from, mirror.cinquix.com,
is down. I'll try to get it from the Savannah site.
I've sent out the SRC_URI fixes to use correct Savannah site.

BTW, if the mirror site is down, you should still get a correct tar ball from
pre-configured poky mirrors (pokylinux.org, ...). Please let's know if those
mirrors don't take effect to you.

Thanks
Kevin
First of all thank for the quick fix! My laptop is busy building Yocto
now as I write.

As for the poky mirrors, they clearly didn't work for me. The bitbake
command just stopped working when it failed to process the acl package.
As far as I can say no attempts were made to reach any poky mirrors at
all. Is there something we have to do to enable them before compiling
the project?
the mirror is only reached if there's no response from original SRC_URI link.
In your case, the original link does work... which however provides a broken
tar ball. From poky p.o.v, the do_fetch task succeeds and thus no attempt
is made from those mirrors.

If you manually remove acl* from your DL_DIR, you should be able to
observe the mirror effect since now the site is down and no response.
Remember to remove previous download, or else poky will always first
grab from local DL_DIR instead of pulling from external. :-)

Thanks
Kevin

Join yocto@lists.yoctoproject.org to automatically receive all group messages.