Re: build error on core-image-sato-sdk


Jim Abernathy
 

On 04/09/2012 06:15 PM, Darren Hart wrote:

On 04/09/2012 01:33 PM, jfabernathy wrote:
at the end of the build of core-image-sato-sdk I got the following
error. I'm using the edison branch with the latest changes and also
building the meta-cedartrail. I had previously built core-image-sato
successfully with this setup.

Any ideas?

ERROR: Function 'build_boot_bin' failed (see
/build/cdv-edison/tmp/work/cedartrail-poky-linux/core-image-sato-sdk-1.0-r0/temp/log.do_bootimg.25810
for further information)
ERROR: Logfile of failure stored in:
/build/cdv-edison/tmp/work/cedartrail-poky-linux/core-image-sato-sdk-1.0-r0/temp/log.do_bootimg.25810
Log data follows:
| mkdosfs: seek failed
Interesting.

Can you provide the "OE Build Configuration" blob that prints at the
start of the build - I'm mostly interested in your commit IDs for.
OE Build Configuration:
BB_VERSION = "1.13.3"
TARGET_ARCH = "i586"
TARGET_OS = "linux"
MACHINE = "cedartrail"
DISTRO = "poky"
DISTRO_VERSION = "1.1.1"
TUNE_FEATURES = "m32 core2"
TARGET_FPU = ""
meta
meta-yocto = "edison:0fbd6a161576b2cafa8583adde0ffb15347c884a"
meta-cedartrail = "edison:072c6e99616c25c31521e05560433c67fb2a0292"
meta-jfa = "<unknown>:<unknown>"

NOTE: Resolving any missing task queue dependencies
NOTE: Preparing runqueue
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks

Also, please include the HEAD of your poky edison tree.
Not sure what git command you want, but here is the git show:

jim@ubuntu-x64:~/poky$ git show edison
commit 0fbd6a161576b2cafa8583adde0ffb15347c884a
Author: Elizabeth Flanagan <elizabeth.flanagan@...>
Date: Wed Mar 14 15:49:33 2012 -0700

poky.conf: Bumping SKD_VERSION

SDK_VERSION needs a bump for 1.1.1 release

Signed-off-by: Elizabeth Flanagan <elizabeth.flanagan@...>

diff --git a/meta-yocto/conf/distro/poky.conf b/meta-yocto/conf/distro/poky.conf
index b7c167d..accbb26 100644
--- a/meta-yocto/conf/distro/poky.conf
+++ b/meta-yocto/conf/distro/poky.conf
@@ -2,7 +2,7 @@ DISTRO = "poky"
DISTRO_NAME = "Yocto (Built by Poky 6.0.1)"
DISTRO_VERSION = "1.1.1"
SDK_VENDOR = "-pokysdk"
-SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
+SDK_VERSION := "${DISTRO_VERSION}"

MAINTAINER = "Poky <poky@...>"

Thanks,

Join yocto@lists.yoctoproject.org to automatically receive all group messages.