Re: Adding Vulkan to core-image-weston


Alexander Kanavin
 

Next you need to check if you have the mesa-vulkan-drives package in
deploy-* in the same mesa builddir, and does it contain the needed
driver file?

Alex

On Wed, 21 Sept 2022 at 14:48, PHIL <heideggm@...> wrote:

It has the individual packages but split up. One directory for mesa-vulkan-drivers etc. I don't know how to process from here.

Am 21. September 2022 14:38:10 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:

You need to check package-split/ to find out why.

Alex

On Wed, 21 Sept 2022 at 14:30, PHIL <heideggm@...> wrote:


Ok, there is a build directory tmp/work/cortexa57-poky-linux/mesa/2_22.0.0-r0 . In there, there is a package directory that has all libGL* libraries and one libvulkan_virtio.so but they are not installed to the Image.

Am 21. September 2022 14:14:10 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:


This is not logs from mesa, this is logs from your image recipe. You
need to start with mesa.

Alex

On Wed, 21 Sept 2022 at 14:12, PHIL <heideggm@...> wrote:



One of the logs has this



Error:
Problem: package packagegroup-base-extended-1.0-r83.qemuarm64 requires packagegroup-base, but none of the providers can be installed
- package packagegroup-base-1.0-r83.qemuarm64 requires packagegroup-distro-base, but none of the providers can be installed
- conflicting requests
- nothing provides mesa-vulkan-drivers needed by packagegroup-distro-base-1.0-r83.qemuarm64
(try to add '--skip-broken' to skip uninstallable packages)

Am 21. September 2022 13:57:17 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:



You need to go to mesa's build directlory and inspect what is getting
built, with which options, and how it is installed and packaged. All
the needed bits are there, but it does take a bit of 'yocto skill' to
find your way around there. Start by looking at temp/log.do_configure
(and then do_compile and do_install).

Alex

On Wed, 21 Sept 2022 at 13:38, PHIL <heideggm@...> wrote:




If I read the mesa-vulkan-drivers recipe right it should install libvulkan_*.so but it didnt I had to use vulkan-loader. Any idea in how to debug that?

Am 20. September 2022 15:26:45 MESZ schrieb Alexander Kanavin <alex.kanavin@...>:




What often works is running it under strace - you might be able to see the one key syscall that causes the failure. Otherwise you might have to go through the heavier gdb step through.

Alex

On Tue 20. Sep 2022 at 10.25, PHIL <heideggm@...> wrote:




Ok it seems to use Software now given how slow weston-simple-egl has become. But vulkaninfo still fails with ERROR_INCOMPATIBLE_DRIVER.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.



--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.


--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.
--
Diese Nachricht wurde von meinem Android-Gerät mit K-9 Mail gesendet.

Join yocto@lists.yoctoproject.org to automatically receive all group messages.