How to add INCOMPATIBLE_LICENSE only for one image? #bitbake #dunfell


Priyanshu Sharma
 

Hi,
 
I've two image recipes (foo.bb & bar.bb). I want to add INCOMPATIBLE_LICENSE="GPLv3" only in foo.bb & not bar.bb

Adding INCOMPATIBLE_LICENSE="GPLv3" in local.conf is applying it on both the images. So I tried this instead,

INCOMPATIBLE_LICENSE_pn-foo="GPLv3"
 
But this also isn't working. Is there any other way for this?
NOTE : The recipes are image recipes, not packages
 
Cheers,
Priyanshu Sharma

Join yocto@lists.yoctoproject.org to automatically receive all group messages.