Re: [PATCH] zephyr-kernel-src: bump the v3 version to v3.1.0


Bartosz Golaszewski
 

On Mon, Jul 25, 2022 at 11:46 PM Jon Mason <jdmason@...> wrote:

On Mon, Jul 25, 2022 at 05:47:44PM +0200, Bartosz Golaszewski wrote:
From: Bartosz Golaszewski <bartosz.golaszewski@...>

This upgrades the 3.x series to using v3.1.0.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@...>
With this patch, I'm seeing:

WARNING: interrupt-3.1.0+gitAUTOINC+2ddd73feaf_5f86244bad-r0 do_patch: Fuzz detected:
Applying patch 0001-cmake-add-yocto-toolchain.patch
patching file cmake/compiler/gcc/target.cmake
Hunk #1 succeeded at 94 with fuzz 1 (offset 26 lines).
patching file cmake/toolchain/yocto/generic.cmake
patching file cmake/toolchain/yocto/target.cmake
The context lines in the patches can be updated with devtool:
devtool modify interrupt
devtool finish --force-patch-refresh interrupt <layer_path>

And similar errors for all the other tests. You can see them all at
https://gitlab.com/jonmason00/meta-zephyr/-/pipelines/596452936

It should be a trival rebase and everything will be happy. Aside from
this, it looks like all the tests are passing.

Thanks,
Jon
Actually it required two versions of this patch as we're still supporting v2.7.

Bart

Join yocto@lists.yoctoproject.org to automatically receive all group messages.