Re: Specified SDKMACHINE value is not valid


Khem Raj
 

On Fri, Apr 1, 2022 at 2:02 PM jchludzinski <jchludzinski@...> wrote:

But obviously commented out.

On 2022-04-01 16:43, jchludzinski via lists.yoctoproject.org wrote:
There's this:
#SDKMACHINE ?= "i686"
OK it should be ok then. Can you describe your steps to setup the system?
maybe there is some caveat


---John

On 2022-04-01 16:22, Khem Raj wrote:

On Fri, Apr 1, 2022 at 1:09 PM jchludzinski via
lists.yoctoproject.org
[1 [1]] <jchludzinski=vivaldi.net@...> wrote:

I'm trying an experiment building yocto/OE on a Raspberry Pi 4 to
host on the same RP4. Admittedly, a not practical platform for
this
purpose but it should work.

I'm trying to target the ARM ISA for the image using yocto-3.4.2.
I've tried simply using the default setting and end up with:

_ERROR: OE-core's config sanity checker detected a potential
misconfiguration._
_ Either fix the cause of this error or at your own risk
disable
the checker (see sanity.conf)._
_ Following is the list of potential problems / advisories:_
_ _
_ Specified SDKMACHINE value is not valid_

I've tried editing ./conf/local.conf:

MACHINE ?= "qemuarm64"

#MACHINE ??= "qemux86-64"
It's complaining about SDKMACHINE setting which is a separate
variable, can you check your local.conf if it's set to something

But this accomplishes nothing. Needless to say, I'm a yacto/OE
newbie, so any suggestions would be greatly appreciated.

---John
Links:
------
[1] http://lists.yoctoproject.org

Links:
------
[1] http://lists.yoctoproject.org

Join yocto@lists.yoctoproject.org to automatically receive all group messages.