[meta-cgl][PATCH] libsocket6-perl: set precise BSD license


Yu, Mingli
 

From: Mingli Yu <mingli.yu@...>

"BSD" is ambiguous, use the precise license BSD-3-Clause to fix
the below warning:
WARNING: libsocket6-perl-0.29-r2 do_populate_lic: QA Issue: libsocket6-perl: No generic license file exists for: BSD in any provider [license-exists]

Signed-off-by: Mingli Yu <mingli.yu@...>
---
meta-cgl-common/recipes-perl/perl/libsocket6-perl_0.29.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta-cgl-common/recipes-perl/perl/libsocket6-perl_0.29.bb b/meta-cgl-common/recipes-perl/perl/libsocket6-perl_0.29.bb
index 9f38380..004efe2 100644
--- a/meta-cgl-common/recipes-perl/perl/libsocket6-perl_0.29.bb
+++ b/meta-cgl-common/recipes-perl/perl/libsocket6-perl_0.29.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Perl extensions for IPv6"
HOMEPAGE = "https://metacpan.org/release/Socket6"
SECTION = "libs"
-LICENSE = "BSD"
+LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://README;beginline=43;md5=b2bfcdf2de2e951c8e4ed544e942d8e1"
PR = "r2"

--
2.25.1

Join yocto@lists.yoctoproject.org to automatically receive all group messages.