[meta-gplv2] [PATCH 1/2] disable-gplv3: Remove ptest from DISTRO_FEATURES


Richard Purdie
 

There are ptest dependencies which don't have coverage from gplv2 components
so disable ptests for meta-gplv2 usage.

Signed-off-by: Richard Purdie <richard.purdie@...>
---
conf/distro/include/disable-gplv3.inc | 1 +
1 file changed, 1 insertion(+)

diff --git a/conf/distro/include/disable-gplv3.inc b/conf/distro/include/disable-gplv3.inc
index 5d948cc..27cdba2 100644
--- a/conf/distro/include/disable-gplv3.inc
+++ b/conf/distro/include/disable-gplv3.inc
@@ -1,3 +1,4 @@
INCOMPATIBLE_LICENSE = '*GPLv3*'
WARN_QA:remove = 'incompatible-license'
RDEPENDS:${PN}-ptest:remove:pn-glib-2.0 = "python3-dbusmock"
+DISTRO_FEATURES:remove = "ptest"
--
2.32.0

Join yocto@lists.yoctoproject.org to automatically receive all group messages.