[meta-security][PATCH 2/3] chipsec: fix WARNING


Armin Kuster
 

distutils3.bbclass is deprecated, please use setuptools3.bbclass instead

Signed-off-by: Armin Kuster <akuster808@...>
---
recipes-security/chipsec/chipsec_git.bb | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/recipes-security/chipsec/chipsec_git.bb b/recipes-security/chipsec/chipsec_git.bb
index e265a08..156be09 100644
--- a/recipes-security/chipsec/chipsec_git.bb
+++ b/recipes-security/chipsec/chipsec_git.bb
@@ -20,7 +20,7 @@ EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
DEPENDS = "virtual/kernel nasm-native python3-setuptools-native"
RDEPENDS:${PN} += "python3 python3-modules"

-inherit module distutils3
+inherit module setuptools3

do_compile:append() {
cd ${S}/drivers/linux
--
2.25.1

Join yocto@lists.yoctoproject.org to automatically receive all group messages.