Re: Problems building eSDK: Exception: variable BBFILES references itself!


Richard Purdie
 

On Wed, 2022-02-09 at 16:51 +0000, Bryan Evenson wrote:
All,

I've used the SDK in the past and want to start using the eSDK for my project.
I'm on the dunfell branch. I'm trying to build the eSDK for my image by
calling:

bitbake <my_image_name> -c populate_sdk_ext

The sdk generation fails with the error in the subject. I haven't been able
to find any documentation on what this means or how to fix it. I've tried
deleting my tmp directory and running cleansstate on my image and I still get
the same error. I've also tried generating the eSDK for core-image-minimal
and I have the same error. I can generate the SDK successfully, just not the
eSDK. I have copied more of the build output below if it helps. Note that I
have replaced some text that I'm paranoid about publishing on the internet;
the modified text is enclosed with <>.

Does anyone have any insight as to why the eSDK build is failing?
Could you share what bitbake -e shows BBFILES as being set to? The variable
history from that command for the variable may also be helpful. 

There has to be something different to how you're setting it compared to what we
test on the autobuilder.

Cheers,

Richard

Join yocto@lists.yoctoproject.org to automatically receive all group messages.