Re: Maintaining ABI Compatibility for LTS branch


Ross Burton <ross@...>
 

On Tue, 8 Feb 2022 at 23:07, Richard Purdie
<richard.purdie@...> wrote:
I was curious about how everyone is approaching this problem.
There was some attempt to bring ABI checking functionality in the past
but this has never been merged.

Is everyone rolling their own solution? or never moving forward?
Relatedly, somewhere I have a branch that uses libabigail to extract
the library ABIs in an build. The next step was doing the comparison,
but I never got that far. I wouldn't be surprised if someone has done
the same but actually finished the effort.

Ross

Join yocto@lists.yoctoproject.org to automatically receive all group messages.