Re: [oe] [OE-core] Inclusive Language Proposal for YP/OE


Enrico Scholz
 

Bryan Evenson <bevenson@...> writes:

For BB_DISKMON_DIRS, the actions "ABORT, STOPTASKS and WARN"
would become "HALT, NO_NEW_TASKS and "WARN".
I am not an native english speaker, but for "HALT" I will have to
think twice whether it will pause the operation or abort it. I would
stay at "ABORT" because it makes much more clear what happens.
Would CANCEL be clearer to you than HALT?
mmmh.... for me as a developer (and non-native english speaker), "cancel"
means some ordered ending of an operation.

But the condition above causes an emergency abort.

I do not know how this can be described without using "abort" or some
extensively long terms.


BB_HASHCONFIG_WHITELIST -> BB_HASHCONFIG_IGNORE_VARS
BB_SETSCENE_ENFORCE_WHITELIST -> BB_SETSCENE_ENFORCE_IGNORE_TASKS
BB_HASHBASE_WHITELIST -> BB_BASEHASH_IGNORE_VARS
MULTI_PROVIDER_WHITELIST -> BB_MULTI_PROVIDER_ALLOWED
The new variable names sound like boolean flags, not like lists.
Would BB_HASHCONFIG_IGNORELIST or BB_HASHCONFIG_ALLOWEDLIST make more
sense to you?
yes; it is much better. But should it be an "IGNORELIST" or an
"IGNORE*D*LIST"?



Enrico
[who is irritated how people and especially developer can waste their
(and other developers) time in trying to change something which was
completely fine before]

Join yocto@lists.yoctoproject.org to automatically receive all group messages.