#yocto #sdk Bitbake populate_sdk not pulling the correct dependencies. #yocto #sdk


Jeffrey Simons
 

Hi Yocto Devs,

I have this issue when I want to generate a SDK for our custom distro. We require the use of debian package due to historic reasons so the package management has been enabled,
where the package class is package_deb. Now I get a lot of dependency errors from APT when generating the SDK.

I will not place the complete list here due to it's length but I got the following:

-- The following packages have unmet dependencies:
bzip2-dev : Depends: bzip2 (= 1.0.8-r0) but it is not going to be installed
Recommends: libbz2-dev but it is not installable
Recommends: update-alternatives-opkg-dev but it is not installable
curl-dev : Depends: curl (= 7.75.0-r0) but it is not going to be installed
Recommends: libcurl-dev but it is not installable
e2fsprogs-dev : Depends: e2fsprogs (= 1.46.1-r0) but it is not going to be installed
Depends: libss
Recommends: attr-dev but it is not going to be installed
Recommends: autoconf-archive-dev but it is not installable
Recommends: e2fsprogs-badblocks-dev but it is not installable
Recommends: e2fsprogs-dumpe2fs-dev but it is not installable
Recommends: libcomerr-dev but it is not installable
Recommends: libe2p-dev but it is not installable
Recommends: libext2fs-dev but it is not installable
Recommends: libss-dev but it is not installable
Recommends: update-alternatives-opkg-dev but it is not installable
libgmp-dev : Depends: libgmpxx
Recommends: libgmpxx-dev but it is not installable
libgnutls-dev : Depends: gnutls-openssl
Depends: gnutls-xx
Recommends: gnutls-openssl-dev but it is not installable
Recommends: gnutls-xx-dev but it is not installable
mosquitto-dev : Depends: libmosquittopp1 but it is not going to be installed
Recommends: libcrypto-dev but it is not installable
Recommends: libmosquitto1-dev but it is not installable
Recommends: libmosquittopp1-dev but it is not installable
Recommends: libssl-dev but it is not installable
Recommends: libsystemd-dev but it is not installable
Recommends: shadow-sysroot-dev but it is not installable
Recommends: uthash-dev but it is not going to be installed
<A lot more items here.>
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

If I add the depending packages as a IMAGE_INSTALL_append then it seem to be resolved, but still the mossquitto-dev or curl-dev package is still not present within the SDK sysroots environment.
That leads me to think that I did something wrong or something is broken?

I found on the internet some pointer to remove the package_deb for the SDK generation (so it will fallback to package_rpm), but that increases the build times significantly (which is not desirable).

Can anyone give me some pointers into resolving this behavior?

With kind regards,

Jeffrey Simons

Software Engineer
Royal Boon Edam International B.V.

Join yocto@lists.yoctoproject.org to automatically receive all group messages.