Re: rebuilding perf fails after cleanall


chuck kamas
 

Bruce,


I am running a 8 month old version of poky Dunfell, commit e32d854e. I can see the code in perf.bb where it copies over the kernel code to its directory, so I think that I have the patch you mentioned. I have been trying for the past few hours to reproduce the issue in the x86 poky build, and have not come up with the magic method.  I'll keep on trying to simplify the issue to be replaceable in the version I am using and the latest dunfell.


Chuck


On 10/22/21 10:57 AM, Bruce Ashfield wrote:
On Fri, Oct 22, 2021 at 1:23 PM chuck kamas via lists.yoctoproject.org
<chuckkamas=yahoo.com@...> wrote:
Hi all,


I am trying to model a new recipe off of perf.bb to compile the usbip
helper kernel code. I have been having issues with the
work-shared/../kernel-source directory being empty, so I went back to
the perf recipie and tried:

bitbake perf -c cleanall

bitbake perf

What release are you using ? We did have some issues with this in the
past, but they should all be accounted for now.

I can bitbake perf, bitbake -c cleanall perf; bitbake perf

perf makes a copy of the kernel-sharel tools directory (it didn't in
the past), so
it should be safe for any combinations like that.

Bruce

I get the same error about path does not exist and the work-shared
kernel-source directory being empty.


Is perf.bb only executable in the context of a global rebuild?


Chuck








--
- Thou shalt not follow the NULL pointer, for chaos and madness await
thee at its end
- "Use the force Harry" - Gandalf, Star Trek II



Join yocto@lists.yoctoproject.org to automatically receive all group messages.