Re: Enabling tk for Python tkinter module


Tim Orling
 



On Tue, Sep 28, 2021 at 2:58 PM Chris Tapp <opensource@...> wrote:
I am trying to get PySimpleGUI running on an RPi4 using meta-raspberrypi with hardknott.

I have created a recipe for PySimpleGUI and added the following to my local.conf:

PACKAGECONFIG_pn-python3 = “tk”
IMAGE_INSTALL_append = " python3 python3-modules python3-pysimplegui tk"

However, the tkinter module fails to load, reporting “No module named _tkinter”, with a note above saying that Python may not be configured for Tk.

Looking on the target, /usr/lib/libtk.8.so is present.

It looks as if there is something else I need to do to get Python to build correctly, but I’m out of ideas ;-)

You need to add “tk” to the package config for python3

Add the following to your distro|site|local.conf (or a python3_%.bbappend)

PACKAGECONFIG:append:pn-python3 = “ tk”

( replace : with _ if you are on old release that doesn’t support the new override syntax)

(This assumes you have meta-oe in your bblayers.conf so you can build tk, which it sounds like you do)

This is because the _tkinter .so built by python3 is dynamically loaded only if present 
—Tim “moto-timo” Orling


I’ve found a few bits on the internet that seem related, but they haven’t helped me get things going:
 https://www.mail-archive.com/yocto@.../msg18232.html
 https://www.yoctoproject.org/pipermail/yocto/2014-July/020547.html

Any pointers on where to look would be appreciated.

--

Chris Tapp
opensource@...
www.keylevel.com




Join yocto@lists.yoctoproject.org to automatically receive all group messages.