[meta-gplv2] [PATCH 1/2] layer.conf: Set elfutils version correctly


Richard Purdie
 

We need to set PREFERRED_VERSION for elfutils or the wrong one will be used.

Signed-off-by: Richard Purdie <richard.purdie@...>
---
conf/layer.conf | 1 +
1 file changed, 1 insertion(+)

diff --git a/conf/layer.conf b/conf/layer.conf
index 3abe6b5..b0915d4 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -18,5 +18,6 @@ LAYERSERIES_COMPAT_gplv2 = "honister"

LICENSE_PATH += "${LAYERDIR}/licenses"

+PREFERRED_VERSION_elfutils = "${@['', '0.148']['GPLV3' in (d.getVar('INCOMPATIBLE_LICENSE') or '').upper()]}"
PREFERRED_VERSION_shared-mime-info = "${@['', '1.10']['GPLV3' in (d.getVar('INCOMPATIBLE_LICENSE') or '').upper()]}"
PREFERRED_VERSION_shared-mime-info-native = "${@['', '1.10']['GPLV3' in (d.getVar('INCOMPATIBLE_LICENSE') or '').upper()]}"
--
2.32.0

Join yocto@lists.yoctoproject.org to automatically receive all group messages.