Re: Cannot build yocto anymore after updating all layers to current dunfell branch tips


Steve Sakoman
 

On Sat, Aug 14, 2021 at 2:29 AM Manuel Wagesreither <ManWag@fastmail.fm> wrote:

Am Fr, 13. Aug 2021, um 23:59, schrieb Steve Sakoman:
On Fri, Aug 13, 2021 at 11:29 AM Manuel Wagesreither <ManWag@fastmail.fm> wrote:

Hello all,

I updated the layers of my project to the current dunfell branch tips. See here: https://gitlab.com/manuel_wagesreither/bora-proj/-/commit/de631634d7556987d2551d0cedca8f67530bc78d

Since then, the build is failing with the following message:
```
ERROR: ParseError at /home/manuel/bora-proj/meta-openembedded/meta-oe/conf/layer.conf:104: unparsed line: 'DEFAULT_TEST_SUITES:pn-meta-oe-ptest-image = " ${PTESTTESTSUITE}"'
```

Indeed this line, and even more the one after look strange.
https://github.com/openembedded/meta-openembedded/blob/master/meta-oe/conf/layer.conf#L104
Note that you are using the master branch of meta-oe ^^^^^^^^

If you use the dunfell branch you won't have this issue.

Steve
I feel like an idiot right now. Thank you! With dunfell it builds indeed.
We've all done this sort of thing :-)


Now I have to deal with the following:
```
ERROR: Layer multimedia-layer is not compatible with the core layer which only supports these series: dunfell (layer is compatible with honister)
Looks like another case of the layer's master/honister branch instead
of dunfell.

Steve

I guess I'll have to analyze the layers .conf file to see where that comes from.

Thanks, Manuel

Join yocto@lists.yoctoproject.org to automatically receive all group messages.